cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8188
Views
5
Helpful
22
Replies

Cisco 7962 Corporate Directory - not working says to Contact Administrator

ereyno001
Enthusiast
Enthusiast

I recently bought 350 Cisco 7962s for UCM 7.X of those 350 about 100 of them I cannot access our corporate directory. I get an error saying to contact the administrator.

I have tried to do the factory reset; there are no Config differences between the phones that work and the phones that do not work, Same Firmware, Same Subnet, and same UCM Config, I know this for sure as I used the same bulk template for them all.

Just wanted to see if anyone else has seen this, our next step is to update the firmware but I did not want to do firmware updates during our busy season in case that causing any other issuers.

Thanks,


Ed

22 REPLIES 22

some new info...

Before the Firmware upgrade, after pressing Corporate Directory, we got a message saying to conatct Administrator.

After the upgrade, its just a blank screen that says unknown host.

I did the wireshark and I am looking at that now... I do not see where I can upload them.

Do a normal reply and just above the HTML tag in the top right is "Use advanced editor"

Click that and at the bottom is an Attach Files box

Graham

just a thought, but under the phone config in cucm admin, set the directories services to external.

Sent from Cisco Technical Support iPad App

I have attached the Wireshark..

I am going to test the extenal directory idea...good thought.

The phone is not making any attempt to access CUCM for the directory XML.

Please try the following.

Login to Call Manager and select "Cisco Unified Serviceability"

Select Tools/Control Center - Feature Services, select the publisher IP address.

Under CM services restart the Cisco Tftp service. After it has restarted wait two minuets, reset one of your problem 7942 phones and see what happens.

If it still fails do a Fcatory Reset on the phone and try again.

If it still fails I want you to download the phone cnf file and post it to the forum.

On any PC open a cmd window, do a cd to a sutable directory, then enter

tftp 10.10.66.34 get SEPE80462127D04.cnf.xml.sgn

and post the resulting SEPE80462127D04.cnf.xml.sgn file

Graham

Wanted to provide an update... This is still not working but I believe I found what may be the issue, just not sure why. Perhaps a new bug. ... But hopefully this may save someone a lot of frustration

  • After the firmware update, I now get Host not found when pressing the corporate directory, no longer says to contact administrator.
  • Running wireshark says the phone did not even try to go to the corporate directory, like Graham noted above.
  • I can get to the URL from the PC the phone is connected too and if I swap with a 7960 or 40 it works.
  • I have also tried everything from this post,,, just to rule out all things. 

To narrow things down a bit, I created a test Device Pool, test Region, and test MRGL, Etc.. and moved a few test phones into it. I edited one thing at a time editing; the MRGL, Region, Date and Time made no difference still no corporate directory on the 7962s, but the 7940s and 7960s still worked.

When I disabled the SRST Reference in the test device pool, the corporate directory started working on the 7962s and it still works on the 7940s and 7960s. however when I re-enable it only the 7940s and 7960s corporate directory works… the 7962s does not and says “Host Not Found”.  I am still digging through all the logs myself but this totally makes no since which is why I think it is a new bug.

I have summed this up for TAC with a TON of logs from the phone to back this up. Hopefully we will be able to move forward with this soon.

Any other thoughts let me know but I will post the resolution once I have it… hopefully this week.

Ed

RESOLVED!!!!

Finally we have this fixed, Apparently the 7962s use DNS for some of the backend functions where the 7940s and 7960s do not. Per TAC, this may still be a bug, as there was no clear explanation to why, we have about 1000 phones and have not needed to do this before the 7962s.

The Fix was simply adding DNS to the DHCP router so the phones would get the DNS setting.  

Just glad it is fixed.

Thanks all.

Hi Ed,

Thanks for confirming the issue.

I saw your case within TAC DB.

Since the 7960 Phones are working with the DNS enabled, could you send us those sniffers(working)?

It will help me to raise a bug with the development team and help other customer's too. Really intresting to know why these model phones need DNS!

Looking forward for a reply.

Thanks.

---

Regrads,

DJ

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: