cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1216
Views
5
Helpful
8
Replies

[Cisco CME] no ringback when call transfer

kamil_folga
Beginner
Beginner

 

Hi,

 

 

I have Cisco CME 11.5

 

Scenario:

  1. External caller (from SIP TRUNK) calls phone A. Ringback is OK.
  2. Then the call is transfered (full-consult) to phone B
  3. Phone B is ringing but the external caller is not hearing a ringback tone.

Any suggestions on this?

 

 SIP -> CME 11.5 -> Phone A (6945) -> Phone B (6945)

 

  Thanks in advance,

 

Kamil

 

1 Accepted Solution

Accepted Solutions

Yup. I suspected that. You are running into the following -
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvb00288/?reffering_site=dumpcr

Upgrade and that should fix the issue. Don't worry about it saying blind transfer. Your situation applies as well.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"

View solution in original post

8 Replies 8

kamil_folga
Beginner
Beginner

My config:

 

!
ip dhcp pool VOICE
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 option 150 ip 192.168.0.1
!
!
!
!
!
voice-card 0
!
!
!
voice service voip
 ip address trusted list
  ipv4 xx.xx.xx.xx
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  early-offer forced
  midcall-signaling passthru
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^.*/ /222/
!
!
voice translation-profile IN
translate called 1
!
!
!
!
application
 service aa flash:its-CISCO.2.0.3.0.tcl
  paramspace english index 0
  paramspace english language en
  param operator 101
  paramspace english location flash:
  paramspace english prefix en
  param aa-pilot 222
 !
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
!

!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
!
!
!
!
dial-peer voice 222 voip
 service aa
 destination-pattern 222
 progress_ind setup enable 3
 progress_ind progress enable 8
 session target ipv4:192.168.0.1
 incoming called-number 222
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 199 voip
 destination-pattern 6........
 session protocol sipv2
 session target dns:sip.xxx.pl
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 198 voip
 translation-profile incoming IN
 session protocol sipv2
 session target dns:sip.xxx.pl
 incoming called-number .%
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
!
sip-ua
 credentials username xxx password 7 0fewfewfewfewfew8 realm dns:sip.xxx.pl
 authentication username xxx password 7 ffewfewfewfewfew
 registrar dns:sip.xxx.pl expires 900 auth-realm xxx
 sip-server dns:sip.xxx.pl
!
!
!
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.0.1 port 2000
 cnf-file location flash:
 cnf-file perphone
 max-conferences 8 gain -6
 moh enable-g711 "en_bacd_music_on_hold.au"
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
 number 101
!
!
ephone-dn  2  dual-line
 number 102
!
!
ephone-dn  3  dual-line
 number 103
!
!
!
ephone  1
 mac-address C414.3C8B.A5EA
 type 6945
 button  1:3
!
!
!
ephone  3
 mac-address 0C27.24BB.E554
 type 6945
 button  1:1
!
!
!
ephone  4
 mac-address 0C27.24BA.D598
 type 6945
 button  1:2
!

Nipun Singh Raghav
Cisco Employee
Cisco Employee
What is the behavior with blind or semi-consult ?

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"

Thanks for reply...

 

full-blind - call disconnected after transfer
full-consult dss - call transfered but no ringtone for caller

 

Best regards,

Kamil

 

So you are doing a semi-consult ? By that I mean, Phone A receives a call, does a transfer to Phone B but has not answered. The transfer is completed and there is no ring back while Phone B is ringing ? Can you confirm this please ?
Also, what is the IOS ?

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"

Yes, transfer is completed and there is no ring back while Phone B is ringing.

 

Cisco IOS Software, C2951 Software (C2951-UNIVERSALK9-M), Version 15.6(3)M, RELEASE SOFTWARE (fc1)

Yup. I suspected that. You are running into the following -
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvb00288/?reffering_site=dumpcr

Upgrade and that should fix the issue. Don't worry about it saying blind transfer. Your situation applies as well.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"

Thanks. I will try upgrade in Wed and reply soon. 

 

Best regards,

 

Kamil

 

Thanks :) It`s works :)
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers