Showing results for 
Search instead for 
Did you mean: 

Cisco CP7911 date time not updating from NTP server SIP SIP11.9-4-2SR3-1S


Hello everyone,


I have a bizzare problem with a Cisco CP7911 running SIP firmware SIP11.9-4-2SR3-1S. After updating, these phones are stuck in 2008 and don't update their date/time. I have tried several different Timezone settings and a couple NTP servers. The configuration below works fine on other phones.


One person suggested it was lack of the tc-sip.jar file, which I procured and put in the tftproot, but that did not solve it. I have removed LOCALE configuration from the SEP.XML file but still no go.


Here is my SEP file

         <timeZone>SA Eastern Standard Time</timeZone>
               <!-- SERVIDOR DE DATA e HORA - não altere  -->
            <member priority="0">



         <line button="1">



This is not only annoying but it seems to be affecting the SIP registration for the LINE 1 configuration, since it hits the server with a date in the past and the server throws an error. I am not sure if that is the cause of it not registering, but this is driving me crazy.


Any help is greatly appreciated.


Thank you


4 Replies 4

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend
Time and date won't update because the phone hasn't join the Asterisk server.

Thank you for the reply. That is definitely a reason, but then I have not been able to register this device's extension and I assumed it was due to sending the wrong date and time when registering, but I will look at that now and see how to make it register and see if then the date/time updates. I can post the Asterisk logs if you think you might know what is going on. Same XML file works for 3905 devices on the same server.


The error I am getting on registration attempts is 401 Unauthorized. The password and username are correct, I have triple-checked. The only thing I saw in the logs is that the date/time is in 2008 so I thought that could be the reason the extension does not register.


This is part of the log I see on the server. I can't figure out why it is not registering. ANy ideas are welcome.



Thanks again


I have solved the problem. It was a firmware version issue. These CP7911s don't do well with 9.x version firmware from what I noticed. I downgraded to SIP11.8-5-4S and it updated date and time immediately, even without registering.


Now I am facing problems with registration. The server says it is getting there and trying to register but it won't register. In the phone logs, I see some clues:

1021: ERR 21:43:52.604477 JVM: sip_regmgr_setup_cc_conns: CCM invalid/Not configured for DN <1> CCM <1>
1022: ERR 21:43:52.605179 JVM: sip_regmgr_setup_cc_conns: CCM invalid/Not configured for DN <1> CCM <2>
1023: ERR 21:43:52.605756 JVM: sip_regmgr_setup_cc_conns: CCM invalid/Not configured for DN <1> CCM <3>
1024: ERR 21:43:52.606335 JVM: sip_regmgr_setup_cc_conns: NO VALID STANDBY CALL CONTROL AVAILABLE!
1025: NOT 21:43:52.626697 JVM: IPC Msg Tx failure from SIP Debug Service - No IPC connection
1026: NOT 21:43:52.599931 TFTP: [12]:Requesting dialplan.xml from with size limit of 550001
1027: NOT 21:43:52.928194 TFTP: [12]:Finished --> rcvd 478 bytes
1028: NOT 21:43:52.993081 tftpClient: request server6 0 ---> ::
1029: NOT 21:43:52.998676 tftpClient: request server6 1 ---> ::
1030: NOT 21:44:24.488250 NTP: Local clock sync'd to NTP reference.
1031: ERR 21:44:24.610536 JVM: %REG auth failed: ack timer
1032: ERR 21:44:24.611690 JVM: sip_platform_localexpires_timer_stop: Error: Line number (53) is invalid
977: NOT 21:43:51.672432 tftpClient: request server 0 ---> 
 978: WRN 21:43:51.675086 tftpClient: TC_SERVER - sendto() failed : Connection refused 
 979: NOT 21:43:51.675687 tftpClient: request server 0 ---> 
 980: WRN 21:43:51.678030 tftpClient: TC_SERVER - sendto() failed : Connection refused 
 981: NOT 21:43:51.678635 tftpClient: request server 1 --->  
 982: NOT 21:43:51.679253 tftpClient: tftp request rcv'd from /usr/tmp/tftp, srcFile = New_Zealand/g3-tones.xml, dstFile = /usr/ram/L10N190679004 max size = 550001 

I have asked the server admin for the logs to see what is going on there but they mentioned it was an authentication fail.


The password and username are correct in the SEP file.

How did you solve this, because a m in the same boat, help plz

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers