Showing results for 
Search instead for 
Did you mean: 

Cisco CP8800 series ip phone access web interface.


Recently purchased a Cisco CP-8861 IP phone that was advertised as specifically designed for 3rd party call control. I started up the phone and it automatically went to an expressway sign-in app. I was able to locate the IP address of the phone and tried accessing the web interface by simply typing in the ip address as typically done with other models. While the phone responds to pings it refuses any connection attempt using it's ip address.

I've looked at all the documentation online numerous times and while I've found several others with the same question I haven't found any answers. I'm wondering if it has to do with upgrading the firmware? If so, can it be done without use of CUCM? I see that a TFTP server might help but I want to make sure that's the issue before doing the upgrade.

My current firmware is sip88xx.10-3-1-20

I really hope there is something simple that I'm overlooking!


Well I had my hopes up that it was fail2ban but I disabled it and still no joy. Is there a way to ping the phone from within Asterisk? I tried using the CLI but it doesn't seem supported. It would be very surprising if they couldn't talk to each other but at this point I can't think of anything else blocking the phone from registering.


You mentioned that more information may help. I have included the SEPMAC.cnf.xml file below, the reported phone settings, the extension settings in asterisk, and also the phone status messages upon startup. Please let me know if you think anything else would be helpful.

It also might be worth mentioning that the phone still hasn't seen an address listed in the active server category either.

<?xml version="1.0" encoding="UTF-8"?>
<timeZone>Central Standard/Daylight Time</timeZone>
<member priority="0">
<phoneLabel>Bryan Office</phoneLabel>
<line button="1" lineIndex="1">
<displayName>DISPLAY NAME</displayName>
<messagesNumber>VOICE MAIL NUMBER</messagesNumber>
<line button="2">
<featureLabel>LABEL BUTTON 2</featureLabel>
<line button="3">
<featureLabel>LABEL BUTTON 3</featureLabel>
<line button="4">
<featureLabel>LABEL BUTTON 4</featureLabel>
<line button="5">
<featureLabel>LABEL BUTTON 5</featureLabel>
<line button="6">
<featureLabel>LABEL BUTTON 6</featureLabel>
<line button="7">
<featureLabel>LABEL BUTTON 7</featureLabel>
<line button="8">
<featureLabel>LABEL BUTTON 8</featureLabel>
<phoneService type="1" category="0">
<name>Missed Calls</name>
<phoneService type="2" category="0">
<phoneService type="1" category="0">
<name>Received Calls</name>
<phoneService type="1" category="0">
<name>Placed Calls</name>
<phoneService type="0" category="0">
<name>WORKED Services</name>

**Phone Screen Startup Status**

[2:04:44pm 31/03/16] No trust list installed
[2:04:46pm 31/03/16] SEP********.cnf.xml(TFTP)
[2:04:49pm 31/03/16] VPN not configured
[2:04:51pm 31/03/16] Error updating locale
[2:04:52pm 31/03/16] Error updating locale

**Debug on phones web gui**

[2:04:44pm 31/03/16] DeviceTLInfoDeviceName=SEP************

IPv4Address= IPv6Address=CTL_Signature=Not InstalledCTL_TFTP_Server=N/AITL_Signature=Not InstalledITL_TFTP_Server=N/AStatusCode=6

[2:04:47pm 31/03/16] DeviceImageDownloadStart DeviceName=SEPSEP************ IPv4Address= IPv6Address= Active=sip88xx.10-3-1-20 RequestedLoadId=sip88xx.10-3-1-9-3PCC

[2:04:52pm 31/03/16] DeviceName=SEPSEP************ DeviceIPv4Address= IPv4DefaultGateway= DeviceIPv6Address= IPv6DefaultGateway= ModelNumber=CP-8861 NeighborIPv4Address= NeighborIPv6Address= NeighborDeviceID= NeighborPortID= DHCPv4Status=1 DHCPv6Status=3 TFTPCfgStatus=1 DNSStatusUnifiedCM1=4 DNSStatusUnifiedCM2=0 DNSStatusUnifiedCM3=0 DNSv6StatusUnifiedCM1=0 DNSv6StatusUnifiedCM2=0 DNSv6StatusUnifiedCM3=0 VoiceVLAN= UnifiedCMIPAddress= LocalPort=0 TimeStamp=1459196875413 ReasonForOutOfService=24 LastProtocolEventSent=Sent:REGISTER sip: SIP/2.0 Cseq:102 REGISTER CallId:*****-1d3a0002-46b0d665-67ada32d@ LastProtocolEventReceived=

[2:04:54pm 31/03/16] DeviceImageDownloadFailure DeviceName=SEPSEP************ IPv4Address= IPv6Address= Method=3 FailureReason=3 Active=sip88xx.10-3-1-20 Inactive=cert.os.mfg.drop FailedLoadId=sip88xx.10-3-1-9-3PCC Server=

Listed phone settings on web gui

Service mode On-premise
Service domain
Service state Idle
Active network interface Ethernet
MAC address ************
Wireless MAC address ***********
Host name SEP**********
Phone DN 1006
App load ID rootfs88xx.10-3-1-20
Boot load ID sb288xx.BE-01-019
Version sip88xx.10-3-1-20
Key expansion module 1
Key expansion module 2
Key expansion module 3
Hardware revision V01
Serial number FCH194182DX
Model number CP-8861
Message waiting No
UDI phone
Cisco IP Phone 8861, Global
Time 2:08:59pm
Time zone Central Standard/Daylight Time
Date 31/03/16
System free memory 2147483647
Java heap free memory 1375940
Java pool free memory 2147483647
FIPS mode enabled No

Network settings on phone gui

MAC address ***********
Host name SEP**********
Domain name
DHCP server
BOOTP server No
IP address
Subnet mask
Default router
DNS server 1
DNS server 2
DNS server 3
Alternate TFTP No
TFTP server 1
TFTP server 2
DHCP address released No
Operational VLAN ID
CUCM server1
CUCM server2
CUCM server3
CUCM server4
CUCM server5
Information URL
Directories URL
Messages URL
Services URL
Idle URL
Idle URL time 0
Proxy server URL
Authentication URL
SW port setup Auto negotiate
PC port setup Auto negotiate
PC port disabled No
User locale English_United_States
Network locale United_States
User locale version Built-In
Network locale version Built-In
Speaker enabled Yes
GARP enabled Yes
Span to PC port No
Video capability enabled Yes
Voice VLAN enabled Yes
Auto line select enabled No
DSCP for call control CS3
DSCP for configuration CS3
DSCP for services Default
Security mode Non secure
Web access enabled Yes
SSH access enabled Yes
CDP: SW Port Yes
CDP: PC Port Yes
LLDP: PC Port Yes
LLDP power priority Unknown
LLDP asset ID
CTL file Not installed
ITL file Not installed
Automatic port synchronization No
Switch port remote configuration Disabled
PC port remote configuration Disabled
IP addressing mode IPv4 only
IP preference mode control V4
IP preference mode for media V4
IPv6 auto configuration Yes
IPv6 duplicate address detection Yes
IPv6 accept redirect message No
IPv6 reply multicast echo request No
IPv6 load server
IPv6 log server
IPv6 CAPF server
DHCPv6 Yes
IPv6 address ::
IPv6 prefix length 0
IPv6 default router ::
IPv6 DNS server 1 ::
IPv6 DNS server 2 ::
IPv6 Alternate TFTP No
IPv6 TFTP server 1 ::
IPv6 TFTP server 2 ::
IPv6 address released No
EnergyWise power level Full
EnergyWise domain

Extension info from Asterisk

Display Name: testuser
CID Num Alias: blank 
SIP Alias: blank

- Extension Options

Queue State Detection: Use State 
Outbound CID: blank
Asterisk Dial Options: Ttr  Override = no
Ring Time: default
Call Forward Ring Time: default 
Outbound Concurrency Limit: 3
Call Waiting: Enabled
Internal Auto Answer: Disable
Call Screening: Disabled
Pinless Dialing: Disable
Emergency CID: Blank

- Assigned DID/CID

DID Description: Blank
Add Inbound DID: Blank
Add Inbound CID: Blank

- Device Options

This device uses CHAN_SIP technology listening on

Change To CHAN_PJSIP Driver Changing SIP Driver unavailable

Secret test1234
DTMF Signaling: RFC 2833 
Can Reinvite: No
Context: from-internal
Host: dynamic
Trust RPID: Yes 
Media Encryption: None 
Send RPID: Send P-Asserted-Identity header
Connection Type: Friend (also tried peer)
NAT Mode: Yes - (force_rport,comedia) (also tried no)
Port: 5060
Qualify: yes
Qualify Frequency: 60
Transport: All- UDP Primary 
Enable AVPF: No
Force AVP: No
Enable ICE Suppor: No 
Enable Encryption: No
Call Groups: Blank
Pickup Groups: Blank
Disallowed Codecs: Blank
Allowed Codecs: Blank
Dial: SIP/1008
Account Code: Blank 
Mailbox: Blank
Voicemail Extension: Blank 

- Extension Routing

Note: Extension Routes is not registered
- Call Camp-On Services

Forcing default settings:

Caller Policy: Generic Device 
Callee Policy: Generic Device

- Default Group Inclusion

Default Directory: Exclude

- Dictation Services

Dictation Service: Disabled 
Dictation Format: Ogg Vorbis
Email Address: Blank

- Endpoint

Brand: Cisco 
MAC ************
Template: 8800_series (custom built in EPM)
Model: CP9971 (CP8861 not listed)
Account: Account 1

- Fax

Enabled: No 
Fax Email: Blank
Attachment Format: PDF

- Language

Language Code: Blank

- Paging and Intercom

Intercom Override Reject

- Pinless Dialing

- Recording Options

Inbound External Calls Force  Don't Care
Outbound External Calls Force  Don't Care 
Inbound Internal Calls Force  Don't Care
Outbound Internal Calls Force  Don't Care
On Demand Recording Disable 
Record Priority Policy: 10

- User Manager Settings

Linked to User 1008
Link to a Different Default User: 1008 (Linked) 
Username: blank Use Custom Username no-checked
Password For New User fc584e06*******62d425b022 (shaded out)

- Voicemail

Status: Disabled
Voicemail Password: blank
Require From Same Extension yes no (not choosen)
Email Address: blank
Pager Email Address: blank 
Email Attachment
Play CID 
Play Envelope
Delete Voicemail 
VM Options: blank
VM Context: default

- iSymphony Settings

Add to iSymphony yes
Auto Answer  no


Enable DTLS: No
Use Certificate: default
DTLS Verify: Fingerprint
DTLS Setup: Act/Pass
DTLS Rekey Interval: 0

- VmX Locater

VmX Locater™ Disabled
Use When: 
Voicemail Instructions: Standard Voicemail prompts.

Press 0: Go To Operator
Press 1: Send to Follow-Me
Press 2:

- Optional Destinations

No Answer: Unavail Voicemail if Enabled
CID Prefix: blank
Busy: Busy Voicemail if Enabled
CID Prefix: Blank
Not Reachable: Unavail Voicemail if Enabled
CID Prefix: blank

Hall of Fame Community Legend

NAT Mode: Yes - (force_rport,comedia) (also tried no)

Set this to "NO" and force the phone to erase the config and reboot.


Set the value to "0".


Thanks, I'll give that a try in the morning. What does 0 represent? I found documentation for 1,2 and 4 online but not 0.

Hall of Fame Community Legend

0 means UDP

1 means TCP

2 doesn't exist

4 means TCP &/or UDP but it doesn't work.


I tried both the suggestions and neither of them worked. The only transport number that got through the "Phone is registering" screen was 2.

When you say "force the phone to erase the config and reboot" does that entail something besides modifying the cnf.xml file and restarting the phone?

Hall of Fame Community Legend

Every time changes are made on the SEPmacaddress.xml.cnf file, the IP phones needs to be factory reset.  The phone needs to have a factory reset because, with newer 9.X phone firmware, the phone will only download this file ONCE.  

Thanks, I'll give that a try in the morning. What does 0 represent? I found documentation for 1,2 and 4 online but not 0.

My sincerest apologies, I am confused.  The setting should be "2" for UDP.  Please make the correction, erase the config of the phone and reboot the phone.  When the phone reboots it should download the corrected SEPmacaddress.xml.cnf file from the TFTP server.


That's weird, I saw changes take effect after modifying the cnf file and just restarting the phone. I'll give factor reset a try.


No worries about the confusion, I've tried 1-4 and only 2 gets me passed the expressway sign-in screen. I did upgrade FreePbx to 13 in hopes it was just a bug with 12 but that didn't work. Right now I'm wondering if it's a NAT issue, which would be strange since the network is small and simple at this point. It sounds like others had issues but nothing to the extent I'm having.

I'm getting a SPA504G shipped from another office to test out, if that doesn't work then it's something bigger than just the phone config.

I am a bit confused on the endpoint manager templates. I use the CP9971 as it sounds like the closest match. I wouldn't imagine this to be the case but would a mismatched template cause the server not to connect?

Hall of Fame Community Legend

I'm wondering if it's a NAT issue

Disable NAT between the phone and the Asterisk. 

Can the phone ping Asterisk (and vice versa)?


I've tried initiating ping from Asterisk CLI and it says it's not an available function. Is there a way to do it from the phone side?


I read somewhere else in a post a few years ago that modifying the sip.conf file was necessary with "cisco_usecallmanager=yes".

Is this patch old or still required? First time I have heard about it and will be trying it in the morning. If it is valid, are there any other modifications to this file that I need to make?

Hall of Fame Community Legend

I don't remember doing this but try it.


I'm currently on freePBX Would updating to 13 potentially help?

Hall of Fame Community Legend

Is there a way to ping the phone from within Asterisk? I tried using the CLI but it doesn't seem supported. It would be very surprising if they couldn't talk to each other but at this point I can't think of anything else blocking the phone from registering.

Is the phone and Asterisk server on the same IP address subnet (highly recommended)?

Content for Community-Ad