cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3969
Views
0
Helpful
2
Replies
Contributor

cisco Ip phone (7940),boot up and requested cnf files

Hi everybody

Please consider the set up below:

Ipphone2(201.201.201.11)--------SW--------CME/TFTP( 201.201.201.1)

The CME router has following CNF files in flash: ( only pertinent files are shown for brevity):

Router#show flash

System flash directory:

File  Length   Name/status

19   129824   P00308000500.bin

20   458      P00308000500.loads

21   705536   P00308000500.sb2

22   130228   P00308000500.sbn

163   1527     XMLDefault.cnf.xml

164   314      ATADefault.cnf.xml

165   762      XMLDefault7905.cnf.xml

166   359      XMLDefault7902.cnf.xml

167   595      XMLDefault7920.cnf.xml

168   410      XMLDefault7936.cnf.xml

169   896      XMLDefault7970.cnf.xml

170   1000     XMLDefault7970-1.cnf.xml

171   1073     XMLDefault7970-2.cnf.xml

172   896      XMLDefault7971.cnf.xml

173   1000     XMLDefault7971-1.cnf.xml

174   1073     XMLDefault7971-2.cnf.xml

175   896      XMLDefault7961.cnf.xml

176   1000     XMLDefault7961-1.cnf.xml

177   1073     XMLDefault7961-2.cnf.xml

178   896      XMLDefault7961GE.cnf.xml

179   1000     XMLDefault7961GE-1.cnf.xml

180   1073     XMLDefault7961GE-2.cnf.xml

181   896      XMLDefault7941.cnf.xml

182   896      XMLDefault7941GE.cnf.xml

183   896      XMLDefault7951.cnf.xml

184   896      XMLDefault7911.cnf.xml

185   896      XMLDefault7906.cnf.xml

186   762      XMLDefault7912.cnf.xml

187   445      XMLDefault7910.cnf.xml

188   410      XMLDefault7935.cnf.xml

189   790      XMLDefault7960.cnf.xml

190   894      XMLDefault-1.cnf.xml

191   967      XMLDefault-2.cnf.xml

192   860      XMLDefaultCIPC.cnf.xml

193   903      united_states_7960-tones.xml

194   8777     united_states_7960-font.xml

195   1313     united_states_7960-kate.xml

196   19750    united_states_7960-dictionary.xml

197   2651     united_states_SCCP-dictionary.xml

I just plug the ip phone into switchport  and capture the packets as shown below:

1982 342.912717 201.201.201.11 201.201.201.1 TFTP 73 Read Request, File: CTLSEP0006537B84EF.tlv, Transfer type: octet


"1986","342.918419","201.201.201.1","201.201.201.11","TFTP","60","Error Code, Code: File not found, Message: No such file"

"1988","342.981670","201.201.201.11","201.201.201.1","TFTP","74","Read Request, File: SEP0006537B84EF.cnf.xml, Transfer type: octet"

"1989","342.986441","201.201.201.1","201.201.201.11","TFTP","60","Error Code, Code: File not found, Message: No such file"


"1990","343.067851","201.201.201.11","201.201.201.1","TFTP","69","Read Request, File: XMLDefault.cnf.xml, Transfer type: octet"

"1991","343.077226","201.201.201.1","201.201.201.11","TFTP","558","Data Packet, Block: 1"

"1992","343.079172","201.201.201.11","201.201.201.1","TFTP","60","Acknowledgement, Block: 1"

"1993","343.081488","201.201.201.1","201.201.201.11","TFTP","558","Data Packet, Block: 2"

"1994","343.083427","201.201.201.11","201.201.201.1","TFTP","60","Acknowledgement, Block: 2"
"1995","343.085743","201.201.201.1","201.201.201.11","TFTP","549","Data Packet, Block: 3 (last)"
"1996","343.087622","201.201.201.11","201.201.201.1","TFTP","60","Acknowledgement, Block: 3"

  Above our ip phone is following hunt algorithm. The ipphone2 first request CTLSEP0006537B84EF.tlv .TFTP/CME has no such file so it sends the message " file not found" to ipphone2.

Ipphone2 goes down its list of the files  need to be requested as specified by hunt algorithm, eventually ipphone2 requests  XMLDefault.cnf.xml which tftp/cme delivers to the ip phone2 as shown in above packet capture.

Next When I unplug the iphone2 and plug it back to switchport, I noticed something strange. Even though Our TFTP/CME does not have SEP0006537B84EF.cnf.xml in flash but somehow TFTP/CME is able to provide that file to ipphone2. Below is the packet capture:

342 97.148783 201.201.201.11 201.201.201.1 TFTP 73 Read Request, File: CTLSEP0006537B84EF.tlv, Transfer type: octet
346 97.154503 201.201.201.1 201.201.201.11 TFTP 60 Error Code, Code: File not found, Message: No such file


348 97.184228 201.201.201.11 201.201.201.1 TFTP 74 Read Request, File: SEP0006537B84EF.cnf.xml, Transfer type: octet
349 97.194833 201.201.201.1 201.201.201.11 TFTP 558 Data Packet, Block: 1
350 97.195850 201.201.201.11 201.201.201.1 TFTP 60 Acknowledgement, Block: 1

351 97.197980 201.201.201.1 201.201.201.11 TFTP 324 Data Packet, Block: 2 (last)
352 97.198743 201.201.201.11 201.201.201.1 TFTP 60 Acknowledgement, Block: 2.

The question is how could tftp/CME provide " SEP0006537B84EF.cnf.xml"   when it does not contain any such file in its flash?

Thanks and have a great day.

=====================================================================

I have attached the running-config below:

Router#show running-config

!

no ip dhcp use vrf connected

ip dhcp excluded-address 200.200.200.1 200.200.200.10

ip dhcp excluded-address 201.201.201.1 201.201.201.10

!

ip dhcp pool voice

   network 201.201.201.0 255.255.255.0

   default-router 201.201.201.1

   option 150 ip 201.201.201.1

!

ip dhcp pool data

   network 200.200.200.0 255.255.255.0

   default-router 200.200.200.1

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 200.200.200.1 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 201.201.201.1 255.255.255.0

!

!

ip http server

ip http path flash:

!

!

tftp-server flash:P00308000500.sbn

tftp-server flash:P00308000500.bin

tftp-server flash:P00308000500.loads

tftp-server flash:P00308000500.sb2

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

gatekeeper

shutdown

!

!

telephony-service

load 7960-7940 P00308000500

max-ephones 4

max-dn 4

ip source-address 201.201.201.1 port 2000

cnf-file location flash:

max-conferences 4 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  1

number 20001

!

!

ephone-dn  2

number 20002

!

!

ephone  1

mac-address 0006.537B.84EF

button  1:1

!

!

!

ephone  2

mac-address 0006.28F0.F7E7

button  1:2

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

Router#

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Community Legend

cisco Ip phone (7940),boot up and requested cnf files

Hi there,

The SEP.cnf.xml file won't necessarily be in flash

In Cisco Unified CME 4.0 and later for SCCP and in Cisco CME 3.4 and  later for SIP, you can designate one of the following locations in which  to store configuration files:

System  (Default)—For SCCP phones, one configuration file is created, stored,  and used for all phones in the system. For SIP phones, an individual  configuration profile is created for each phone.

Flash  or slot 0—When flash or slot 0 memory on the router is the storage  location, you can create additional configuration files to be applied  per phone type or per individual phone, such as user or network locales.

TFTP—When  an external TFTP server is the storage location, you can create  additional configuration files to be applied per phone type or per  individual phone, which are required for multiple user and network  locales.

The following example selects flash memory as the configuration file  storage location and per-phone as the type of configuration files that  the system generates.

telephony-service

cnf-file location flash:

cnf-file perphone

http://docstore.mik.ua/univercd/cc/td/doc/product/voice/its/cmeadm/basic/cmefiles.htm#wp1018492

Cheers!

Rob

"And if I should fall behind
Wait for me" - Springsteen

View solution in original post

2 REPLIES 2
Highlighted
Hall of Fame Community Legend

cisco Ip phone (7940),boot up and requested cnf files

Hi there,

The SEP.cnf.xml file won't necessarily be in flash

In Cisco Unified CME 4.0 and later for SCCP and in Cisco CME 3.4 and  later for SIP, you can designate one of the following locations in which  to store configuration files:

System  (Default)—For SCCP phones, one configuration file is created, stored,  and used for all phones in the system. For SIP phones, an individual  configuration profile is created for each phone.

Flash  or slot 0—When flash or slot 0 memory on the router is the storage  location, you can create additional configuration files to be applied  per phone type or per individual phone, such as user or network locales.

TFTP—When  an external TFTP server is the storage location, you can create  additional configuration files to be applied per phone type or per  individual phone, which are required for multiple user and network  locales.

The following example selects flash memory as the configuration file  storage location and per-phone as the type of configuration files that  the system generates.

telephony-service

cnf-file location flash:

cnf-file perphone

http://docstore.mik.ua/univercd/cc/td/doc/product/voice/its/cmeadm/basic/cmefiles.htm#wp1018492

Cheers!

Rob

"And if I should fall behind
Wait for me" - Springsteen

View solution in original post

Highlighted
Beginner

cisco Ip phone (7940),boot up and requested cnf files

Hi Rob, thanks for the answer on this one.......

I have a similar issue in that I am specifying to use the Flash Card as the storage location, but I get this:

R1(config-telephony)#cnf-file location flash:
Warning: The flash file system does not support
              directories, all files will be stored in the root
              directory. Make sure to switch to another storage
              device if there are a large number of phones
%Error: The flash file system does not support
              directories, all files will be stored in the root
              directory. Make sure to switch to another storage
              device if there are a large number of phones


Now even though this is a warning advising me to switch to another storage device if there is going to be a large number of phones i assumed it should still allow me to save the config files to the root of flash

R1(config-telephony)#do show flash

CompactFlash directory:
File  Length   Name/status
  1   53251448  c2800nm-entservicesk9-mz.124-24.T3.bin 
  2   703153   cmterm-7940-7960-sccp.8-1-2SR2.cop 
[53954732 bytes used, 10270544 available, 64225276 total]
62720K bytes of ATA CompactFlash (Read/Write)

As you can see I have nothing stored there dispite having two cisco SCCP phones registered and working with CME?

I assume the .cnf default and actual SEP .cnf files are located within system as per you previos post but I don't know how to view the system location to check and I would still like them to be stored in flash if possible (even if it is in the root).

Any help would be much appreciated

Thanks in advance

David

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here