cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1405
Views
35
Helpful
16
Replies

Cisco IP Telephony / CUCM / Live audio source translation

vantonenko
Level 1
Level 1

Hello, is it possible to create internal phone number with live audio source for everyone to listen.

I have CME with VIC3-E/M card and CUCM 9.1. Audio signal coming to E & M voice port with disabled signaling, CME connected to CUCM via SIP trunk. And now users can call to special number, and listen audio translation. But POTS port has only one line and second user can't dial this number (line is busy).

Is there workaround of this issue with this software and hardware? Or what is the proper way to implement this?

16 Replies 16

Aaron Harrison
VIP Alumni
VIP Alumni

Hi

I've been looking at these products recently... this PDF shows how you can use a little hardware box to stream multicast audio, and get the phones to receive it.

They're only a few hundred dollars... 

http://www.barix.com/fileadmin/data/howto/Instreamer-Cisco_application_note_v14.pdf

 

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi, Aaron.

Thank you for info,

So why it couldn't do with Cisco hardware?

Cisco CME can send multicast with "feed ip 239.X.X.X" command, or I mistaking?

Only the question is write and host XML page, that can be parsed by IP Phone with commands to start and stop receiving RTP multicast, and subsribe phone to this page as a Phone Service.

I tried to create simple page, but have "HTTP content is not supported 23" error. 

The hardware you described is using static XML file to provide service, can you show the XML file that generated by Barix Instreamer?

Hi 

As I say, i don't have one yet.

The arguments against using Cisco kit would be expense, messy cabling, complexity etc. A little one-box device that streams continually and serves only that purpose seems like a good idea to me.

Maybe post up your code. I don't have an instreamer to get the pages from, but can review what you have written.


Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

The code is:

<CiscoIPPhoneMenu> 
<Title>Conference listening</Title> 
<MenuItem> 
<Name>Start listening</Name> 
<URL>RTPMRx:239.0.0.10:20480:100</URL> 
</MenuItem> 
<MenuItem> 
<Name>Stop listening</Name> 
<URL>RTPRx:Stop</URL> 
</MenuItem> 
</CiscoIPPhoneMenu> 
 
I tried to add declares like <?xml version="1.0" encoding="utf-8"?> not worked, all examples I find in documentation corresponding to active web servers (PHP-scripts, Java scripts). I will be appreciate if you can help me to write this.
 
Today and here this solution not more complex than Barix Instreamer, cause Cisco router 2901 and CUCM already installed for their purposes. New installation was only E&M VIC, founded in the storage. 
 
In future projects, it's better to use Barix Instreamer for streaming. Thank you for info again.

Hi 

Your menu fragment is OK.

What web server are you using?

Basically the server needs to set the 'content-type' header to text/xml for the phone to parse it. IIS does this based on the file extension, so if you have called it html or something, call it .xml. If you are using another web server it might need more config.

Are you using the IOS web server?

Aaron

 

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Thank you,

For test i used Synology WEB station, linux apache WEB-server. And i weak in web-developing. 

Can IOS web server serve content in needed "content-type"? It can will be great one-box solution.

 

Hi

I googled it, and it claims to support content-type as a valid option (http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/https/configuration/12-2sy/https-12-2sy-book/nm-http-web.html)... however I don't see how you configure it if it's not based on the file extension.

Did you have the file named whatever.xml?

If so I'd probably get the CME GUI files on their and see how they work, they'll definitely serve up XML to the phones...

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi, Thank You, for the info Aaron.

I configured endpoints, but hear nothing.

Phone executing command from XML, sends IGMP reports to join group to network, CME sends rtp flow to network.

A tried to forward packets from CME to IP-phone for a last week, but not succesful.

I notice that a not so much documentation about enabling multicast in C3750 L2 network, and most configurations has a router.

Please, could you tell about simple enabling multicast and in VLAN on C3750?

CME in a same LAN with IP Phones, default router in the network is L3/2 switch stack.

What route might be written in "feed ip" command on CME(Multicast-Server), is it needed to enable "ip multicast-routing" on switches?

Perfectly will be a bare minimum of config to enable Multicast forwarding throuhg the switches.

(CME(multicast server))-(L3/2-Core-Switch)-(L3/2-Gateway-Switch-Stack(With Users))

Please help, if You can, i'll provide needed information.

Hi

Can you post your CME config?

And your 3750? 

If you do a show int on the switch for the CME port do you see it receiving mcast packets?

Generally if the sender and worry about mcasteh same VLAN you don't need to worry about mcast much as it's not being routed. IIRC IGMP snooping is on by default.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi!

Thank you.

Here is config of CME (It also used for internet connection)

CME#sh run   
Building configuration...
Current configuration : 8035 bytes

hostname CME
!
voice-card 0
!
!        
!
voice service voip
ip address trusted list
  ipv4 172.16.60.0 255.255.254.0
allow-connections h323 to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
sip
  registrar server expires max 3600 min 3600
!
voice class codec 1
codec preference 1 g711ulaw
!
voice class h323 1
  h225 timeout tcp establish 3
  h225 timeout setup 3
!
!
license udi pid CISCO2901/K9 sn FCZ1609C2SZ
hw-module pvdm 0/0
!
username XXXX privilege 15 secret 5 XXXX
!
redundancy
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Uplink
ip address XXXXXXXX
ip access-group 101 in
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1
description Link to LAN
ip address XXXXX
ip access-group 100 in
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1.30
description VOIP
encapsulation dot1Q 30
ip address 172.16.60.20 255.255.254.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.16.60.20
!         

!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
{NAT and ACL rules}
!
control-plane

!
voice-port 0/0/0 - Live Source
auto-cut-through
operation 4-wire
signal immediate
input gain 14
!
voice-port 0/0/1
!
mgcp profile default
!
!
dial-peer voice 500 pots
destination-pattern 3000
port 0/0/0
!
!
dial-peer voice 1 voip
description Incoming for test live source
session protocol sipv2
session target sip-server
incoming called-number .%
dtmf-relay rtp-nte
no vad
!
!
sip-ua
sip-server ipv4:172.16.60.20
!
!
gatekeeper
shutdown
!
!
telephony-service
max-ephones 10
max-dn 10
ip source-address 172.16.60.20 port 2000
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp
!
!
ephone-dn  1
number 3000
!
!
ephone-dn  2  dual-line
number 3001
!
!
ephone-dn  3
number 3003
feed ip 239.0.0.10 port 20480 route 172.16.60.6 (Nighbour switch SVI) out-call 3000
!
!
ephone  2 (Phone for testing live source)
mac-address 10BF.4867.E608
type CIPC
button  1:2
!
!
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
logging synchronous
login local
transport input telnet ssh
line vty 5 15
logging synchronous
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

Port of the switch next to CME is receiving mcast packets. Counter is increasing so fast (about 100 packets/sec)

Hi

I think the 'route' param in your feed ip command should be set to the source address to use, e.g. 172.16.60.20, rather than the next hop.


Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi

Changed the param, not worked, 

Mcast packet is received too.

How can i trace the multicast traffic through the network?

Can initiate synthetic join to multicast group on switches for troubleshoot?

 

Hi

You can put 'ip igmp join-group x.x.x.x' on an interface.

You'd first need to enable IGMP - put 'ip pim dense' on the interface facing the router. That enables PIM, but also IGMP on the interface.

Also verify you have IGMP snooping on the 3750. It's on by default.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Hi, Aaron, and thanks.

First of all, i put "ip igmp join-group X.X.X.X" on interface Vlan 30, on switch neighbour to CME (172.16.60.6), and second switch (with users) (172.16.60.1).

I used Vlan int cause there is Trunk between CME and CoreSW. Correct me if this is not right. Must i use Sub-Interface?

Then i put "ip pim dense" on interface Vlan 30 switch neighbour to CME (CoreSW), and saw "Warning" about multicast routing.

Then i exec "sh ip igmp groups" on switches:

CoreSW:

Group Address    Interface                Uptime    Expires   Last Reporter

239.0.0.10       Vlan30                   18:14:36  00:02:27  172.16.60.6224.0.1.40       Vlan30                   01:23:34  00:02:30  172.16.60.9

UserSW:

Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
239.0.0.10       Vlan30                   1d21h     stopped   172.16.60.1

There are no multicast packet between CoreSW and UserSW

IGMP snooping enabled on both switches. 

 

Debug IP IGMP groups on CoreSW:

007309: 3d23h: IGMP(0): Received v2 Report on Vlan30 from 172.16.60.6 for 224.0.1.40
007310: 3d23h: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 172.16.60.6 for 0 sources
007311: 3d23h: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40
007312: 3d23h: IGMP(0): Received v2 Report on Vlan30 from 172.16.60.1 for 239.0.0.10
007313: 3d23h: IGMP(0): Received Group record for group 239.0.0.10, mode 2 from 172.16.60.1 for 0 sources
007314: 3d23h: IGMP(0): Cancel report for 239.0.0.10 on Vlan30
007315: 3d23h: IGMP(0): Updating EXCLUDE group timer for 239.0.0.10
007316: 3d23h: IGMP(0): Received Leave from 172.16.60.1 (Vlan30) for 224.0.1.40

Debug IGMP Snooping on CoreSW:

007230: 3d22h: IGMPSN: group: Received V2 report for group 239.0.0.10 received on Vlan 30, port Gi1/0/12
007231: 3d22h: IGMPSN: group: Adding client ip 172.16.60.1, port_id Gi1/0/12, on vlan 30
007232: 3d22h: IGMPSN: group: Added port Gi1/0/12 to group 239.0.0.10
007233: 3d22h: IGMPSN: group: Forwarding 239.0.0.10 report to router ports
007234: 3d22h: IGMPSN: timer: Vlan 30 report timer expired
007235: 3d22h: IGMPSN: Received SVI query(224.0.0.1) on vlan 30
007236: 3d22h: IGMPSN: Adding iquerier flag in vlan 30
007237: 3d22h: IGMPSN: router: iquerier added on Vlan 30
007238: 3d22h: IGMPSN: group: Received V2 report for group 239.0.0.10 received on Vlan 30, port Gi1/0/12
007239: 3d22h: IGMPSN: group: Added port Gi1/0/12 to group 239.0.0.10
007240: 3d22h: IGMPSN: group: Forwarding 239.0.0.10 report to router ports
007241: 3d22h: IGMPSN: timer: Vlan 30 report timer expired
007242: 3d22h: IGMPSN: group: Leave for group 239.0.0.10 received on Vlan 30, port Gi1/0/12
007243: 3d22h: IGMPSN: group: Adding client ip 172.16.60.5, port_id Gi1/0/12, on vlan 30
007244: 3d22h: IGMPSN: group: Created v2 leave port on port Gi1/0/12, for group 239.0.0.10 on Vlan 30 
007245: 3d22h: IGMPSN: group: Sending Group-Specific Query for group 239.0.0.10 on Vlan 30, port Gi1/0/12
007246: 3d22h: IGMPSN: timer: Vlan 30, group 239.0.0.10, port Gi1/0/12 leave port timer expired
007247: 3d22h: IGMPSN: group: Deleting leave port on port Gi1/0/12, for 239.0.0.10 on Vlan 30 
007248: 3d22h: IGMPSN: mgt: deleted port Gi1/0/12 on gce 0100.5e00.000a, on Vlan 30
007249: 3d22h: IGMPSN: group: Deleting port Gi1/0/12 from group 239.0.0.10 on Vlan 30
007250: 3d22h: IGMPSN: group: Deleting group 239.0.0.10
007251: 3d22h: IGMPSN: mgt: deleting group EF00000A, on Vlan 30
007252: 3d22h: IGMPSN: group: Deleting gce 0100.5e00.000a
007253: 3d22h: IGMPSN: mgt: deleting gce 0100.5e00.000a, on Vlan 30
007254: 3d22h: IGMPSN: group: Sending Leave for group 239.0.0.10, source 172.16.60.5 on Vlan 30
007255: 3d22h: IGMPSN: Received SVI query(239.0.0.10) on vlan 30
007256: 3d22h: IGMPSN: Adding iquerier flag in vlan 30
007257: 3d22h: IGMPSN: router: iquerier added on Vlan 30
007258: 3d22h: IGMPSN: group: Received V2 report for group 239.0.0.10 received on Vlan 30, port Gi1/0/4
007259: 3d22h: IGMPSN: group: Adding client ip 172.16.60.9, port_id Gi1/0/4, on vlan 30
007260: 3d22h: IGMPSN: mgt: created gce 0100.5e00.000a, on Vlan 30
007261: 3d22h: IGMPSN: mgt: created group EF00000A, on Vlan 30
007262: 3d22h: IGMPSN: group: Created group 239.0.0.10
007263: 3d22h: IGMPSN: mgt: added port Gi1/0/4 on gce 0100.5e00.000a, Vlan 30
007264: 3d22h: IGMPSN: group: Added port Gi1/0/4 to group 239.0.0.10
007265: 3d22h: IGMPSN: group: Forwarding 239.0.0.10 report to router ports
007266: 3d22h: IGMPSN: group: Received V2 report for group 239.0.0.10 received on Vlan 30, port Gi1/0/12
007267: 3d22h: IGMPSN: group: Adding client ip 172.16.60.1, port_id Gi1/0/12, on vlan 30
007268: 3d22h: IGMPSN: mgt: added port Gi1/0/12 on gce 0100.5e00.000a, Vlan 30
007269: 3d22h: IGMPSN: group: Added port Gi1/0/12 to group 239.0.0.10

Debug IGMP on UserSW:

 *Mar  4 22:49:44.568: IGMP(1): Received v2 Query on Vlan30 from 172.16.60.6
*Mar  4 22:49:44.568: IGMP(1): Set report delay time to 3.5 seconds for 239.0.0.10 on Vlan30
*Mar  4 22:49:48.158: IGMP(1): Send v2 Report for 239.0.0.10 on Vlan30
*Mar  4 22:49:54.567: IGMP(1): Received v2 Query on Vlan30 from 172.16.60.6
*Mar  4 22:49:54.567: IGMP(1): Set report delay time to 7.6 seconds for 239.0.0.10 on Vlan30
*Mar  4 22:49:55.574: IGMP(1): Received v2 Query on Vlan30 from 172.16.60.6
*Mar  4 22:50:02.184: IGMP(1): Send v2 Report for 239.0.0.10 on Vlan30
*Mar  4 22:50:44.899: IGMP(1): Received v2 Query on Vlan30 from 172.16.60.6
*Mar  4 22:50:44.899: IGMP(1): Set report delay time to 0.8 seconds for 239.0.0.10 on Vlan30
*Mar  4 22:50:45.754: IGMP(1): Send v2 Report for 239.0.0.10 on Vlan30
*Mar  4 22:51:45.305: IGMP(1): Received v2 Query on Vlan30 from 172.16.60.6
*Mar  4 22:51:45.305: IGMP(1): Set report delay time to 1.6 seconds for 239.0.0.10 on Vlan30
*Mar  4 22:51:46.312: IGMP(1): Received v2 Report on Vlan30 from 172.16.60.6 for 239.0.0.10
*Mar  4 22:51:46.312: IGMP(1): Received Group record for group 239.0.0.10, mode 2 from 172.16.60.6 for 0 sources
*Mar  4 22:51:46.312: IGMP(1): Cancel report for 239.0.0.10 on Vlan30
*Mar  4 22:52:45.627: IGMP(1): Received v2 Query on Vlan30 from 172.16.60.6
*Mar  4 22:52:45.627: IGMP(1): Set report delay time to 2.7 seconds for 239.0.0.10 on Vlan30

Debug igmp snooping on UserSW:

*Mar  4 23:01:48.974: IGMPQR: vlan_id 30: GQ with src addr 172.16.60.6 received on port Gi1/0/1 in Disabled state
*Mar  4 23:02:49.372: IGMPQR: vlan_id 30: GQ with src addr 172.16.60.6 received on port Gi1/0/1 in Disabled state
*Mar  4 23:03:49.770: IGMPQR: vlan_id 30: GQ with src addr 172.16.60.6 received on port Gi1/0/1 in Disabled stateu all 

 

Is this is normal functioning of IGMP? Thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: