cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

2886
Views
69
Helpful
10
Replies
Beginner

Cisco ISR 4321 cannot download MGCP XML Configuration Files

Dear all,

I'm trying to configure Cisco ISR 4321 as MGCP gateway. I've configured the hostname and domain name in MGCP gateway. And i've added the MGCP gateway using device name : hostname.domain name. In the MGCP gateway, i've entered two commands :

ccm-manager config

ccm-manager config server (ip address of CUCM)

I've verified network connectivity between MGCP gateway and CUCM, it's ok. The MGCP gateway and CUCM is located in the same network segment, no firewall between them. But the MGCP gateway cannot download the configuration file from CUCM. Does anyone have any idea?

Thank you.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Collaborator

Check your config for the

Check your config for the command "ip tftp source-interface" and make sure it references the correct interface. My came out of the factory referencing GigabitEthernet0 which is the management interface, not one of the main interfaces.

I general had huge problems recently setting up a new 4321 router for MGCP. The IOS for this range appears to be quite flaky for voice. I'm using sr4300-universalk9.03.15.02.S.155-2.S2-std.SPA.bin as my firmware image as this was the one that seemed to work.

GTG

Please rate all helpful posts.

View solution in original post

10 REPLIES 10
Engager

I personally don't like these

I personally don't like these two commands as it downloads many other configuration which I need to change later on manually. Do you see it's mandatory for you to configure gateway like this?

- Vivek

Hi.

Hi.

Can you share a debug ccm-manager config-download?

To retrieve the output first issue no ccm-manager config and ccm-manager config again in config mode

Thanks

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
Rising star

More over I am bit surprised

More over I am bit surprised the need or the requirement to use MGCP gateway. I would be more happy to go H323 or even better SIP Gateway (aka CUBE) than an MGCP.  However sometimes, we need to use the older technology :)

Collaborator

Check your config for the

Check your config for the command "ip tftp source-interface" and make sure it references the correct interface. My came out of the factory referencing GigabitEthernet0 which is the management interface, not one of the main interfaces.

I general had huge problems recently setting up a new 4321 router for MGCP. The IOS for this range appears to be quite flaky for voice. I'm using sr4300-universalk9.03.15.02.S.155-2.S2-std.SPA.bin as my firmware image as this was the one that seemed to work.

GTG

Please rate all helpful posts.

View solution in original post

Beginner

Re: Check your config for the

This was happening to me as well. Mine came default "ip tftp source-interface GigabitEthernet0" and I had to change it to "ip tftp source-interface GigabitEthernet 0/0/0"for it to work for my MGCP registration. Thank you for this.

Cisco Employee

Bryan,

Bryan,

can you please add this command on GW and do no ccm-manager config and ccm-manager config.

#ip tftp source interface < interface>===this is should be same as mgcp bind command pointed to that interface.

also check bind command is there or not if not added the same

#mgcp bind control source-interface <interface>

#mgcp bind media source-interface <interface>

Br,

Nadeem

PS; Please rate all useful post.

Br, Nadeem Please rate all useful post.
Hall of Fame Community Legend

Hi Bryan,

Hi Bryan,

In addition to the good tips from my friends Vivek, Carlo, Gordon & Nadeem (+5 each!)

This bug is interesting as well;

43xx/44xx removes Mgcp bind on reboot
CSCuv85943
Cisco Employee

Thanks Rob my friend (+5) for

Thanks Rob my friend (+5) for sharing the BUG.

Br,

nadeem

Br, Nadeem Please rate all useful post.

+5 Rob,

+5 Rob,

Great as usual my friend ;)

Cheers 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Contributor

100% correct on this.  The

100% correct on this.  The newer ISR come with the wrong default for ip tftp.  Especially is you use Loopback1 as your registration point.  A show run command does not expose this.  Thanks for great info.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here