cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
992
Views
0
Helpful
8
Replies

Cisco Unity Default Mailbox

Chetty
Beginner
Beginner

Hi all, I’m looking for a little help on setting up a default announcement only mail box for all users.

 

We use extension mobility throughout but not all users have a mail box – Licence costs, with this is mind we would like to forward all calls to unity connect which as an announcement only mail box, the problem CUCM passes the callers number through so not hitting the correct VM box.

 

Example:

CUCM: I’ve set up a CTI route point with a DN of 1234, this call forwards all to a call handler on Unity Connect.

I call forward all my phone (63220) to 1234 with the hope of hitting the the announcement only

 

This does not work because CUCM has passed my (63220) number to unity and not the extension of 1234, the only way I can get this to work is by sending call through the PBX to a mobile and then the mobile divert all back to 1234, this then strips my number from the CLI.

 

Is there anyway I can strip the CLI from internal calls so when we divert to 1234, its this number that is passed to Unity.

 

Thanks

1 Accepted Solution

Accepted Solutions

Well it looks like there is still an open bug for the mask not working with SIP integration:

https://community.cisco.com/t5/unified-communications/voice-mail-profile-mask-and-unity-connection-with-sip/td-p/3814939

 

It works fine in my lab with SCCP integration. I added a SIP integration to test and sure enough I get the default Unity call handler as my test extension does not have a mailbox.

 

I tried to find my notes from translation pattern config but it was years ago!

 

Couple of other suggestions:

1. In Unity connection go to Advanced, Conversations, then tick to enable “Use Last (Rather than First) Redirecting Number for Routing Incoming Call“. As the call is to your extension initially this is the extension that gets passed to Unity by default, the above setting should cause it to use 1234 as that was the number that actually redirected the call in.

2. Setup an SCCP intergration for Unity, you can have both SIP and SCCP at the same time so you don;t need to break your current setup, configured the SCCP with a new pilot number used on a new profile with a mask applied. Use that profile and SCCP for the extensions you want to redirect to your 1234 mailbox. Leave everything else on SIP.

View solution in original post

8 Replies 8

mmoulson1
Enthusiast
Enthusiast

It's been a while but I believe if you create a separate Voice Mail Profile on CUCM and use the 'Voice Mail Box Mask'. set to 1234. You then configure the DN to use the new profile. It is then just a case of configuring call forward to voicemail rather than forward to 1234.

 

Hope that helps.

Chetty
Beginner
Beginner

Thanks for the response

 

I’ve just tested this but I’m still presented with my mail box and not that of 1234

I have CFA to 1234.

 

Thanks

Try with CFA to voicemail rather than 1234, this will cause it to use the Voicemail profile and pickup the mask. If you forward to 1234 it wouldn't use it.

No love I'm afraid, still sends it to my personal mail box

 

Thanks

Is your Unity connection integration SIP or SCCP? I remember ages ago a situation where if SIP integration was used then it didn't use the mask on the voicemail profile. The fix that we applied was to use a translation pattern to manipulate the calling party and that was a work around.

Yes using SIP

 

OK, I've created a Translation Pattern using 1234, in the under calling party transformation pattern I have 1234, then under Called transformation Mask I have 81400 (vm)

 

Sill passing my DN through and hitting my mail box

 

Thanks

Well it looks like there is still an open bug for the mask not working with SIP integration:

https://community.cisco.com/t5/unified-communications/voice-mail-profile-mask-and-unity-connection-with-sip/td-p/3814939

 

It works fine in my lab with SCCP integration. I added a SIP integration to test and sure enough I get the default Unity call handler as my test extension does not have a mailbox.

 

I tried to find my notes from translation pattern config but it was years ago!

 

Couple of other suggestions:

1. In Unity connection go to Advanced, Conversations, then tick to enable “Use Last (Rather than First) Redirecting Number for Routing Incoming Call“. As the call is to your extension initially this is the extension that gets passed to Unity by default, the above setting should cause it to use 1234 as that was the number that actually redirected the call in.

2. Setup an SCCP intergration for Unity, you can have both SIP and SCCP at the same time so you don;t need to break your current setup, configured the SCCP with a new pilot number used on a new profile with a mask applied. Use that profile and SCCP for the extensions you want to redirect to your 1234 mailbox. Leave everything else on SIP.

Many thanks, I'm going to try the second option but during Xmas and new year, I'm going to accept this as fix and I will get back to you before next year.

 

Thank-you and everybody else who contributed to this question

 

Martyn

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers