cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

1879
Views
5
Helpful
4
Replies
Highlighted
Beginner

CME 8.5 and 7940G not registering

hello. I am trying to get an IP phone registering with CME, but it doesnt seem to work. here is what i got:

System image file is "flash:c2800nm-advipservicesk9-mz.151-3.T.bin"

VOIP1#sh telephony-service

CONFIG (Version=8.5)

=====================

Version 8.5

VOIP1#sh telephony-service tftp-bindings

tftp-server system:/its/united_states/7960-tones.xml alias United_States/7960-tones.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml

tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7920-font.xml

tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml

tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7920-kate.xml

tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml

tftp-server system:/its/vrf1/XMLDefault7940.cnf.xml alias SEP001E7A263123.cnf.xml

tftp-server system:/its/vrf1/XMLDefault7910.cnf.xml alias SEP0004C1879F50.cnf.xml

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf

tftp-server system:/its/vrf1/XMLDefault.cnf.xml alias XMLDefault.cnf.xml

tftp-server system:/its/vrf1/ATADefault.cnf.xml alias ATADefault.cnf.xml

phone firmware: cmterm-7940-7960-sccp.8-1-2.zip (P00308010200)

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/cme85spc.htm.html

The phone itself doesnt show errors under the status, it just keeps looping between the "configuring ip" and "opening 172.16.1.1" mesages.

I upgraded the phone's firmware to match the requirements of CME8.5. Before the upgrade I got an application loader error or something similar.

Router's configuration is as follows:

VOIP1#sh run

Building configuration...

Current configuration : 2193 bytes

!

! Last configuration change at 16:35:01 UTC Fri Sep 14 2012

! NVRAM config last updated at 13:17:54 UTC Fri Sep 14 2012

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VOIP1

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$xkRi$DOfdEzKCHWqk2wb6KTUUf/

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 172.16.1.1

ip dhcp excluded-address 172.16.1.254

!

ip dhcp pool VOIPPOOL

   network 172.16.1.0 255.255.255.0

   default-router 172.16.1.1

   dns-server 172.16.1.1

   option 150 ip 172.16.1.1

!

!

!

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2811 sn FHK1427F3EA

license accept end user agreement

!

redundancy

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.172

encapsulation dot1Q 172

ip address 172.16.1.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

logging esm config

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

telephony-service

max-ephones 5

max-dn 5

ip source-address 172.16.1.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp 7960 Sep 14 2012 16:33:20

!

!

ephone-dn  1

number 1111

name VOIP1_1

!

!

ephone-dn  2

number 1112

name VOIP_2

!

!

ephone  1

device-security-mode none

mac-address 001E.7A26.3123

type 7940

button  1:1

!

!

!

ephone  2

device-security-mode none

mac-address 0004.C187.9F50

type 7910

button  1:2

!

!

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password cisco

login

transport input all

!

scheduler allocate 20000 1000

end

And the debugging of the router's tftp events loops between the following:

Sep 14 16:37:30.623: TFTP: Looking for CTLSEP001E7A263123.tlv

Sep 14 16:37:30.691: TFTP: Looking for SEP001E7A263123.cnf.xml

Sep 14 16:37:30.691: TFTP: Opened system:/its/vrf1/XMLDefault7940.cnf.xml, fd 10, size 1059 for process 377

Sep 14 16:37:30.703: TFTP: Finished system:/its/vrf1/XMLDefault7940.cnf.xml, time 00:00:00 for process 377

VOIP1#

Sep 14 16:38:02.583: TFTP: Looking for CTLSEP001E7A263123.tlv

Sep 14 16:38:02.647: TFTP: Looking for SEP001E7A263123.cnf.xml

Sep 14 16:38:02.647: TFTP: Opened system:/its/vrf1/XMLDefault7940.cnf.xml, fd 10, size 1059 for process 377

Sep 14 16:38:02.659: TFTP: Finished system:/its/vrf1/XMLDefault7940.cnf.xml, time 00:00:00 for process 377

Any ideas? thanks!

Everyone's tags (5)
4 REPLIES 4
Collaborator

Re: CME 8.5 and 7940G not registering

Hello Heiki,

Check this links:

https://supportforums.cisco.com/docs/DOC-21494

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/troubleshooting/guide/ts_phreg.html

Other thing can you ping the IP Phones from CME? The IP Phone configured at the correct VLAN?

Put the command load for the firmware load file.

telephony-service

 Load 7960-7940 P00308010200 !---<==== configuration for load command

Regards

Leonardo Santana

Rate this if helps

Beginner

Re: CME 8.5 and 7940G not registering

yes, the phones acquire ip fine and they are assigned to the voice vlan.

i also got to the point where i compared the configs and saw i was missing the load command.

however i know for sure that on another router with the same model phones i had everything working without the load command. however it could be that on the other setup i had different IOS and phone firmware.

anyway i will give it a try and let you know how it works out. first thing on monday.

thanks for your help!

Beginner

Re: CME 8.5 and 7940G not registering

I know this is crazy, but today the original configuration works like a charm. All the equipment is the same, the configuration is the same, all the firmwares are the same. I have no idea why it is working now and didnt work last week. I guess I could call the problem solved.

Beginner

I was having the exact same

I was having the exact same problem with CME 8.5 and a 7940. Simply rebooting the router fixed the issue. I had not reloaded the router in a very long time and had tried many different configurations on it because it is my lab router. When we make a lot of changes sometimes it is good to reload the system. Thanks for the help everyone.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here