cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
349
Views
0
Helpful
5
Replies

CME 8.6 (UC520) - Strange call forward all issue - Forward all softkey - cfwdall issue

Alexander Fix
Level 1
Level 1

Hi,

I recently switched a customer's UC520 PSTN-breakout from ISDN BRI to SIP-Trunk and I am encountering some problems with this setup.

They are using 9951 and 8961 SIP-phones.

There is an issue with call forwarding on some phones. I am trying to use the "Forward all"-Softkey on the phone to forward all calls to an internal extension. On some phones it works, on some phones it doesn't.

Examples:

  • Pool 2 with DN 2: It doesn't work. When I press the softkey the dialog for entering the number opens. After entering the extension the dialog closes and nothing happens. Call forwarding doesn't get set up.
  • Pool 8 with DN 8: It works. When I press the softkey the dialog for entering the number opens. After entering the extension the dialog closes and call forwarding is set up.

All phones are configured equally, except for the DNs. All phones use the same firmware (9.2.2 - though "sh voice register pool ..." shows 9.2.1). There are some 8961s with and some without this issue, also there are some 9951s with and some without this issue

The only difference I can see is the "Registration method" under "sh voice register pool ...", although all phones use tcp as session transport.

As far as I am concerned, bulk registration is used with tcp and per line registration is used with udp.

The Phones that don't work all use "Registration method: bulk - completed" and the phones that work use "Registration method: per line"

I don't really get it.

Please find attached some relevant files.

Best Regards,

Alexander

5 Replies 5

Hi,

Can you try the command no digit-collect kpml on the voice register pool

Hi Mohammed,

thanks for your reply.

I tried the command "no digit collect kpml" on pool 2, but still forwarding doesn't work.

The behavior changed a bit though, the dialog stays open for a little bit longer after entering the number, then a small window with "Forward all" appears on the right side of the screen (where the called number is usually displayed) and disappears right after.

Please find attached two new log files.

1. Forwarding from Pool 2 DN 2 >> DN 1

2. Forwarding from Pool 2 DN 2 >> DN 9

Please let me know if I should collect more debug logs.

Hi,

Can you please include bind command in your config as below

voice service voip

sip

bind all source vlan 100

!

dial-peer voice 202 voip
voice-class sip bind control source fa0/0

voice-class sip bind media source fa0/0
!
dial-peer voice 203 voip
voice-class sip bind control source fa0/0

voice-class sip bind media source fa0/0

dial-peer voice 2000 voip
voice-class sip bind control source vlan 1

voice-class sip bind media source vlan 1

I added the bind commands as per your recommendation.

Still not working.

The errors in the log are still there:

- %VOICE_IEC-3-GW: C SCRIPTS: Internal Error (Software Error)

- SIP/2.0 500 Internal Server Error

- %VOICE_IEC-3-GW: TCL_IVR: Internal Error (Get infotag failed)

Alexander Fix
Level 1
Level 1

I removed the non-working pools / phones from the configuration and recreated them.

Now it works (without "no digit collect kpml" and without the bind commands, the bind command under voice service voip -> sip caused all inbound calls to fail).

This appliance is a f... piece of s**t

Thanks for your support Mohammed!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: