cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6316
Views
5
Helpful
26
Replies

CME 8.6 with voip.ms

Hi, I am trying to get inbound and outbound calling working. I am trying to get inbound first, and setup my config....however, it rings busy. My provider is VOIP.MS, and it shows registered on their main page and all incoming connections work fine. Even to my VM and AA system. I did a ccsip debug error and attached this with the config as well.

I need help to get our phone system up and communicating.

Thanks!

                 

 

Ping to chicago.voip.ms works fine too:

USRMIHQ#ping chicago.voip.ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 173.208.83.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/30/60 ms
USRMIHQ#

2 Accepted Solutions

Accepted Solutions

Hi Frederick,

Look like the call is been blocked by your gateway. Please add this:

voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0

Regards

Please rate all useful posts
Favor calificar todos las respuestas útiles.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie
MDGDP, CCNA, CCNA Voice, CCNP Voice Certified

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

View solution in original post

This traces doesn't actually show any call information. It is as if the call never reached the router. The trace shows an OPTIONS ping sent to the provider and that is all.

Can you check that your SIP trunk is still registered to the provider? You can use "show sip-ua register status" to find this out.

View solution in original post

26 Replies 26

Hi Frederick,

Look like the call is been blocked by your gateway. Please add this:

voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0

Regards

Please rate all useful posts
Favor calificar todos las respuestas útiles.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie
MDGDP, CCNA, CCNA Voice, CCNP Voice Certified

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

What is wierd is that inbound works, and I hear the AA but I cannot speak nor dial any choices, like it cannot hear me.

So now you're able to receive the inbound calls, right?

Please rate all useful posts
Favor calificar todos las respuestas útiles.
___________________________________________
LinkedIn Profile: do.linkedin.com/in/leosalcie
MDGDP, CCNA, CCNA Voice, CCNP Voice Certified

__________________________________________________
Please remember to rate useful posts clicking on the stars below.
LinkedIn Profile: do.linkedin.com/in/leosalcie

Yes, through Exchange UM. I can hear the Auto attendant and choices but no matter what I say or press it does not seem to get it.

Hello Frederick this  address trusted list is mechanism againts toll fraud if you leave the config that way:

You router will accept call from any ip source:

voice service voip

ip address trusted list

  ipv4 0.0.0.0 0.0.0.0

This is not recommend, take a look on this doc:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080b3e123.shtml

Regards

Leonardo Santana

Regards
Leonardo Santana

*** Rate All Helpful Responses***

Thank you, will adjust accordingly.

So two issues I am still having trouble dealing with:

1) Incoming calls not being heard by the auto attendant.

2) I need to make outgoing calls, preferably with a 9 prepended and stripped before going to SIP provider.

Can anyone help on this please?

This is my ccsip error log when dialing in:

USRMIHQ#debug ccsip error

SIP Call error tracing is enabled

USRMIHQ#

SIP: (1796) Attribute mid, level 1 instance 1 not found.

Mar 23 04:57:52.916: //1796/0D90B5378366/SIP/Error/sipSPI_ipip_update_codec_params_in_channelInfo:

failed to update call entry

Mar 23 04:57:52.916: //1796/0D90B5378366/SIP/Error/sipSPI_ipip_update_call_entry:

failed to update call entry

Mar 23 04:57:52.916: //-1/xxxxxxxxxxxx/SIP/Error/sipSPI_ipip_set_channel_count: Unable to set CHANNEL_COUNT for callid 1796

Mar 23 04:57:52.916: //1796/0D90B5378366/SIP/Error/sip_iwf_sip_copy_sdp_to_channelInfo: Channel count is not set at this point. Not SIP-SIP or SET_MODE is not done.

Mar 23 04:57:52.920: //1797/0D90B5378366/SIP/Error/sip_iwf_sip_copy_channelInfo_to_sdp: We are either escalating, orno stream found for this m-line index:1

SIP: (1797) Group (a= group line) attribute, level 65535 instance 1 not found.

Mar 23 04:57:52.988: //1797/0D90B5378366/SIP/Error/ccsip_alert_parent_or_child: Unable to add unsupported

                                      hdrs to container

SIP: Attribute mid, level 1 instance 1 not found.

Mar 23 04:57:52.992: //1796/0D90B5378366/SIP/Error/sipSPIUpdateRtpSession: voip_rtp_update_callinfo returns FALSE

SIP: (1796) Group (a= group line) attribute, level 65535 instance 1 not found.

Mar 23 04:58:14.324: //1798/000000000000/SIP/Error/sipSPIAddPrivacyHeader: Orig Container is NULL...should have value

Mar 23 04:58:14.324: //1798/000000000000/SIP/Error/sipSPIAddAssertedIDHeader: Orig Container is NULL...should have value

Mar 23 04:58:14.324: //1798/000000000000/SIP/Error/sipSPIAddPreferredIDHeader: Orig Container is NULL...should have value

Can anyone help?

daniel.bloom
Level 1
Level 1

Can you post your latest config?

For the voicemail issue can you perform the following debugs and make an inbound call then post the result.

Debug ccsip messages
Debug ccsip call

Sent from Cisco Technical Support iPhone App

Thanks sir,

I have attached the latest configuration. As of 10 minutes ago.

I also posted the debugs.

Thank you!

I will work on this config for you now. But before I do I thought it best to point out the following 2 things.

1st - Setup a firewall on your internet interface as this is currently open to the internet and your config includes your public IP address. Also the SIP service on your router is trusting all IP address which leaves you open to toll fraud. I would change the following to only trust the IP address of your SIP providers Signaling servers.

voice service voip

ip address trusted list

  ipv4 0.0.0.0 0.0.0.0

2nd - Change your password, as your config includes the password hash which can be broken. As your config allows all SSH traffic to your router someone could easily reverse engineer your password and gain access.

Dualy noted! Thanks

This will give you the basis of an outbound dial plan.

voice translation-profile SIP_OUTBOUND

translate called 2

dial-peer voice 2000 voip

description **VoIP MS OUTBOUND**

translation-profile outgoing SIP_OUTBOUND

destination-pattern 9T

session protocol sipv2

session target sip-server

session transport tcp

dtmf-relay rtp-nte

codec g711ulaw

no vad

To get the best results you will want to create multiple dial peers based on the above example, replacing the line "destination-pattern 9T" with more specific rules that relate to your countries dial plan. The above will get outbound calls working, however it relies on the interdigit timeout being triggered before the calls will be placed (so you will have to wait up to 15 seconds before the call is sent to the SIP provider).