Showing results for 
Search instead for 
Did you mean: 

CME and SIP calls through VPN



I have configured CME 4.1 to act as SIP Proxy Server,Configured it corectly so X-Lite SIP Softphone can register with it. Inside LAN network X-Lite to X-Lite calls function without the problem, but:

I connect through VPN to my LAN and register X-Lite with CME (extenssion 66) without any problem.

The other person also connects to our LAN through and registers his X-Lite with CME (extenssion 55).I would like them to talk to each other.

The problem is following. When any of us try to call eachother, the X-Lite Rings, and when a call is answered it immediatly drops with error "Internal Server Error". This is SIP 500 message.

Does anybody has a clue why is this happening and how it can be solved.


1 Accepted Solution

Accepted Solutions

Call from 2222 tries to use an unsupported speex codec. Please configure x-lite to use g711u only.

View solution in original post

13 Replies 13

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Have configured codec g711u for the voice pool

yes, I have configured it with the command

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

and then under voice poolvalso

voice-class codec 1

Are both phones registered to CME ?

Can you include the full "debug ccsip message" ?

Yes,both phones are registered to CME through VPN.

I have also to mention following.

When I connect from one location using VPN and registering to CME with IP Communicator and from other Location using VPN and registering X-Lite, calls can be placed between IP Communicator and X-Lite.

The only issue is X-Lite to X-Lite (SIP to SIP) calls


Should not be necessary, but please also configure

voice service voip

allow-connections sip-to-sip

have already configured that.

Please send the complete trace.


I will send it soon

here is the trace

Call from 2222 tries to use an unsupported speex codec. Please configure x-lite to use g711u only.


In X-Lite I have set only G711a and G711u codecs, but it was not working.

When I set only G711u codec it worked.

Thanx very much

I will grade it with 5 ;-)


Great, thanks for the nice rating and good luck!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers