cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
551
Views
0
Helpful
5
Replies
Highlighted

CME-CUBE Pick up call from ITSP issue

Hi Community,

 

I 'Think' I have got an interoperability issue with my ITSP. Pick up call from ITSP to IP Phone under CME come up with no audio at all.

 

Below is the details:
Configuration set.

  • Router CME.
  • SIP Trunk to ITSP.
  • Endpoint is Cisco SIP IP Phone.
  • CUBE Enable.
  • DID is configured
  • Hunting.

Identity Sheet.

IP AddressNumberDescription
10.18.20.121-ITSP IP
10.18.20.122-CE IP
10.10.70.2-CME
10.10.40.7103IP Phone A (IP Phone who received the call)
10.10.40.13109IP Phone B (IP Phone who pickup the call)
10.10.40.80-Microsip
-08XXXX496190 (I hide 4 digit for security purpose)Caller from outside
-02XXXX04003 (I hide 4 digit for security purpose)PSTN Number

 

Skenario 1.
Step 1. Call from ITSP to DID IP Phone A Extension 103
Step 2. Call comming to IP Phone A Extension 103 and IP Phone is ringing.
Step 3. IP Phone B Extension 109 Pickup the call.
Step 4. Call Connected but no audio on caller and called side.

Attached:

-Diagram SIP Call : Pick up Fail.jpg

-Debug ccsip message : debug ccsip message - pickup call no audio.txt


Skenario 2.
Step 1. Call from ITSP to DID IP Phone A Extension 103
Step 2. Call comming to IP Phone A Extension 103 and IP Phone is ringing.
Step 3. IP Phone B Extension 109 Pickup the call.
Step 4. Call Connected but no audio on caller and called side.
Step 5. IP Phone B extension 109 press hold, and press resume.
Step 6. Audio is normal.

Attached:

-Diagram SIP Call : Pick up with re-invite.jpg

-Debug ccsip message : debug ccsip message - pickup call wih re-invite.txt


Skenario 3.
Step 1. Call from MicroSIP (standalone SIP Endpoint) to Extension 103 IP Phone A.
Step 2. Call comming to IP Phone A Extension 103 and IP Phone is ringing.
Step 3. IP Phone B Extension 109 Pickup the call.
Step 4. Call Connected with audio normally.

-Diagram SIP Call : Pick up success from MicroSIP.jpg (*will uploaded later, because the policy of maximum attached file)

-Debug ccsip message : debug ccsip message - pickup call normal microsip.txt

 

I see that CME foward update sip message to ITSP; ITSP seems doesn't understand the massage and call come up with no audio. i have already configure sip normalization message and apply it specifically on dial-peer or Global config but problem still persist. and i have configured sip midcall-signalling block the sip message 'update' still forwarded to ITSP.


Please, advice how to fix this.

Thank you.

 

 

5 REPLIES 5
Highlighted

Really appreciate if anyone can help me out of this problem.

Highlighted

Hi Gilang,

 

i am facing sama issue, is there any update that you can share?

 

Thanks,

Anju

Highlighted

Which dial-peer you are matching for an incoming call from ITSP. Make sure you are not matching the default dial-peer 0.

*** Please rate helpful post; Mark "Accept as a Solution" if applicable

Thanks,
Haris

Highlighted


@HARIS_HUSSAIN wrote:
Which dial-peer you are matching for an incoming call from ITSP. Make sure you are not matching the default dial-peer 0.

*** Please rate helpful post; Mark "Accept as a Solution" if applicable

Thanks,
Haris


Hi Haris,

 

Thank you for ur reply,

 

I am pretty sure incoming calls from ITSP not hit default dial-peer. below is the configuration.

version 16.8
!
hostname Router_CME
!
voice service voip
ip address trusted list
ipv4 10.18.20.122
ipv4 10.18.20.121
ipv4 10.10.70.2
ipv4 10.10.40.240
ipv4 10.10.40.0 255.255.255.0
ipv4 10.10.70.130
ipv4 10.10.70.134
mode border-element
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
supplementary-service media-renegotiate
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
no h225 timeout keepalive
sip
bind control source-interface Loopback0
bind media source-interface Loopback0
registrar server
early-offer forced
midcall-signaling passthru
g729 annexb-all
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g729br8
!
!
voice class sip-profiles 1
request INVITE sip-header SIP-Req-URI modify "501@" "500@"
request INVITE sip-header To modify "501@" "500@"
request INVITE sip-header Remote-Party-ID remove
!
voice class sip-profiles 2
request INVITE sip-header From modify "<sip:A(.*)@" "<sip:(.*)\1@"
!
voice class sip-profiles 3
request ANY sip-header Allow-Header modify ",UPDATE" ""
!
voice register global
mode cme
source-address 10.10.70.2 port 5060
timeouts interdigit 2
max-dn 100
max-pool 50
load 7811 sip78xx.12-1-1-12
authenticate register
authenticate realm all
timezone 41
tftp-path flash:
create profile sync 0000510342268907
auto-register
!
voice register dn 1
number 301
name Call Center
label Call Center
!
voice register dn 2
number 302
name Call Center
label Call Center
!
voice register dn 3
number 303
name Call Center
label Call Center
!
voice register dn 4
number 304
name Call Center
label Call Center
!
voice register dn 5
number 101
pickup-group 1
name Office Room
label Office Room
!
voice register dn 6
number 102
pickup-group 1
name Office Room
label Office Room
!
voice register dn 7
number 103
pickup-group 1
name Office Room
label Office Room
!
voice register dn 8
number 104
pickup-group 1
name Office Room
label Office Room
!
voice register dn 9
number 105
pickup-group 1
name Office Room
label Office Room
!
voice register dn 10
number 106
pickup-group 1
name Office Room
label Office Room
!
voice register dn 11
number 107
pickup-group 1
name Office Room
label Office Room
!
voice register dn 12
number 108
pickup-group 1
name Office Room
label Office Room
!
voice register dn 13
number 109
pickup-group 1
name Office Room
label Office Room
!
voice register dn 14
number 200
pickup-group 2
name Information
label Information
!
voice register dn 15
number 201
pickup-group 2
name Receipt
label Receipt
!
voice register dn 16
number 202
pickup-group 2
name Receipt
label Receipt
!
voice register dn 17
number 204
pickup-group 2
name Registration
label Registration
!
voice register dn 18
number 205
pickup-group 2
name Registration
label Registration
!
voice register dn 19
number 207
pickup-group 2
name Registration
label Registration
!
voice register dn 20
number 208
pickup-group 2
name Registration
label Registration
!
voice register dn 21
number 209
pickup-group 2
name Registration
label Registration
!
voice register dn 22
number 210
pickup-group 2
name Registration
label Registration
!
voice register dn 23
number 211
pickup-group 2
name Registration
label Registration
!
voice register dn 24
number 213
pickup-group 2
name Registration
label Registration
!
voice register dn 25
number 214
pickup-group 2
name Registration
label Registration
!
voice register dn 26
number 215
pickup-group 2
name Registration
label Registration
!
voice register dn 27
number 216
pickup-group 2
name Registration
label Registration
!
voice register dn 28
number 217
pickup-group 2
name Service
label Service
!
voice register dn 29
number 220
pickup-group 2
name Collecting
label Collecting
!
voice register dn 30
number 221
pickup-group 2
name Collecting
label Collecting
!
voice register dn 31
number 222
pickup-group 2
name Input
label Input
!
voice register dn 32
number 223
pickup-group 2
name Input
label Input
!
voice register dn 33
number 224
pickup-group 2
name Input
label Input
!
voice register dn 34
number 225
pickup-group 2
name Input
label Input
!
voice register dn 35
number 226
pickup-group 2
name Input
label Input
!
voice register dn 36
number 227
pickup-group 2
name Input
label Input
!
voice register pool 1
busy-trigger-per-button 2
id mac 00D6.FEEC.8971
type 7811
number 1 dn 1
cor incoming PSTN default
dtmf-relay sip-notify
username 301 password cisco
codec g711ulaw
no vad
!
voice register pool 2
busy-trigger-per-button 2
id mac 00D6.FEEC.9014
type 7811
number 1 dn 2
cor incoming PSTN default
dtmf-relay sip-notify
username 302 password cisco
codec g711ulaw
no vad
!
voice register pool 3
busy-trigger-per-button 2
id mac 00D6.FEEC.9069
type 7811
number 1 dn 3
cor incoming PSTN default
dtmf-relay sip-notify
username 303 password cisco
codec g711ulaw
no vad
!
voice register pool 4
busy-trigger-per-button 2
id mac 00D6.FEEC.89FA
type 7811
number 1 dn 4
cor incoming PSTN default
dtmf-relay sip-notify
username 304 password cisco
codec g711ulaw
no vad
!
voice register pool 5
busy-trigger-per-button 2
id mac 00D6.FEEC.8F92
type 7811
number 1 dn 5
cor incoming PSTN default
dtmf-relay sip-notify
username 101 password cisco
codec g711ulaw
no vad
!
voice register pool 6
busy-trigger-per-button 2
id mac 00D6.FEEC.8FAC
type 7811
number 1 dn 6
cor incoming PSTN default
dtmf-relay sip-notify
username 102 password cisco
codec g711ulaw
no vad
!
voice register pool 7
busy-trigger-per-button 2
id mac 00D6.FEEC.F2AC
type 7811
number 1 dn 7
cor incoming PSTN default
dtmf-relay sip-notify
username 103 password cisco
codec g711ulaw
no vad
!
voice register pool 8
busy-trigger-per-button 2
id mac 00D6.FEEC.F2BF
type 7811
number 1 dn 8
cor incoming PSTN default
dtmf-relay sip-notify
username 104 password cisco
codec g711ulaw
no vad
!
voice register pool 9
busy-trigger-per-button 2
id mac 00D6.FEEC.F2E3
type 7811
number 1 dn 9
cor incoming PSTN default
dtmf-relay sip-notify
username 105 password cisco
codec g711ulaw
no vad
!
voice register pool 10
busy-trigger-per-button 2
id mac 00D6.FEEC.F300
type 7811
number 1 dn 10
cor incoming PSTN default
dtmf-relay sip-notify
username 106 password cisco
codec g711ulaw
no vad
!
voice register pool 11
busy-trigger-per-button 2
id mac 00D6.FEEC.F30A
type 7811
number 1 dn 11
cor incoming PSTN default
dtmf-relay sip-notify
username 107 password cisco
codec g711ulaw
no vad
!
voice register pool 12
busy-trigger-per-button 2
id mac 00D6.FEEC.F324
type 7811
number 1 dn 12
cor incoming PSTN default
dtmf-relay sip-notify
username 108 password cisco
codec g711ulaw
no vad
!
voice register pool 13
busy-trigger-per-button 2
id mac 00D6.FEEC.F333
type 7811
number 1 dn 13
cor incoming PSTN default
dtmf-relay sip-notify
username 109 password cisco
codec g711ulaw
no vad
!
voice register pool 14
busy-trigger-per-button 2
id mac 00D6.FEEC.F342
type 7811
number 1 dn 14
cor incoming Local default
dtmf-relay sip-notify
username 200 password cisco
codec g711ulaw
no vad
!
voice register pool 15
busy-trigger-per-button 2
id mac 00D6.FEEC.F356
type 7811
number 1 dn 15
cor incoming Local default
dtmf-relay sip-notify
username 201 password cisco
codec g711ulaw
no vad
!
voice register pool 16
busy-trigger-per-button 2
id mac 00D6.FEEC.F361
type 7811
number 1 dn 16
cor incoming Local default
dtmf-relay sip-notify
username 202 password cisco
codec g711ulaw
no vad
!
voice register pool 17
busy-trigger-per-button 2
id mac 00D6.FEEC.F36F
type 7811
number 1 dn 17
cor incoming Local default
dtmf-relay sip-notify
username 204 password cisco
codec g711ulaw
no vad
!
voice register pool 18
busy-trigger-per-button 2
id mac 00D6.FEEC.F370
type 7811
number 1 dn 18
cor incoming Local default
dtmf-relay sip-notify
username 205 password cisco
codec g711ulaw
no vad
!
voice register pool 19
busy-trigger-per-button 2
id mac 00D6.FEEC.F376
type 7811
number 1 dn 19
cor incoming Local default
dtmf-relay sip-notify
username 207 password cisco
codec g711ulaw
no vad
!
voice register pool 20
busy-trigger-per-button 2
id mac 00D6.FEEC.F388
type 7811
number 1 dn 20
cor incoming Local default
dtmf-relay sip-notify
username 208 password cisco
codec g711ulaw
no vad
!
voice register pool 21
busy-trigger-per-button 2
id mac 00D6.FEEC.F38C
type 7811
number 1 dn 21
cor incoming Local default
dtmf-relay sip-notify
username 209 password cisco
codec g711ulaw
no vad
!
voice register pool 22
busy-trigger-per-button 2
id mac 00D6.FEEC.F39C
type 7811
number 1 dn 22
cor incoming Local default
dtmf-relay sip-notify
username 210 password cisco
codec g711ulaw
no vad
!
voice register pool 23
busy-trigger-per-button 2
id mac 00D6.FEEC.F3A1
type 7811
number 1 dn 23
cor incoming Local default
dtmf-relay sip-notify
username 211 password cisco
codec g711ulaw
no vad
!
voice register pool 24
busy-trigger-per-button 2
id mac 00D6.FEEC.F3AE
type 7811
number 1 dn 24
cor incoming Local default
dtmf-relay sip-notify
username 213 password cisco
codec g711ulaw
no vad
!
voice register pool 25
busy-trigger-per-button 2
id mac 00D6.FEEC.F3B3
type 7811
number 1 dn 25
cor incoming Local default
dtmf-relay sip-notify
username 214 password cisco
codec g711ulaw
no vad
!
voice register pool 26
busy-trigger-per-button 2
id mac 00D6.FEEC.F3DA
type 7811
number 1 dn 26
cor incoming Local default
dtmf-relay sip-notify
username 215 password cisco
codec g711ulaw
no vad
!
voice register pool 27
busy-trigger-per-button 2
id mac 00D6.FEEC.F3E7
type 7811
number 1 dn 27
cor incoming Local default
dtmf-relay sip-notify
username 216 password cisco
codec g711ulaw
no vad
!
voice register pool 28
busy-trigger-per-button 2
id mac 00D6.FEEC.F41B
type 7811
number 1 dn 28
cor incoming Local default
dtmf-relay sip-notify
username 217 password cisco
codec g711ulaw
no vad
!
voice register pool 29
busy-trigger-per-button 2
id mac 00D6.FEEC.F41F
type 7811
number 1 dn 29
cor incoming Local default
dtmf-relay sip-notify
username 220 password cisco
codec g711ulaw
no vad
!
voice register pool 30
busy-trigger-per-button 2
id mac 00D6.FEEC.F428
type 7811
number 1 dn 30
cor incoming Local default
dtmf-relay sip-notify
username 221 password cisco
codec g711ulaw
no vad
!
voice register pool 31
busy-trigger-per-button 2
id mac 00D6.FEEC.F471
type 7811
number 1 dn 31
cor incoming Local default
dtmf-relay sip-notify
username 222 password cisco
codec g711ulaw
no vad
!
voice register pool 32
busy-trigger-per-button 2
id mac 00D6.FEEC.F49A
type 7811
number 1 dn 32
cor incoming Local default
dtmf-relay sip-notify
username 223 password cisco
codec g711ulaw
no vad
!
voice register pool 33
busy-trigger-per-button 2
id mac 00D6.FEEC.F49C
type 7811
number 1 dn 33
cor incoming Local default
dtmf-relay sip-notify
username 224 password cisco
codec g711ulaw
no vad
!
voice register pool 34
busy-trigger-per-button 2
id mac 00D6.FEEC.F4EF
type 7811
number 1 dn 34
cor incoming Local default
dtmf-relay sip-notify
username 225 password cisco
codec g711ulaw
no vad
!
voice register pool 35
busy-trigger-per-button 2
id mac 00D6.FEEC.F544
type 7811
number 1 dn 35
cor incoming Local default
dtmf-relay sip-notify
username 226 password cisco
codec g711ulaw
no vad
!
voice register pool 36
busy-trigger-per-button 2
id mac 00D6.FEEC.F753
type 7811
number 1 dn 36
cor incoming Local default
dtmf-relay sip-notify
username 227 password cisco
codec g711ulaw
no vad
!
voice hunt-group 1 longest-idle
list 301,302,303,304
timeout 10
pilot 510
!
!
voice hunt-group 2 sequential
list 107,105,106,104,108,109
timeout 10
pilot 520
!
!
voice hunt-group 3 parallel
list 301,302,303,304
timeout 10
pilot 530
!
!
!
voice translation-rule 1
rule 1 /^9\(.*\)/ /\1/
!
voice translation-rule 2
rule 1 /^101$/ /02XXXX04001/
rule 2 /^102$/ /02XXXX04002/
rule 3 /^103$/ /02XXXX04003/
rule 4 /^104$/ /02XXXX04004/
rule 5 /^105$/ /02XXXX04005/
rule 6 /^106$/ /02XXXX04006/
rule 7 /^107$/ /02XXXX04007/
rule 8 /^02XXXX0400.$/ /\0/
rule 9 /.*/ /02XXXX04000/
!
voice translation-rule 3
rule 1 /^02XXXX04000/ /501/
rule 2 /^02XXXX04001/ /101/
rule 3 /^02XXXX04002/ /102/
rule 4 /^02XXXX04003/ /103/
rule 5 /^02XXXX04004/ /104/
rule 6 /^02XXXX04005/ /105/
rule 7 /^02XXXX04006/ /106/
rule 8 /^02XXXX04007/ /107/
!
voice translation-rule 4
rule 1 /02XXXX04000/ /501/
!
!
voice translation-profile incoming
translate called 4
!
voice translation-profile outboundtoCME
translate called 3
!
voice translation-profile outbtestsipcme
translate called 3
!
voice translation-profile outgoing
translate calling 2
translate called 1
!
voice translation-profile pilot
translate called 1
!

application
service aa flash:bacd/app-b-acd-aa-3.0.0.7.tcl
paramspace english index 1
param number-of-hunt-grps 3
param menu-timeout 6
param handoff-string aa
param dial-by-extension-option 4
param moh bacd_music_on_hold.au
paramspace english language en
param max-time-vm-retry 2
param max-extension-length 3
param aa-pilot 500
paramspace english location flash:bacd/
param second-greeting-time 60
param welcome-prompt _bacd_welcome.au
param call-retry-timer 5
param voice-mail 550
param max-time-call-retry 600
param service-name callq
!
service callq flash:bacd/app-b-acd-3.0.0.7.tcl
param aa-hunt3 530
param queue-len 10
param number-of-hunts-grps 3
param aa-hunt1 510
param aa-hunt2 520
param queue-manager-debugs 1
!
!
!
voice-card 0/4
dsp services dspfarm
no watchdog
!
!
!
interface Loopback0
ip address 10.10.70.2 255.255.255.255
!
interface GigabitEthernet0/0/0
ip address 10.10.70.130 255.255.255.252
negotiation auto
!
interface GigabitEthernet0/0/1
ip address 10.10.70.134 255.255.255.252
negotiation auto
!
interface GigabitEthernet0/1/0
description ## connection to ITSP ##
ip address 10.18.20.122 255.255.255.252
negotiation auto
!
interface Service-Engine0/4/0
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
!
router eigrp 100
network 10.10.70.2 0.0.0.0
network 10.10.70.128 0.0.0.3
network 10.10.70.132 0.0.0.3
!
ip route 0.0.0.0 0.0.0.0 10.10.40.254
ip route 10.10.40.0 255.255.255.0 GigabitEthernet0/0/0 10.10.70.129
ip route 10.10.40.0 255.255.255.0 GigabitEthernet0/0/1 10.10.70.133 200
!

sccp local Loopback0
sccp ccm 10.10.70.2 identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 3 register mtpcisco
associate profile 1 register xcoder
!
!
!
telephony-service
sdspfarm units 2
sdspfarm transcode sessions 5
sdspfarm tag 1 xcoder
max-ephones 5
max-dn 36
ip source-address 10.10.70.2 port 2000
max-conferences 8 gain -6
call-park system application
moh enable-g711 "flash:bacd/en_bacd_music_on_hold.au"
web admin system name admin password P@ssw0rd!
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Jun 26 2019 17:40:00
!
!
dspfarm profile 1 transcode
codec g711alaw
codec g711ulaw
codec g729br8
codec g729r8
maximum sessions 5
associate application SCCP
!
dspfarm profile 2 transcode universal
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729br8
codec g729r8
maximum sessions 8
associate application CUBE
!
dspfarm profile 3 mtp
codec g711ulaw
maximum sessions software 10
associate application SCCP
shutdown
!
dial-peer cor custom
name PSTN
name internal
!
!
dial-peer cor list Local
member internal
!
dial-peer cor list PSTN
member PSTN
member internal
!
!
dial-peer voice 1000 voip \\ incoming to service AA translate
destination-pattern 501
session protocol sipv2
session target ipv4:10.10.70.2
voice-class sip profiles 1
dtmf-relay sip-kpml
codec g711ulaw
!
dial-peer voice 1001 voip \\ incoming to service AA pilot
service aa
session protocol sipv2
incoming called-number 500
dtmf-relay sip-kpml
codec g711ulaw
no vad
!
dial-peer voice 1011 voip
description ## Inbound - SIP Trunk - BACD ##
destination-pattern 500
session target ipv4:10.10.70.2
incoming called-number 500
dtmf-relay rtp-nte
codec g711ulaw
no vad
shutdown
!
dial-peer voice 2000 voip \\ outgoing leg 2
corlist outgoing PSTN
description ## Outbound - CME - SIP Trunk ##
translation-profile outgoing outgoing
destination-pattern 9T
session protocol sipv2
session target ipv4:10.18.20.121
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/1/0
voice-class sip bind media source-interface GigabitEthernet0/1/0
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 1002 voip \\ outgoing leg 1
description ## Inbound - CME - Telco ##
session protocol sipv2
incoming called-number 9T
voice-class codec 1
voice-class sip bind control source-interface Loopback0
voice-class sip bind media source-interface Loopback0
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 1009 voip \\ incomming leg 2
description ## Outbound - SIPTrunk - CME ##
translation-profile outgoing outboundtoCME
destination-pattern 0213950400.
session protocol sipv2
session target ipv4:10.10.70.2
voice-class codec 1
voice-class sip bind control source-interface Loopback0
voice-class sip bind media source-interface Loopback0
dtmf-relay sip-notify rtp-nte
no vad
!
dial-peer voice 1010 voip \\ incomming leg 1
description "" TESTING INCOMING INBOUND TELCO - CME ""
translation-profile incoming incoming
session protocol sipv2
incoming called-number 0213950400.
voice-class codec 1
voice-class sip bind control source-interface GigabitEthernet0/1/0
voice-class sip bind media source-interface GigabitEthernet0/1/0
dtmf-relay sip-notify rtp-nte
no vad
!

 

really appreciate any advise on this case. thank you

 

Highlighted

Just to confirm the same can you make a test call keep it active and execute these commands before and after you perform pickup. To verify which dial-peer is matched.

show call active voice compact | s PeerId

*** Please rate helpful post; Mark "Accept as a Solution" if applicable

Thanks,
Haris