cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
137
Views
0
Helpful
7
Replies

CME Sip trunk - outgoing calls not working

Hi, I have a CME with a private address. I have a dial-peer for outgoing calls to a sip provider which is requesting to use port udp 5060 as destination. I did a paquet capture in the outgoing interface and I can see it is using random destination ports. Is there a way to hardcode it?

I tried to use  session target ipv4:185.8.244.80:5060 instead of  session target ipv4:185.8.244.80 but same result.

 

 

 

 

7 REPLIES 7
Rising star

Re: CME Sip trunk - outgoing calls not working

Are you utilizing the following in your dial-peers

session protocol sipv2

 

Also if you are using private IP addresses what is your connectivity like to your SIP carrier? Can they talk to you over that private address space.

Highlighted
VIP Advisor

Re: CME Sip trunk - outgoing calls not working

CME SIP trunk will always initiate to destination port 5060 by default. It
impossible to initiate to random ports. I think you are not looking at the
right capture.

>From debug ccsip mess, you should be able to see why the calls are failing
Rising star

Re: CME Sip trunk - outgoing calls not working

I am with Mohammad here this is why I was asking to make sure your dial-peers where correct and not using h.323 which is the default. Sharing your config and the debug Mohammad is asking for would be very helpful.

Re: CME Sip trunk - outgoing calls not working

Hi, This is the config I have. Incoming calls are working good. Attached is the screenshot of the pcap on FastEthernet0/1.200. Also I attached the degub 

voice service voip
ip address trusted list
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
h323
sip
registrar server expires max 3600 min 3600
sip-profiles 1
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729br8
!

interface FastEthernet0/1.100
description ** Voice VLAN **$ETH-LAN$
encapsulation dot1Q 100
ip address 192.168.201.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
service-policy output output-L3-to-L2
!
interface FastEthernet0/1.200
description ** Data VLAN **
encapsulation dot1Q 200 native
ip address 192.168.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly in
!

no ip nat service sip udp port 5060
ip nat inside source list 100 interface FastEthernet0/1.200 overload

dial-peer voice 1 voip
description **SIP local 0**
destination-pattern 9T
session protocol sipv2
session target ipv4:185.8.244.80
incoming called-number .
voice-class codec 1
voice-class sip profiles 1
dtmf-relay rtp-nte cisco-rtp sip-kpml sip-notify

Rising star

Re: CME Sip trunk - outgoing calls not working

Here is something from you debugs that stand out to me.  What codecs does your carrier support.

SIP/2.0 488 Not Acceptable Media Via: SIP/2.0/UDP 62.210.90.142:60235;branch=z9hG4bK1490916210 From: <sip:1161@80.25.129.76>;tag=1071009364 To: <sip:0048221530029@80.25.129.76>;tag=49D0FC4-2510 Date: Tue, 06 Aug 2019 09:16:10 GMT Call-ID: 1365010232-350663368-1158547968 CSeq: 1 INVITE Allow-Events: telephone-event Warning: 304 192.168.1.2 "Media Type(s) Unavailable" Reason: Q.850;cause=65 Server: Cisco-SIPGateway/IOS-12.x Content-Length: 0
Rising star

Re: CME Sip trunk - outgoing calls not working

You can see more media Negotiation fails for the call.

Aug  6 09:16:10.483: //33432/AA13A8B98ACA/SIP/Error/sipSPIDoMediaNegotiation: 
no valid fax or audio streams
Aug  6 09:16:10.483: //33432/AA13A8B98ACA/SIP/Error/sipSPIHandleInviteMedia: Media Negotiation failed for an incoming call
Aug  6 09:16:10.483: //33432/AA13A8B98ACA/SIP/Info/ccsip_set_cc_cause_for_spi_err: Categorized cause:65, category:278
Aug  6 09:16:10.483: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_set_release_source_for_peer: ownCallId[33432], src[6]
Aug  6 09:16:10.483: //33432/AA13A8B98ACA/SIP/Info/sipSPIContinueNewMsgInvite: ccsip_api_call_setup_ind returned: SIP_UNACCEPTABLE_MEDIA_ERR
Aug  6 09:16:10.483: //33432/AA13A8B98ACA/SIP/Error/sipSPIContinueNewMsgInvite: Unacceptable media indicated for INVITE
Rising star

Re: CME Sip trunk - outgoing calls not working

Can you capture a debug cccsip messages of a successful inbound call with two way audio established. We can search the m and a lines of that debug to confirm. 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards