cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
517
Views
0
Helpful
5
Replies

connecting two sites using back to back cable.

morenike1_2
Level 1
Level 1

the ip phones conneted to Switch2 could not register with the CUCM86 that is connect to Switch1. Router1 and Router2 are connected via the E1 controller through the serial interfaces that are provided. The ip add of the CUCM is 192.168.1.6

Router(config)#do sh run

Building configuration...

Current configuration : 2134 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.20

ip dhcp excluded-address 31.31.31.1 31.31.31.20

!

ip dhcp pool VOICE

   network 31.31.31.0 255.255.255.0

   default-router 31.31.31.1

   option 150 ip 192.168.1.6

   lease 5

!

ip dhcp pool DATA

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   option 150 ip 192.168.1.6

   lease 5

!

controller E1 0/2/0

channel-group 30 timeslots 30

!

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 30.30.30.1 255.255.255.0

!

interface FastEthernet0/1.3

encapsulation dot1Q 3

ip address 31.31.31.1 255.255.255.0

!

interface FastEthernet0/1.9

encapsulation dot1Q 9

ip address 192.168.1.1 255.255.255.0

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2/0:30

ip address 20.20.20.1 255.255.255.0

!

interface Serial0/3/0

no ip address

shutdown

clock rate 2000000

!

router rip

version 2

network 20.0.0.0

network 30.0.0.0

network 31.0.0.0

network 192.168.1.0

no auto-summary

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

end

Router1#sh ip int bri

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES unset  administratively down down

Service-Engine0/1          unassigned      YES unset  administratively down down

FastEthernet0/1            unassigned      YES unset  up                    up

FastEthernet0/1.1          30.30.30.1      YES manual up                    up

FastEthernet0/1.3          31.31.31.1      YES manual up                    up

FastEthernet0/1.9          192.168.1.1     YES manual up                    up

Serial0/1/0                unassigned      YES unset  administratively down down

Serial0/2/0:30             20.20.20.1      YES manual up                    up

Router1#sh ip protocols

Routing Protocol is "rip"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Sending updates every 30 seconds, next due in 19 seconds

  Invalid after 180 seconds, hold down 180, flushed after 240

  Redistributing: rip

  Default version control: send version 2, receive version 2

    Interface             Send  Recv  Triggered RIP  Key-chain

    FastEthernet0/1.1     2     2

    FastEthernet0/1.3     2     2

    FastEthernet0/1.9     2     2

    Serial0/2/0:30        2     2

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    20.0.0.0

    30.0.0.0

    31.0.0.0

    192.168.1.0

  Routing Information Sources:

    Gateway         Distance      Last Update

    20.20.20.2           120      00:00:16

  Distance: (default is 120)

Switch1#sh run

Building configuration...

Current configuration : 1482 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport voice vlan 3

spanning-tree portfast

!

interface FastEthernet0/2

switchport voice vlan 3

spanning-tree portfast

!

interface FastEthernet0/3

switchport voice vlan 3

spanning-tree portfast

!

interface FastEthernet0/4

switchport voice vlan 3

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 9

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 9

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 9

spanning-tree portfast

interface FastEthernet0/24

switchport mode trunk

!

interface Vlan1

ip address 30.30.30.2 255.255.255.0

no ip route-cache

!

ip default-gateway 30.30.30.1

ip http server

################################################################

Router2#sh run

Building configuration...

Current configuration : 1361 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router2

!

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 51.51.51.1 51.51.51.20

!

ip dhcp pool VOICE

   network 51.51.51.0 255.255.255.0

   default-router 51.51.51.1

   option 150 ip 192.168.1.6

   lease 5

!

!

no ip domain lookup

!

!

controller E1 0/1

channel-group 30 timeslots 30

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 50.50.50.1 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 10

ip address 51.51.51.1 255.255.255.0

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1:30

ip address 20.20.20.2 255.255.255.0

!

router rip

version 2

network 20.0.0.0

network 50.0.0.0

network 51.0.0.0

no auto-summary

!

!

dial-peer voice 5000 voip

destination-pattern 5...

session target ipv4:20.20.20.1

!

!

line con 0

exec-timeout 0 0

logging synchronous

!

!

end

Router2#sh ip int bri

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            unassigned      YES unset  up                    up

FastEthernet0/0.1          50.50.50.1      YES manual up                    up

FastEthernet0/0.2          51.51.51.1      YES manual up                    up

Serial0/0                  unassigned      YES unset  administratively down down

Serial0/1:30               20.20.20.2      YES manual up                    up

Router2#sh ip route

Gateway of last resort is not set

     51.0.0.0/24 is subnetted, 1 subnets

C       51.51.51.0 is directly connected, FastEthernet0/0.2

     50.0.0.0/24 is subnetted, 1 subnets

C       50.50.50.0 is directly connected, FastEthernet0/0.1

     20.0.0.0/24 is subnetted, 1 subnets

C       20.20.20.0 is directly connected, Serial0/1:30

R    192.168.1.0/24 [120/1] via 20.20.20.1, 00:00:10, Serial0/1:30

     31.0.0.0/24 is subnetted, 1 subnets

R       31.31.31.0 [120/1] via 20.20.20.1, 00:00:10, Serial0/1:30

     30.0.0.0/24 is subnetted, 1 subnets

R

Swich 2

Switch2(config)#line con 0

Switch2(config-line)#logg syn

Switch2(config-line)#no exec-time

Switch2(config-line)#no exec-timeout

Switch2(config-line)#exit

Switch2(config)#int range fa0/1 - 4

Switch2(config-if-range)#switchport voice vlan 2

Switch2(config-if-range)#no shutdown

Switch2(config-if-range)#exit

Switch2(config)#int vlan 1

Switch2(config-if)#ip add 50.50.50.2 255.255.255.0

Switch2(config-if)#no shut

Switch2(config-if)#exit

Switch2(config)#ip default-gateway 50.50.50.1

Switch(config)#

Switch(config)#

Switch(config)#int fa0/24

Switch(config-if)#switchport mode trunk

Switch(config-if)#no shutdown

Cisco Logo                    Cisco Unified CM Administration

For Cisco Unified Communications Solutions

Navigation 

admin|Search Documentation|About|Logout

Informational Message          3 records found

Find and List Route Plan Report(1 - 3 of 3)            Rows per Page

Find             Find and List Route Plan Report           where

Pattern/Directory NumberSort Descending          Partition          Type          Route Detail

Directory Number = 3000          3000                    Directory Number          Phone = SEP00170E7DFFF6 SEP00170E7DFFF6

Directory Number = 3001          3001                    Directory Number          Phone = SEP00146AC3C745 SEP00146AC3C745

Directory Number = 3002          3002                    Directory Number          Phone = SEP00146A878E91 SEP00146A878E91

DHCP Server        192.168.1.6

Subnet IPv4        31.31.31.0

Primary Start      31.31.31.21

Primary End        31.31.31.30

Secondary Start

Secondary End

Primary Router

Secondary Router

IPv4 Subnet Mask   255.255.255.0

Cisco Unified Communications Manager Group Settings

NameRequired Field

Auto-registration Cisco Unified Communications Manager Group

5 Replies 5

yahsiel2004
Level 7
Level 7

Can you post the config of Switch2?

Yosh

HTH Regards, Yosh

Chris Deren
Hall of Fame
Hall of Fame

Are phones getting IP address with proper TFTP option?

Can you ping CUCM from the site and can you ping the phone from CUCM?

Is CUCM configured properly, i.e. CUCM service running, auto registration ON, or phones defined in CUCM?

Are there other phones working on CUCM?

HTH,

Chris

The ip phones on site 2 that has the Router2 & Switch2 using router on the stick is not registering the the ip phones on site 2. But the Router1 & Switch1 which has the CUCM register the ip phones automatically given the three ip phones ext numbers on each ip phones

Switch2#sh run

Building configuration...

Current configuration : 1481 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switch2

!

!

ip subnet-zero

!

no ip domain-lookup

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport voice vlan 2

spanning-tree portfast

!

interface FastEthernet0/2

switchport voice vlan 2

spanning-tree portfast

!

interface FastEthernet0/3

switchport voice vlan 2

spanning-tree portfast

!

interface FastEthernet0/4

switchport voice vlan 2

spanning-tree portfast

interface Vlan1

ip address 50.50.50.2 255.255.255.0

no ip route-cache

!

ip default-gateway 50.50.50.1

ip http server

!

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

login

line vty 5 15

login

!

!

end

Router2#

Router2#ping 192.168.1.6

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms

outer2#ping 192.168.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Router2#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Router2#sh ip protocols

Routing Protocol is "rip"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Sending updates every 30 seconds, next due in 12 seconds

  Invalid after 180 seconds, hold down 180, flushed after 240

  Redistributing: rip

  Default version control: send version 2, receive version 2

    Interface             Send  Recv  Triggered RIP  Key-chain

    FastEthernet0/0.1     2     2

    Serial0/1:0           2     2

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    20.0.0.0

    50.0.0.0

  Routing Information Sources:

    Gateway         Distance      Last Update

    20.20.20.1           120      00:00:26

  Distance: (default is 120)

Can you ping the phones on switch 2 from router 1?

HTH Regards, Yosh

Hi,

In router 2 you have configured a sub interface

!

interface FastEthernet0/0.2
encapsulation dot1Q 10
ip address 51.51.51.1 255.255.255.0
!

The encap is for 802.1Q VLAN 10

However you switch 2 does not have any ports in VALN 10
It seems you have set all switch ports to use VLAN 2
as their voice vlan and vlan 1 default native.

On switch 2

Change the voice vlan to be 10

Switch2(config)#int range fa0/1 - 4
Switch2(config-if-range)#switchport voice vlan 10
Switch2(config-if-range)#no shutdown
Switch2(config-if-range)#exit

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.