Showing results for 
Search instead for 
Did you mean: 
Sue Fallon

Connection Database Proxy - activate service failed

Hi there

I wonder if someone can help me with this?

I am trying to get the connection database proxy started but it just will not start.

So far i have an account that I am use to log into the Connection Servicability which has "Remote Administrator" role.

I have also set the service shutdown timeer to 999 days.

After all this the service will still not start.

Any advice would really be appriciated.

Thanks in advance
Sue image1.JPG


Chris Deren
Hall of Fame Master

You have bigger issue as none of your services are starting which has nothing to do with DB proxy service.  Is this newly installed system or existing that worked before?


This is a system that an engineer put in for us about 2 years ago.

It works fine but since I have taken over this system and tried to install some monitoring tools, I have noticed these services are not running and don't know how to get them started.

I promise you, that crlunity01 server is NOT working. As Chris pointed out, everything on it is deactivated (i.e. services are disabled). The only possible way this is working is if you have an HA node which is online. My guess is that the licenses expired or you made a change which impacted the License MAC and never rehosted the licenses.

Please remember to rate helpful responses and identify helpful or correct answers.

Sorry if I seem ignorant about this but our system is working. We can administer it and users can receive and leave voicemail fine.

I have looked at the licences for Unity and the all seem fine so I am a bit confused - am I looking in the correct place??

Looking at earlier posts regarding the License MAC, i noticed that issues may occur if changes have been made to DC's. There has been some changes on our network to DC's.

As I did not install this system and don't know much about the configuration (as I said it was an external engineer that did all the work), I am unsure how to resolve this.

I would really appriciate any help you can give.


Interesting. Does a 'utils service list' command from the CLI show the same results? If it does, I think it's time to open a TAC SR. With the database disabled, database proxy isn't going to do you any good. As you have probably noticed, the critical services lack an activate button as well (they normally can be stopped but not disabled).

If the CLI looks good and all the services are running then try a 'utils service restart Cisco Tomcat' and see if that clears things up. Note that this is service impacting to things such as web inbox, cisco PCA, administration, etc.

Please remember to rate helpful responses and identify helpful or correct answers.

Rob Huffman
Hall of Fame Community Legend

Hi Sue,

If your CUC was deployed in HA (2 server cluster) mode, it's still

possible for everything to be running with the Pub out of service.

Can you please go to Connection admin> Cisco Unity Connection Serviceability

> Tools> Cluster management and send us the screenshot.



"A smile relieves a heart that grieves" 

- Stones

Here is a list i get

Requesting service status, please wait...


Cluster Manager [STARTED]

Service Manager is running

Getting list of all services

>> Return code = 0


A Cisco DB Replicator[STARTED]

Cisco AMC Service[STARTED]

Cisco AXL Web Service[STARTED]

Cisco Audit Event Service[STARTED]


Cisco CDP Agent[STARTED]

Cisco CallManager Serviceability[STARTED]

Cisco CallManager Serviceability RTMT[STARTED]

Cisco Certificate Expiry Monitor[STARTED]

Cisco DRF Local[STARTED]

Cisco DRF Master[STARTED]

Cisco Database Layer Monitor[STARTED]

Cisco DirSync[STARTED]

Cisco Log Partition Monitoring Tool[STARTED]

Cisco RIS Data Collector[STARTED]

Cisco RTMT Reporter Servlet[STARTED]

Cisco Serviceability Reporter[STARTED]

Cisco Syslog Agent[STARTED]

Cisco Tomcat[STARTED]

Cisco Tomcat Stats Servlet[STARTED]

Cisco Trace Collection Service[STARTED]

Cisco Trace Collection Servlet[STARTED]

Cisco UXL Web Service[STARTED]

Connection Access Layer[STARTED]

Connection Administration[STARTED]

Connection CM Database Event Listener[STARTED]

Connection Conversation Manager[STARTED]

Connection DB[STARTED]

Connection DB Event Publisher[STARTED]

Connection Groupware Caching Service[STARTED]

Connection IMAP Server[STARTED]

Connection Inbox RSS Feed[STARTED]

Connection Integrated Mailbox Configuration[STARTED]

Connection License Server[STARTED]

Connection Message Event Service[STARTED]

Connection Message Transfer Agent[STARTED]

Connection Mixer[STARTED]

Connection Notifier[STARTED]

Connection Personal Communication Assistant[STARTED]

Connection Realtime Monitoring APIs[STARTED]

Connection Reports Data Harvester[STARTED]

Connection SMTP Server[STARTED]

Connection SNMP Agent[STARTED]

Connection Server Role Manager[STARTED]

Connection Serviceability[STARTED]

Connection System Agent[STARTED]

Connection Voice Mail Web Service[STARTED]

Connection Voice Recognition Transport[STARTED]

Connection Voice Recognizer[STARTED]

Host Resources Agent[STARTED]


Native Agent Adapter[STARTED]

SNMP Master Agent[STARTED]

SOAP -Log Collection APIs[STARTED]

SOAP -Performance Monitoring APIs[STARTED]

SOAP -Real-Time Service APIs[STARTED]

System Application Agent[STARTED]

Connection Database Proxy[STOPPED]  Service Not Activated

Connection Digital Networking Replication Agent[STOPPED]  Service Not Activated

Connection File Syncer[STOPPED]  Service Not Activated

Primary Node =true

Rob Huffman
Hall of Fame Community Legend

Hi Sue,

Good stuff! So we see that this is not set up as a cluster (HA mode).

Did you try what our friend Jonathan nicely suggested +5 buddy!)

'utils service list' command from the CLI

Also, can you tell us what version you are running?



"A smile relieves a heart that grieves" 

- Stones

Cisco Unity Connection version:

Rob Huffman
Hall of Fame Community Legend

Hi Sue,

It looks like this bug (at least everything is running!!)

Unity Connection Serviceability page incorrectly shows services disabled




Unity Connection  serviceability page does not display the accurate active status and  service status conditions. The web page displays 'Deactivated' and  Server Status 'Unknown'.

Services are properly running as seen from the CLI.


Unity Connection

Behavior has also been seen in and 7.1.2ES9.21900-9


Make  sure that the original administrator account for the web interface does  not have a locked or expired password as this has been seen to cause  these symptoms. (The account set up for web administration during  installation)

Last Modified:

Jul 21,2013




4 Minor


Cisco Unity Connection

Support Cases:


Known Affected Releases:





Will give this a go and let you all know if it works.

Cisco Unity Connection Serviceablility Page Display Services Deactivated

The Cisco Unity Connection serviceability page does not display      accurate Active Status and Service Status conditions. Instead, the web page      displays Deactivated and Server Status      Unknown.

This issue is documented in Cisco bug ID      CSCtd31601 (registered customers only)


Make sure that the original administrator account for the web      interface, the account set up for web administration during installation, does      not have a locked or expired password, because this has been known to cause      these symptoms. If it does, go to Users >      Administrator, click Edit >      password settings, and click unlock      password.

No joy I am afraid!!

I have unlocked the password and the password is already set to Does Not Expire.

Went back into Unity Connection Servicability and tried to start the services but NONE of them will activate!

It's been seven years

Please try Rob's way, and then go to:-


Cisco Unity Connection Administration, click System Settings > Advanced > Connection Administration

1- In Cisco Unity Connection Administration, click System Settings > Advanced > Connection Administration .
2- In the Database Proxy: Service Shutdown Timer field, enter a value between 1 and 999 days.
>> A value of zero (which is the default) disables the Database Proxy Service <<


It worked for me.

Content for Community-Ad

Spotlight Awards 2021