cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
48752
Views
49
Helpful
22
Replies

Corporate Directory getting Host not found.

mmendonca
Beginner
Beginner

Some 7941 phones can't find the corporate directory since upgrading to CUCM 8.0.3.10000-8.  Phone load is SCCP41.9-0-3S.  Forum is loaded with similar problems.  I've tried some of the solutions suggested none of which have corrected the problem.  It seems that the phones in question are being seen as 'secure' phones because they are picking up the Secure Phone URL's from Enterprise params.  I can't see why this is happening all phones are set to use the Standard SCCP non-secure profile.  The only difference I can find between 7941 that were working and ones that weren't is the URL pointers.    I tried changing the secure Enterprise params to the same as the non secure Enterprise params.  The phones picked up the new URL but still couldn't find the corporate directory (host  not found).  Guess I could try deleting the phone and recreating it but that would leave me not knowing what caused it if it's resolved by this action.  Other than that I'm running short on ideas.

I've attached the latest phone log from one of the lost 7941.  Seems it's not finding the proper .CTL file?

22 Replies 22

There is one more item to look at that can cause the "Host not found" as well as a loss of ring tones on version 8.6 and later. I am not sure which version this started in but I believe it is with 8.5 that the phones started using the configuration file for the URLs to look up services. It also used the locale file to confirm the certificates. If there is "ANYTHING" that is out of place with the certificates on the servers it can cause this process to fail and the error to occur. In my case during a rehost of my servers I was forced to reload the subscriber to get the cluster working and the database to sync. In the process the servers had created some self signed certificates. My servers originally had third party certs from our internal CA server. When I finally found this thread it got me looking at the phone logs and I could see the cert validation failures. Looking at the certificates there were several for tomcat-trust issued to the server name. The self signed cert was there along with the third party cert. To fix my system it was a matter of deleting the self signed certificates for the services that I had issued third party certificates for. After a reboot all was well (at least so far). The directory now works as well as the custom ring tones have returned.

If running on the CUCM 8.x version, because on the "Prepare Cluster for Rollback to pre 8.0 Required Field".

Need to set false, else the Https request wont work

Hi,

Do you know if this new mecanism "Services Provisioning" (set to internal) is phone depending ?

We have a lot of 7940G here and I wanted to know if it should work with this type of phone ? (firmware P0030801SR01)

Thanks you in advance,

Thierry

ma75
Beginner
Beginner

joemar2 fix worked for me. I have the new 8.51 server in a test enviroment, and the FQDN wasn't setup in DNS yet. Changing the name to IP and resetting the services worked. (and then the phone)

Hi ma75,

Ya, by default i have use the IP Address instead of the DNS.

But the problem still same.

CK,

Your best bet is to use a tftp to download the phone configuration file. You can attach it here and we can look at it for you.

Use the command below:

tftp -i 10.1.1.1 get SEP0000DEADBEEF.cnf.xml

where 10.1.1.1 will be changed to your cucm tftp server and the sep0000XXX wil be your phone mac

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

rifthy822
Beginner
Beginner

I have the same problem but I am using CCM 8.5, but my problem appeared all of a sudden. It was working fine till yesterday. Now I get host not found when I select corporate directory on my cisco 7942. 

 

Any body has any idea? 

Sean_edwards
Beginner
Beginner

Deleting ITL and CTL files from  phone and resetting fixed issue for me

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers