cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

638
Views
0
Helpful
9
Replies
Beginner

CP 3905 configure for SRST

Hi all,

I am using CP 3905 now I tried to configure SRST (10.5) but it cant register with the router. Is there any compatibility requirement for it? Can any one answer my question?

Thanks,

Tanim

9 REPLIES 9
Cisco Employee

you can check compatiblity

you can check compatiblity matrix for SRST 10.5 along with endpoints. You need take debug to check why phones is not registering ? arey you getting registered message from the phone on GW ??

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/requirements/guide/33matrix.html

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cusrst/requirements/guide/srs105spc.html

Br, Nadeem Please rate all useful post.
Beginner

Hi all, I did not debug with

Hi all, I did not debug with ccsip mess.I will try it tomorrow. Its first time I am trying to configure SRST. Here is the configuration of SRST:

!
ip dhcp pool VOICE_PCL
 network 10.14.30.0 255.255.255.0
 dns-server 192.168.12.5 192.162.12.16
 domain-name abc.local
 netbios-node-type h-node
 default-router 10.14.30.1
 option 150 ip 10.7.40.2 10.1.30.2
!
interface Vlan40
 ip address 10.14.40.1 255.255.255.0
!
!
ccm-manager switchback immediate
ccm-manager fallback-mgcp
!
!
!
call-manager-fallback
 secondary-dialtone 9
 max-conferences 8 gain -6
 transfer-system full-consult
 timeouts interdigit 2
 ip source-address 10.14.30.1 port 2000
 max-ephones 100
 max-dn 250
 system message primary SRST Mode
 time-zone 42
 time-format 24
!

As 3905 is sip should I need to source-address port to 5060 ? Please advice me..

Thanks

Tanim

VIP Advisor

Ur config for sccp srst. It

Ur config for sccp srst. It won't work for sip.

Go through srst config guide

Hall of Fame Cisco Employee

It seems to be supported,

It seems to be supported, have you already configured SIP SRST??

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cusrst/requirements/guide/srs105spc.html

HTH

java

if this helps, please rate
VIP Advisor

Can you share the output of

Can you share the output of debug ccsip mess when the phone is trying to register? Also, can you share your SRST config.

Highlighted
VIP Rising star

CP 3905 is a SIP Only Phone

CP 3905 is a SIP Only Phone you can refer the data sheet.

http://www.cisco.com/c/en/us/products/collateral/collaboration-endpoints/unified-sip-phone-3905/data_sheet_c78-651588.html.

  1.  Make sure you add Routers IP as SRST Reference in CUCM

      • Go to Systems>SRST
      • Add New SRST Refernce
      • Configure The SIP Network/IP address as Routers IP.( You can keeo 5060 port)
      • Save
      • Apply the same to the Device pool of the required. phones. and reset the phones. 
      • Verify that Phone has downloaded the SRST Reference. You do same via Settings and Browse to the Unified CM List. SRST Ip will be displayed as last one after CUCM IP address

2. Now configure the router with SIP Srst commands. Below is an example

voice service voip
ip address trusted list

ipv4 0.0.0.0 0.0.0.0

< You can allow only your subnets>
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip


sip
registrar server expires max 600 min 60


sip-ua
registrar ipv4:172.16.31.240 expires 600
<IP of SRST Gateway>


voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8


voice register global
mode srst OR  mode esrst
system message Fallback Mode
timeouts interdigit 7
max-dn 5
max-pool 2


voice register pool 1
id network 172.16.31.0 mask 255.255.255.0
<NEED TO ADJUST THIS IP and MAs as per your network>
voice-class codec 1
dtmf-relay rtp-nte

Finally test the same.

Please rate if found useful.

Thanks

Haris

Beginner

Hi Haris,

Hi Haris,

Thank you for your post. Today I've tried with your configuration but no luck yet. My phone 3905 frequently goes for registering and provisioning state but cant not register with SRST. :(

Here is the error message at SRST:

*Aug 20 06:22:04.043: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_get_listen_idb_entry: sipListenerList list is not yet created
*Aug 20 06:22:04.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_check_bind_int_comingup: no listen_idb for IDB GigabitEthernet0/0/0; check unready IDB records
*Aug 20 06:22:04.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_bindIDB_find_unready_idb: no bindIDB entry found for IDB GigabitEthernet0/0/0
*Aug 20 06:22:04.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_check_bind_int_comingup: No SIP bind to physical interface GigabitEthernet0/0/0.
exi
*Aug 20 06:22:04.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_bindIDB_find_unready_idb: no bindIDB entry found for IDB GigabitEthernet0/0/0
*Aug 20 06:22:04.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_check_bind_int_comingup: GigabitEthernet0/0/0 not an unready IDB to perform SIP bind
*Aug 20 06:22:04.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_get_listen_idb_entry: sipListenerList list is not yet createdt
*Aug 20 06:22:10.045: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_get_listen_idb_entry: sipListenerList list is not yet created
*Aug 20 06:22:11.044: //-1/xxxxxxxxxxxx/SIP/Transport/ccsip_get_listen_idb_entry: sipListenerList list is not yet created

Here is the config according to your post:

Building configuration...
ip name-server 192.168.12.5 192.168.12.16
ip domain name abc.com
!
!
ip dhcp pool VOICE_PCL
network 10.14.30.0 255.255.255.0
dns-server 192.168.12.5 192.162.12.16
domain-name abc.local
netbios-node-type h-node
option 150 ip 10.7.40.2 10.14.30.1
default-router 10.14.30.1
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0
media disable-detailed-stats
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice register global
mode esrst
timeouts interdigit 7
system message Fallback Mode
max-dn 5
max-pool 2
!
voice register pool 1
id network 10.14.30.0 mask 255.255.255.0
dtmf-relay rtp-nte
voice-class codec 1
!
voice-card 0/1
no watchdog
!
voice-card 0/4
no watchdog
!
!
spanning-tree extend system-id
!
!
redundancy
mode none
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/0/0
ip address 10.1.14.2 255.255.255.252
negotiation auto
!
!
interface Vlan30
ip address 10.14.30.1 255.255.255.0
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 10.1.14.1
ip ssh version 2
!
control-plane
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
sip-ua
registrar ipv4:10.14.30.1 expires 600
!

Any suggestion????

VIP Advisor

Try the following commands:

Try the following commands:

voice service voip

sip

bind all source vlan 30

!

voice register global

source-add 10.14.30.1

VIP Rising star

Is the phone registered  to

Is the phone registered  to CUCM and in the Phone can you see the SRST Ip.

Go to Settings>Device Configuration. You should see the SRST IP address there.

  • When you try to test the SRST Scenario, you should disable the connective to All the CUCM Nodes. In cucm Phone will show as unregistered.
  • Try to capture debug ccsip logs and attach the same.
  • Also add the SIP Bind source Command
  • voice service voip 

sip
bind all source-interface gig0/0

  • I believe your phone is not sending any requests to the Router.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here