Showing results for 
Search instead for 
Did you mean: 

CP-8851 Feature/Session Buttons Flashing Red, Amber, and Green

As the title states, my phone is flashing all three colors. The only thing that changed before this started happening, is that the phone was unplugged to be cleaned. After plugging it back in, the top buttons on both sides of the screen are flashing through each color, red, amber, and green. I am logged into it correctly and the phone appears to function as it should. I could not find anything online about all three colors flashing like this. I only found reasons for flashing of single colors. Any ideas?


Unless I am missing something, all I see is that there is an issue with the hardware and they are replacing the phone.  If it was an issue with the hardware wouldn't it affected all my 300+ 8861 phones vs just a handful?

Well, this thread is off topic in this community. Thus so many smart experts missed it thus, in turn, you may not receive answer you wish for.

My experience with this model is insufficient to provide valuable advice to you. Try to ask in community related to this product.

Anthony Holloway
Cisco Employee

I just experienced this issue/behavior after an upgrade from 11.0(1) to 11.5(1)SR1 on what seems to be a very small sample of phones in my pool of phones targeted for an upgrade.

  • Cisco IP Phone CP-8841
  • App load ID rootfs88xx.11-5-1SR1-1
  • Boot load ID sb288xx.BE-01-019
  • Version sip88xx.11-5-1SR1-1
  • Hardware revision V01

I cannot find a defect filed for this problem/behavior.

Top two buttons on the phone flash in sequence of green, amber, red constantly.  Phone seems to be working otherwise.  Neither a factory reset, nor a downgrade of firmware to previous release fixed it for me.

EDIT: I upgraded to sip88xx.11-7-1-17 and the problem was resolved.  I then reverted back to sip88xx.11-5-1SR1-1, and the problem DID NOT return.  So, the upgrade to 11.7(1) permanently fixed the issue for me.

I have/had this problem with a 8811 and this post was helpful, until it wasn't... I downloaded, extracted, uploaded each file to TFTP on each server, restarted TFTP service, changed load for the problematic phone, Saved and Applied Config. The phone updated the firmware, rebooted, and there were no more flashing lights. Great, I thought...

Then I removed the manual load entry, Saved and Applied Config. During the firmware upgrade process (back to 12.5(1)SR3) the flashing lights returned. I don't know which firmware version introduces this bug, so I'll stay on an old firmware for now...until TAC can assist further.


I had the same or a similary issue. A CP-8841 w/ flashing red light and prompt login with 1. Service domain, 2. Username, and 3. Password.

Later found the the voice vlan was not configured on the port. Configured on connected switch:

conf t

int gi XX/XX/XX

switchport voice vlan XX


no shut



Phone then retrieved an IP address (visual in CUCM), pulled new config file from TFTP, upgraded, and Registered to CUCM.

Rob Huffman
Hall of Fame Community Legend


Just as an FYI there is a recent Sev.3 bug that you can use to track this bug;

88XX IP Phone buttons flash red, amber, and green in a continuous cycle

Upgrading the firmware to sip88xx.11-7-1-17 fixed the problem for me. 

I can confirm that the issue is gone in cmterm-88xx.11-7-1-17



The issue is back again in cmterm-88xx.12-0-1SR1-1 for me.

I also had this issue. Was able to resolve it by entering an intermediary firmware load on the device under "Phone Load Name"This forces a new installation since it was not the active or inactive load. Then I added the old firmware load to that field to completely wipe the 12.0.1 load from the device, let it upgrade, then cleared the Phone Load Name so it would reinstall 12-0-1SR1-1 again. No more red/amber/green lights. I'm not sure if there is a more efficient way to wipe the inactive load from a phone to force a reinstall.


I have the problem on a 8845 phone after a network switch swap/upgrade. The recently installed phone worked fine for 30-45 days up until the network switch was swapped out. Phone was running "12-0-1ES-2" firmware and upgrading to "12-1-1-12" did not fix the problem. There are several 8845 phones currently patched into the same network switch that were not affected.

This process worked for me on an 8811


This problems occurs during firmware load process. In order to correct this problem load the old firmware as the active load this should stop the flashing. Then reload the new firmware again should be set to go!!

I got 8851 with firmware Ver: 12-1-1SR1-4 With this issue (only 1 at this time having this problem),

I tried downgrade to 11-7-1-17 and the flashing issue gone,

But when i upgrading to Ver 12-1-1SR1-4 - the issue occured

in the Bug Search Tool:


Further Problem Description:
Please contact TAC and reference this issue if further assistance is required."

Someone solved this issue?

At the moment I have the same issue in a cucm 12.x cluster with more than 200 CP-8841 phones. 

Luckly at the moment just one phone have that issue. But RMA is not an option, if all the phones are affected.


Active Load ID: sip88xx.12-0-1-11
Inactive Load ID: sip88xx.10-3-1-20


Interesting about the BUGID: CSCve49657 is that fixed releases are listed, but those releases aren't available for download.


Known Fixed Releases: 
So now I will try to fix the problem with the cmterm-88xx-sip.12-1-1SR1-4.k3.cop.sgn release and hope that this solve the problem. If not, I will try to downgrade to 11-7-1-17. 
Best Regards


Active load: sip8845_65.12-1-1ES-6

In Active load sip8845_65.11-5-1-18

Switching the loads did not work for me.  After replacing the original phone, I did deleted the blinking phone.  Did a Super Copy from a different device.  Blinking stopped and phone fine.

Recognize Your Peers
Content for Community-Ad