cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
770
Views
0
Helpful
24
Replies
Highlighted
Beginner

cube to sip service provider

we have a 4300 serie router , and a sip trunk to a service provider, outgoing calls are working perfectly but not incoming; having try to "debug ccsip messages" for an incoming call, there is no output at all, while it works for an outgoing call, we want to know if the call is hitting the router ?. thank you
24 REPLIES 24
Highlighted
Cisco Employee

Take a pcap on the external interface of the CUBE.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Highlighted
Beginner

Hi, 

 

Check the SIP service is running.

 

show sip service

You should see "SIP service is up"... If not, then I would suggest you check the SIP service configuration and make sure it matches with the suppliers configuration. 

 

Also, if you are debugging SIP calls and not getting any information from using the messages filter, i would rather run "debug ccsip allthis will give you every bit of information from the invite attempt.

 

If you get a response from this, upload on here and I will do my best to help out. 

Highlighted

yes i thing the call hit the router as we did a pcap capture; attached the "cap buffer detailed"

Highlighted

Can you give me the actual pcap please ? Monitor buffer is not helpful for troubleshooting. All it does is lets us know if a capture was correct or not.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Highlighted

hi, attached the pcap file

thank you

Highlighted

Do you have your service provider IP address in the voip trust list?

 

Mary Beth

Highlighted

yes i do 

Highlighted

Such behavior is only seen when the IP is not trusted.

Firstly make sure you have the correct ip in there with the following config

 

voice service voip
 ip address trusted list

 ipv4 196.41.228.32 255.255.255.255

 

If its still not working try disabling the toll fraud app for testing purpose and collect debug ccsip all

the toll fraud app can be disabled with command:

voice service voip

no ip add trusted auth

 

HTH

Chuck

Highlighted

no problem with the trusted list, 

is it normal there is nothing shown on the debug ccsip ALL ( just messages bestween the cucm and the router )

but on the PCAP we see the invite message  ?

 

thank you

Highlighted

Can you share the pcap ? I requested this previously as well. If the messages appear in the PCAP but not in the debugs, it might related to the fact that the router is not listening on the port the traffic is being sent on for this particular application i.e.SIP.

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"
Highlighted

hi, i shared the pcap in my previous messages, just take a look at it 

thanks

Highlighted

We need your help to help you.

 

The capture you have shared is .txt, we cant open .txt in wireshark, we need actual .pcap file.

Hope you understand. If its your companies policy that you cant share those details publicly.

Then I would request you to open a TAC case so that they can help you.

 

Chuck.

Highlighted

hi, i'm sorry didn't realize , attached the file

Highlighted

The destination IP that you see in the pcap, which interface is that on the router ? Add an output for "show udp detail"

Nipun Singh Raghav
"We cannot solve our problems with the same thinking we used when we created them"