cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1286
Views
0
Helpful
3
Replies
Contributor

CUBE: Using SIP-profiles to repair ip-addresses behind a NAT firewall

Does anyone have shareable examples?

I have a CUBE behind a VMwareEdge firewall, performing NAT towards the ITSP.

When I receive an "OPTIONS" from the ITSP, the external ip-address is presented to my CUBE, and teh request is rejcted as shown below.

*Jan  5 10:32:49.634: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

OPTIONS sip:2.106.44.22 SIP/2.0

Via: SIP/2.0/UDP 213.83.164.141:5060;branch=z9hG4bK74df1bb9;rport

Max-Forwards: 70

From: "hemmeligt" <sip:hemmeligt@213.83.164.141>;tag=as75ab17ef

To: <sip:2.106.44.22>

Contact: <sip:hemmeligt@213.83.164.141:5060>

Call-ID: 11d4450f7621780f149be57b37f24c5e@213.83.164.141:5060

CSeq: 102 OPTIONS

User-Agent: Condor_gw1

Date: Thu, 05 Jan 2017 10:48:24 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE

Supported: replaces

Content-Length: 0

 

 

*Jan  5 10:32:49.634: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 400 Bad Request - 'Invalid IP Address'

Via: SIP/2.0/UDP 213.83.164.141:5060;branch=z9hG4bK74df1bb9;rport

From: "hemmeligt" <sip:hemmeligt@213.83.164.141>;tag=as75ab17ef

To: <sip:2.106.44.22>;tag=46A52250-1E1F

Date: Thu, 05 Jan 2017 10:32:49 GMT

Call-ID: 11d4450f7621780f149be57b37f24c5e@213.83.164.141:5060

Server: Cisco-SIPGateway/IOS-15.4.3.M

CSeq: 102 OPTIONS

Content-Length: 0

 

My CUBE are using 10.190.87.100 for the interface receiving packets from the ITSP.

CUBE configuration attached, "voice class sip-profiles " most certainly flawed.

fortvald
Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Participant

Hi,

Hi,

Please correct me if I am wrong.

Do you wish to modify OPTIONS sip:2.106.44.22 SIP/2.0 to OPTIONS sip:10.190.87.100 SIP/2.0 ?

if that's the case then you would need add the following line in your sip-profiles.

request OPTIONS sip-header SIP-Req-URI modify "sip:2.106.44.22 SIP/2.0" "sip:10.190.87.100 SIP/2.0"

Please rate and mark if helpful

Regards,

Adarsh Chauhan


Please rate and mark correct if helpful
Regards,
Adarsh Chauhan
3 REPLIES 3
Participant

Hi,

Hi,

Please correct me if I am wrong.

Do you wish to modify OPTIONS sip:2.106.44.22 SIP/2.0 to OPTIONS sip:10.190.87.100 SIP/2.0 ?

if that's the case then you would need add the following line in your sip-profiles.

request OPTIONS sip-header SIP-Req-URI modify "sip:2.106.44.22 SIP/2.0" "sip:10.190.87.100 SIP/2.0"

Please rate and mark if helpful

Regards,

Adarsh Chauhan


Please rate and mark correct if helpful
Regards,
Adarsh Chauhan
Contributor

Just tried the suggested

Just tried the suggested configuration, no change in behavoir though.

result from "Tools Catalog SIP-Profile Test Tool" attached.

Also current config. Any help appreciated

fortvald
Highlighted
Contributor

The advise was right on the

The advise was right on the spot.

Unfortunately I was also missing the "inbound", for sip profiles, once that was corrected the profiles did their job.

fortvald
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards