cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1317
Views
10
Helpful
3
Replies

CUBE with Webex Calling SDP

Hi 

I have a vCube running Version 17 and all is configured. Sip Trunk to Webex Calling and another to our PSTN provider (also SIP trunk).

Now we were testing some calls and have a strange behavior.

The received Invite from Webex contains three lines for the video codec in sdp

 

Received
a=rtpmap:112 H264/90000 a=fmtp:112 profile-level-id=640c16;packetization-mode=1;max-fs=3600;max-mbps=108000 a=rtpmap:111 H264/90000 a=fmtp:111 profile-level-id=428016;packetization-mode=1;max-fs=3600;max-mbps=108000 a=rtpmap:110 H264/90000 a=fmtp:110 profile-level-id=428016;packetization-mode=0;max-fs=3600;max-mbps=108000

 

The Invite sent to the provider contains also three lines but two lines have the same value, which will result in a 400 bad request

 

Sent
a=rtpmap:98 H264/90000
a=fmtp:98 profile-level-id=640C16;packetization-mode=1;max-mbps=108000;max-fs=3600 a=rtpmap:98 H264/90000 a=fmtp:98 profile-level-id=428016;packetization-mode=1;max-mbps=108000;max-fs=3600 a=rtpmap:99 H264/90000 a=fmtp:99 profile-level-id=428016;packetization-mode=0;max-mbps=108000;max-fs=3600

It seems that the cube assume "..it is actually the same stuff so just use the same rtmap again.."

 

I was trying to configure a video codec on the codec list, but this didn't change anything. Modifying the SDP a= header is not possible as I understood from cisco documentations.

Did anyone had the same issue and resolved it or have an idea how to fix it?

Thanks

Eike  

 

 

 

1 Accepted Solution

Accepted Solutions

Nuno Melo
Enthusiast
Enthusiast

Assuming your provider does not support video codecs witch is usual on PSTN , you can use the following to completely strip video codecs:

Device(config)# voice service voip
Device (config-voi-serv)# sip
Device (config-voi-sip)# audio forced
Device (config-voi-sip)# end

 

This will make the cube strip any video information on invites towards isp, if you don't want to disable video cube wide and can make it dial-peer specific using voice-class sip audio forced on the dial-peer

 

View solution in original post

3 Replies 3

Nuno Melo
Enthusiast
Enthusiast

Assuming your provider does not support video codecs witch is usual on PSTN , you can use the following to completely strip video codecs:

Device(config)# voice service voip
Device (config-voi-serv)# sip
Device (config-voi-sip)# audio forced
Device (config-voi-sip)# end

 

This will make the cube strip any video information on invites towards isp, if you don't want to disable video cube wide and can make it dial-peer specific using voice-class sip audio forced on the dial-peer

 

Hi Eike,

on dial-peer pointing your provider , add this.

no voice-class sip pass-thru content custom-sdp

 

It strips custom sdp message so your provider can receive a standard formatted sdp message.

 

HTH

 

Cheers

 

Carlo 

Please rate all helpful posts "The more you help the more you learn"

Thank you guys

 

I did both of the commands already as workaround. The command "no pass-thru content custom-sdp" was already applied at the tenant section. Audio forced solved it, I was just curious how this can happen.

 

Eike

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: