cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3035
Views
5
Helpful
11
Replies

CUC 7.x - No Ringback When Releasing to Switch...

dan
Beginner
Beginner

Here is my scenario:

  • The customer would like the Front desk phone to ring for 20 seconds
    • If no answer between the hours of 0800 and 1700 the call should roll to a hunt group for all engineers
      • If no answer there it will forward to the answering service
    • If no answer between the hours of 1700 and 0800 the call should be forwarded to the answering service

The front desk phone is configured to forward to voicemail if there is no answer in 20 seconds.

Once the call hits voicemail it is transferred to a "Engineers" call handler.

The call handler is on a schedule and configured as described above.

Here is the issue:

When the call goes to voicemail and CUC is supposed to release it to the switch all the person on the phone hears is dead air yet the hunt group is ringing.

I know that when you get dead air such as this it usually means that CUC is not releasing the call to the switch properly but I cannot seem to nail it down.

Any assistance would be greatly appreciated!

Thanks!


Dan

1 Accepted Solution

Accepted Solutions

Im pretty sure you have an issue at the gateway/CUCM with ringback.    Also, it would on hurt to upgrade your CUCM and CUC when you get a chance.  There are a couple reports of bugs with SIP and transfers.


here is one:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCso04169&from=summary

If there is one, there are typically others

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCta92144&from=summary

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsm31029&from=summary

You can run a quick test and use an internal IP phone to call CUC Call Handler.  (Create a CTI, forward to unity,)  Hit the default opening greeting, enter in a mailbox to transfer to, Unity should do a transfer back out to CUCM and you will hear ring.

I suspected the call was coming from external.  There have been issues with PIMGs, T1 and H323 connections via CUCM to CUC and no ring backs.

Without some traces, it will be hard.  (its hard enough trying to find this needle)  but i suspect (or possibly) there is a command missing in the SIP gateway to provide ringback.

Here is an H323 no ringback doc also.


http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080094c33.shtml

Hope this helps!

View solution in original post

11 Replies 11

Tommer Catlin
Advocate
Advocate

Have you tried to release it to a non-hunt group number to see what happens?  If its consistantly dead air, then you know its a system wide problem with CUC.

Thank you for the response!

I just tried it to an extension that is not a hunt group and got the same result...no ring back.

Any thoughts?

Dan