cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

27739
Views
115
Helpful
14
Replies
Highlighted

CUCM 10.5 vmware tools

I have recently upgraded from 9.1.2 to 10.5.  Everything went fine with the exception of vmware tools.  VCenter shows that vmware tools are installed, but out of date.  When I do utils vmtools refresh it tells me that no vmware tools are installed on the system at all.  I have tried mounting the install from vcenter and rebooting the server but I always get the same thing.  Presence and my subscriber server say the same thing, but oddly enough Unity updated just fine and reads as current.

 

Has anyone else seen this and found a way to update vmware tools?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate

I had issues with it and I

I had issues with it and I had to put the firewall to permissive, install the vmtools and then turn on the firewall back on. utils os secure permissive and utils os secure enforce are the commands.

Please rate useful posts.

View solution in original post

14 REPLIES 14
Highlighted
Advocate

I had issues with it and I

I had issues with it and I had to put the firewall to permissive, install the vmtools and then turn on the firewall back on. utils os secure permissive and utils os secure enforce are the commands.

Please rate useful posts.

View solution in original post

Highlighted

Worked like a champ.  Thanks.

Worked like a champ.  Thanks.

Highlighted

Hi George, thanks for the tip

Hi George,

 

thanks for the tip, but unfortunately this worked only for one of four servers. But together with TAC we figured this workaround out:

 

1. Check the Status of the VMware Tools in the VMware Client. It should show the status "not installed"

2. Disable CCM Firewall (utils os secure permissive)

3. Restart Server the Server and check if the VMware Client shows now "Out of date" the VMware Tools. If not, restart again.

4. Start the VMware Tools installation from VMware Client in Automatic Modus

5. Check Status and activate the firewall with utils os secure enforce.

 

best regards

Christian

- Please rate helpful posts -
Highlighted
Engager

I've recently had problems

I've recently had problems with updating VMWare tools on some servers.

 

If, in vCentre, it shows the VM as having no VMWare tools installed, then you need to reboot the server.

 

If it shows VMWare tools as out of date, you can then, without a reboot, do:

  • utils os secure permissive
  • Automatic VMWare tools update from vCentre
  • utils os secure enforce

 

GTG

Please rate all helpful posts.
Highlighted

"Like a champ" CLI:admin:

"Like a champ"

 

CLI:

admin: utils os secure permissive

admin: utils vmtools refresh

admin: utils os secure enforce

Highlighted

Worked perfectly in release

Worked perfectly in release 11.

CallManager CLI

admin: utils os secure permissive

VMware ,

right click on host

right click on guest, select Install Upgrade VMware tools, select interactive upgrade then OK

CallManager CLI

admin: utils vmtools refresh

After warning that vmware tools is out of date and system will reboot twice it select cli "y"

CM will reboot twice and VMware in shows VMware tool up to date

Highlighted
Beginner

this worked for my UCCX

this worked for my UCCX server.  However, it had already failed on the UCM servers and therefore removed the VMware tools all together.  So I don't have the option to upgrade and only have the option to install.  When I mount the install within vCenter and then run the command "utils vmtools refresh" it tells me that there are no tools installed and this is probably because they were recently upgraded and the server wasn't rebooted.  I restarted a few times just to be sure and it still won't install.  I also tried setting the vm to automatically install/upgrade the tools at restart and that didn't work either.  I have a TAC case open, but I'm waiting to hear back from them.  Any ideas how to install the tools when they're not currently installed?

Highlighted
Beginner

Cisco had to install the

Cisco had to install the tools with root access.  The TAC engineer was very hesitant to do this and kept looking for a COP file for the install that apparently doesn't exist.  I think this method was support for version 8 but after 8.5 they stopped using the COP file.  After convincing TAC that root access was the only way, I mounted the VMware tools iso for them and they manually did the tools install via the CLI with root access.  I'm now current again and will make sure I put the firewall in permissive mode before doing any tools upgrades in the future.

Highlighted
Enthusiast

Thanks!! This did the job for

Thanks!! This did the job for us too.. 

 

Although this sounds like SELinux command rather than firewall. It should be in their upgrade guide or something though. 

Highlighted
Advocate

SELinux is the firewall in

SELinux is the firewall in later versions.
Please rate useful posts.
Highlighted

No its not, SElinux has

No its not, SElinux has nothing to do with Firewalls, that's iptables in verison 6 of Red Hat.

Selinux is more about where what app can read and write to the filesystem. 

 

see 

 

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Security-Enhanced_Linux/sect-Security-Enhanced_Linux-Working_with_SELinux-Enabling_and_Disabling_SELinux.html

 

 

CCIE-Collaboration #24527
Highlighted
Enthusiast

:)

:)

Highlighted
Advocate

Whatever you say sir. Windows

Whatever you say sir. Windows firewall is not a full blown firewall that you can deploy in the perimeter network and have it do DPI or things like that. You can allow programs through the firewall and open ports, same thing with SElinux (like you mentioned). Turn off SElinux and its like turning off firewall on Windows systems.

Anyways thanks for the enlightenment. 

Please rate useful posts.
Highlighted
Cisco Employee

To close the loop on this

To close the loop on this post:

There is a cop file available and it is the fix for this issue (instead of the workaround of putting SELinux into permissive).

You can download the COP file on CCO.

http://www.cisco.com/web/software/282074227/127489/README_CER_COP_VMtool.txt

CreatePlease to create content
Content for Community-Ad
Future of Work Virtual Summit Day 5

Cisco COVID-19 Survey