Showing results for 
Search instead for 
Did you mean: 

CUCM 8.5: how to reset the Primary User Device to <None>

Hoa Dao

I need to reset the Primary User Device to <None> using the Bulk admin tool.  No-matter what I use, the job is submitted and sucessfull, but the field is NOT reset.  How can I do this?

11 Replies 11

%NULL% is generally the clear keyword, assuming that BAT will accept it for that field (it doesn't in all cases). If that doesn't work you could export the phone with all details, delete it to forcefully break the link, and then readd it.

Please remember to rate helpful responses and identify helpful or correct answers.



What does the BAT log report indicate after making the changes?

Can you paste the log snippets for the job from Job Scheduler page?

Sent from Cisco Technical Support iPad App

Regards, Avinash

Here is my csv input file:



The output:

Update Users - Custom File

Begin Time : 07/08/2013 07:41:16

Query :

Update Users in update_users_primary_user_device.csv

Failure Details :

users          Error Code          Error Description


Warning :

LDAP Sync status is enabled.Some fields cannot be updated.

******** NO ERROR FOUND ********

Result Summary :

UPDATE for 1 USERS passed.

UPDATE for 0 USERS failed.

End Time   : 07/08/2013 07:41:17


Is CSV file correct ?

Have you configured the 3 columns yourself? Try using the default BAT template from CUCM and see if your update works ?

Regards, Avinash

Yes, my csv is correct.  It is the shorten version of the BAT template. 

I also try with the default BAT template with the following value in the Primary User Device field:

  • NULL
  • %NULL%

  • empty string (0 length)

The NULL, %NULL% and returns with "PRIMARY USER DEVICE: NULL doesnot exist" error.  The last value (empty string) does not give errors, but the field is NOT reset to


Have you attempted to import the file leaving the "Primary User Device"field blank? I believe you must specify a special character in any field you want BAT to ignore. In this case you want the field overwritten so leave the field blank in your csv.

Sent from Cisco Technical Support Android App

Yes, I did try that; and all other posibilities I could think of.

The strange thing is I am able to set the Primary User Device field to using the CUCM web interface.  Through BAT it does not work.  I have to reset the field for few hundred users

This can be done and here's how:

Export Users --> All User Format

Remove contents of Primary Device field. (the field should be blank)

User ID is mandatory, leave alone

Add # to all other fields and specify that as the value for fields to be ignored when updating users.

Save the csv and then rename it to .txt

***NOTE - do not "save as" .txt as this does not work. Just rename csv file to .txt


Thanks JP.  But it does not work.  Attached is the input file

Did you disable mobility in the update file? Disable Mobility by placing f in the "Enable Mobility" field, then re-run the job.

same behaviour with Enable Mobility disabled

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers