Showing results for 
Search instead for 
Did you mean: 

CUCM 9.1 Call Forward with Authorization Codes

Matthew Miktus

Client has the TelCo managing their Authorization codes.  They want to be able to call-forward from a phone to a mobile by pressing CallForward All, then dialing 91212XXXXXXX <introduce a pause> then add the 4-digit auth code.


I created a route-pattern that was 9.1[2-9]XX[2-9]XXXXXX**XXXX


I created a new Partition called CFWD and a new CSS that accounts for this.  when the string is matched, the phone goes into CFWD-ALL mode and shows call-forwarded to 91212XXXXXXX**XXXX as it should.  


When i dial the ext of the phone, it attempts to dial out, but never dials the extra 4 digits, or, when it does dial, it's so fast the digits are missed all together.


Is there anyone who has had to deal with something like this, and if so, is there a work-around?  or suggestions for a work-around?



7 Replies 7


Hi Matt,

Starting from CUCM 9.X, Route Patterns now support pauses (commas) for
authorization codes.

So why you don't try something like this on the route pattern 9.1[2-9]XX[2-9]XXXXXX,,XXXX


ok, i can try that, but what does the user enter from a desk-phone to indicate a pause when attepting to cfwd-all to a cel phone?


so, from an 8945, user picks up and presses cfwd, then dials 91212XXX1234 + <pause character(s)> + <access code>.

what would be the pause character from a phone?

It looks like they will have to do it from the user page , if they have access.




i've been "playing" with this for a little while today, and have had no luck.

it appears CUCM is sending the entire string - 9.1+area code+Number+FAC en-block; but what verizon needs to see is (strip the 9)1+area code+number come through first, THEN it expects the FAC after the first 10 digits have been collected. 


I've tried cfwd to a speed dial with pauses - 91212XXXXXXX,,,<FAC> - time out then busy.

If i CFWD All to a speed-dial with 91212xxxxxxx, the call routes, then i'm prompted for the FAC.

It doesn't matter how many pauses I insert, it never completes the first leg, instead just busy's out.


banging my head against the keyboard


Did you find a solution for this, I have this 'exact' same issue. Just started hacking it about 10 minutes ago. the "," is not allowed from the self care portal. ONly # and *. Still going.

I never found a resolution. I opened a case with Cisco TAC, but they were no help.some phones allow you to enter pauses from the phone. But not all. 

if you figure something out please let me know.

Update: But not good news. Found this doc on the 78XX series and it still doesn't work. It says simply to add a "," to the speed dial string. Seems that when presented with the tone from the carrier the digits are sent, but rather when the call completes to the called party, we can hear the dtmf come through.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: