cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

2744
Views
0
Helpful
24
Replies

[CUCM 9.x] No dial tone when calling in

I have a fairly new setup with CUCM and CUC running 9.1 version. Calls are going to the CUBE via SIP trunk from the provider, then they get sent via another SIP trunk to the CUCM, which then forwards it to the Call Handler in CUC (for business hours and holiday reasons). CUC then redirects the calls to Hunt Group 600 to ring the required phones.

Now when the some makes a call to the system from outside does not hear any ringing. However if the person is to call a someone's phone directly then the tone is there. DDI and main number use the same Route Pattern for translation and I have the outside dialtone ticked on the CUBE config as well as the Hunt Group.

Am I missing something?

1 ACCEPTED SOLUTION

Accepted Solutions
Contributor

Re: [CUCM 9.x] No dial tone when calling in

On the trunk you can assigned a Media Resource Group list and in this list is a Media Resource Group that contains certain resources like Conference, MTP, MOH and ANN.  ANN=Annunciators.  MRGL can be assigned at the trunk level in this case or device pool.  My question has a MRGL been assigned to either place and if so does it contain the CUCM

Annunciators resources?

View solution in original post

24 REPLIES 24
Highlighted
Contributor

[CUCM 9.x] No dial tone when calling in

What does the cube dialpeers look like?  You might be needing this on the voip dialpeer, but without seeing your dialpeer configuration for these calls it might be hard to tell.  You can try this and see if it works.

progress_ind setup enable 3

progress_ind progress enable 8

Re: [CUCM 9.x] No dial tone when calling in

Hi Kevin,

This is my config of the dial-peers.

dial-peer voice 1 voip

description **Incoming Calls**

destination-pattern 441525......

session protocol sipv2

session target ipv4:192.168.13.101

voice-class codec 1 

voice-class sip early-offer forced

dtmf-relay rtp-nte sip-notify

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

dial-peer voice 10 voip

description **Outgoing Calls**

destination-pattern 0.T

session protocol sipv2

session target sip-server

voice-class codec 1 

voice-class sip early-offer forced

dtmf-relay rtp-nte sip-notify

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

dial-peer voice 2 voip

description **Incoming Calls**

destination-pattern 441908787...

session protocol sipv2

session target ipv4:192.168.13.101

voice-class codec 1 

voice-class sip early-offer forced

dtmf-relay rtp-nte sip-notify

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

dial-peer voice 100 voip

description **Inbound dial-peer for Outbound calls**

session protocol sipv2

session target sip-server

incoming called-number 0.T

voice-class codec 1 

dtmf-relay rtp-nte sip-notify

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

dial-peer voice 101 voip

description **Outbound Emergency calls**

session protocol sipv2

session target sip-server

incoming called-number 0...

voice-class codec 1 

dtmf-relay rtp-nte sip-notify

ip qos dscp cs5 media

ip qos dscp cs4 signaling

no vad

Also, what you suggested made no difference.

Contributor

Re: [CUCM 9.x] No dial tone when calling in

Try using the commands I suggested on your incoming dialpeer.  If that is unsuccessful, please provide a sho run excluding any passwords.  Also, please provide the following debug's:

debug ccsip messages

debug ccsip calls

debug voip dialpeer inout

Thanks,

Re: [CUCM 9.x] No dial tone when calling in

Please see attached debug. Thanks for your help so far but the commands for DPs didn't do any difference.

Beginner

[CUCM 9.x] No dial tone when calling in

This is my config of the dial-peers.

Покажи dial-peers pots

[CUCM 9.x] No dial tone when calling in

У меня только sip. Проблема устронена, спасибо.

Re: [CUCM 9.x] No dial tone when calling in

Here is the show run with sensitive info removed.

Contributor

Re: [CUCM 9.x] No dial tone when calling in

First Suggestion:

Your matching incoming dialpeer of 10 and outgoing dialpeer of 2. 

Dialpeer 2 add

incoming called XXXXXX <<<--should match destination-pattern

progress_ind setup enable 3

progress_ind progress enable 8

see if that helps..

provide debugs again if no go..

Re: [CUCM 9.x] No dial tone when calling in

Sorry, makes no difference.

Re: [CUCM 9.x] No dial tone when calling in

Here is the debug. Many thanks

Contributor

Re: [CUCM 9.x] No dial tone when calling in

Going out on a limb considering i can't look at your CUCM trunk configuration..

On your SIP profile in CUCM, do you have disable early media 180 checked?  try checking this to see if it helps or unchecking it. One thing that is really bothering me as well is this statement on the dialpeer to CUCM.. By default CUCM is delayed offer. 

voice-class sip early-offer forced is not needed to CUCM.  It wasn't until 9.X that early offer is supported, but you need

Re: [CUCM 9.x] No dial tone when calling in

Hi Kevin,

Sorry but none of these seem to make any difference.

1) I tried checking "Disable Early Media on 180" and making a call in, nothing - just silence but the internal phones ring.

2) Then I tried taking out "early-offer forced" as well which made no difference either.

Do I need to have 2 dial-peers on the CUBE, one for accepting the call from the VoiP provider and the second one for passing this call to the CUCM? At the moment I only have the one.

Contributor

Re: [CUCM 9.x] No dial tone when calling in

Do you have an MRGL assigned to the trunk that contains a ANN..? 

Also, bind you sip traffic to a single interface.  this can cause issues as well. 

For example:

voice service voip

sip

     bind control source-interface GigabitEthernetx/x

     bind media source-interface GigabitEthernetx/x

Re: [CUCM 9.x] No dial tone when calling in

Sorry, no clue what the top bit means?

When I bind sip to Port-Channel 1.1 (which is my VLAN1), I get no audio when making a call.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here