cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
797
Views
5
Helpful
15
Replies
Highlighted
Beginner

CUCM Backup fails to a specific SFTP server

Hello,

 

I manage two clusters, Cluster A and Cluster B connected over a WAN.
Cluster A has a publisher and 8 Subscribers
Cluster B has a publisher and a Subscriber

 

• CUCM in cluster B is UNABLE to backup to SFTP server in Cluster B network. Error message is "update failed :       unable to access sftp server. Please ensure the username and password are correct"
• CUCM in cluster B is able to backup to SFTP Server in cluster A network
• CUCM in Cluster A is able to backup to STFP server in cluster B network

 

I use Solarwinds as SFTP server solution. I also tried Coreftp, but got the same result.
I have checked to ensure there are no restrictions on the network either by firewall or otherwise.

 

What could be causing this? Are there troubleshooting methods I can try?

 

15 REPLIES 15
Highlighted
VIP Advisor

What does the logs in Solarwind SFTP server say when you access it from server B?

Please rate all useful posts
Highlighted

Hello @Roger Kallberg , 

Thanks for your response. There are no logs on the SFTP from the server. Not even authentication logs.

Highlighted

If you don't see the request in the SolarWind SFTP server monitor that would mean that the traffic never gets that far. As other have pointed out make sure that the traffic for the SFTP server is not blocked by anything along the way or in the server software firewall.

Please rate all useful posts
Highlighted

For reference this is what we get in SolarWind SFTP server monitor when I update the configuration of the backup device in CUCM DRS.

Snag_852515.png

The first line with the failed login is for not typing in the password on the backup device definition again before pressing save.

Please rate all useful posts
Highlighted
Rising star

Hi,

CoreSFTP Server is one of the best out there. For troubleshooting I use WinSCP client to test the SFTP Servers for UCM backups. You can use the interactive User Interface to rule out many issues.

All the best.
Please rate all helpful posts.
Wilson Samuel
Highlighted

Hello @Wilson Samuel ,

 

Thanks for your response. As stated in my original post, I already tried Coreftp. I will also try WinSCP and provide feedback.

Highlighted
VIP Engager

Hi,

Try below troubleshooting steps:

1. Are you able to ping SFTP server from CUCM Cluster B.

2. Do you have any access list or firewall that is blocking SFTP port between CUCM Cluster B and SFTP Server?

3. Disable any firewall on antivirus software on the machine where Solarwinds SFTP is running and try it.

4. Make sure you have correct Username and Password configured. 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.
Highlighted

Hello @Vaijanath Sonvane, Thanks for your response.

1. Yes, ping between the publisher and the SFTTP servers are successful.

2. All Firewalls and antivirus were disabled temporarily . It still did not work.

3. The same username and password were used on the Publisher in Cluster A and the backup was successful. The credentials are fine.

Highlighted

Do you have the path correct as well?  I've seen issues where an incorrect path gave this same error.  To save in the SFTP server's root, some want the path specified as "\", some want ".\" and I'm sure I've seen other variants.  Try connecting to the server with a command line SFTP client and set the path to see what works.

Highlighted

Hi Daniels

While you try to save the Backup configuration, Please collect PCAP from Cluster B CUCM

1. Run the following command in Cluster B CUCM Pub CLI
utils network capture eth0 file packets count 100000 size all host ip <Backup server IP>

2. Press Enter

3. Go to DRF page and Try to save the Config to reproduce the issue.

4. To stop the PCAP press Ctrl+C

Kindly upload the PCAP here
Thanks
Riyaz
Rate Useful Post If it resolve your issue
Highlighted

The invalid credential error is a general one that it fails, you may have to go look into the logs/traces.
When this came up for me this was due to a cipher incompatibility, that we had enabled FIPS mode and the server didn't offer a cipher that was usable.
It sort of shows up in the logging that this is what the issue was, but it says invalid username which is not what it means.
Highlighted
Beginner

Hi,

Cisco only stands behind a couple specific SFTP servers for reliability for backups. GlobalScape is one, and I can personally attest to TitanFTP being good for both DRS backups and CDR storage. mcdvoicesurvey.onl

 

Regards.

mybk-experience.onl

Highlighted

We’ve been using SolarWind SFTP server for a few years, minimum for 6-7 years, and it’s been rock solid.

Please rate all useful posts
Highlighted
Cisco Employee

could you please share DRF master and DRF local logs (logs level set to detailed in serviceability page) from RTMT for non working cluster.

Regards
Content for Community-Ad