cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1639
Views
25
Helpful
3
Replies
James Hawkins
Collaborator

CUCM Engineering Specials

Hi,

I have a customer who is interested in deploying Calabrio call recording.

They have informed him that he needs to run CUCM 8.6.2.22033 which is an Engineering Special based upon CUCM 8.6.2.21900-01

I have always tried to avoid ES releases based upon my experiences with Windows based CallManager where sometimes ES patches had to be removed before applying upgrades.

My question is does using Engineering Specials with appliance based versions of CUCM have any gotchas? - e.g. can I base any upgrade planning on the CUCM base version (in this case CUCM 8.6(2a)SU1 as far as I can determine).

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Rob Huffman
Hall of Fame Community Legend

Hi James,

We have used many CUCM and CUC ES's over the years when required but

you do need to be aware of certain bugs when doing future upgrades. Here is

one such example

CSCtx42925 - 8.6(2a)su1 upgrade rules to prevent install over ineligible ES's

Description

Symptom:
Upgrades to CUCM  8.6(2a)su1, also known as 8.6.2.21900-x, are not displayed as a valid  upgrade for any es's between 8.6.2.21016-x and 8.6.2.21899 inclusive.
Conditions:
Only  applicable for customers upgrading to CUCM 8.6(2a)su1, also known as  8.6.2.21900-x. The upgrade rules included with this fix prevent  customers from installing over an Engineering Special that may contain  fixes not present in 8.6(2a)su1.
Workaround:
Upgrade to an es in the 8.6.2.22xxx-x range or higher
When you run an ES you do needd to do a bit more "due diligence" on your next upgrade.
Cheers!
Rob

"Show a little faith, there's magic in the night" - Springsteen

View solution in original post

3 REPLIES 3
Gordon Ross
Engager

Avoid ESs if you can, but they don't affect upgrade planning. I've had various ESs on CUCM 6, 7 & 8, and upgrading from them was not a problem.

GTG

Please rate all helpful posts.
nikshah
Cisco Employee

Hi James,

Its true that SU's undergo a little higher testing as compared to ES's but not all bug fixes and getting a roll up of the bugs integrated in the SU will take a long time and ES's are released every week integrating multiple bugs being encountered/filed by customers. I have multiple customers various ES's and havent encountered any issues in ugprading to them.

Hope this helps

Regards

Niket

Kindly rate useful posts!!

Rob Huffman
Hall of Fame Community Legend

Hi James,

We have used many CUCM and CUC ES's over the years when required but

you do need to be aware of certain bugs when doing future upgrades. Here is

one such example

CSCtx42925 - 8.6(2a)su1 upgrade rules to prevent install over ineligible ES's

Description

Symptom:
Upgrades to CUCM  8.6(2a)su1, also known as 8.6.2.21900-x, are not displayed as a valid  upgrade for any es's between 8.6.2.21016-x and 8.6.2.21899 inclusive.
Conditions:
Only  applicable for customers upgrading to CUCM 8.6(2a)su1, also known as  8.6.2.21900-x. The upgrade rules included with this fix prevent  customers from installing over an Engineering Special that may contain  fixes not present in 8.6(2a)su1.
Workaround:
Upgrade to an es in the 8.6.2.22xxx-x range or higher
When you run an ES you do needd to do a bit more "due diligence" on your next upgrade.
Cheers!
Rob

"Show a little faith, there's magic in the night" - Springsteen

View solution in original post

Create
Recognize Your Peers
Content for Community-Ad