cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
504
Views
0
Helpful
2
Replies

CUCM - Trusted Certificate

gpsriramdc
Level 4
Level 4

Hi All,

we are uploading the trusted certificate in CUCM Page to avoid the security error while accessing the  web page. We successfully uploaded the root and intermediate certificate as "tomcat-trust".

While uploading the signed certificate ( as tomcat ) got in to the  error as in the attachment.

"java.security.cert.Certpathbuilderexception: Certificate contains critical extensions that could not be processed".

 

Thanks in Advance !!

 

2 Replies 2

What CA are you using?

If it is a microsoft CA, use the Web Server template, for the tomcat certificate.

 

See this document for certificate requirements:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/cucos/9_1_1/CUCM_BK_C5D96C80_00_cucm-os-admin-guide-91/CUCM_BK_C5D96C80_00_cucm-os-admin-guide-91_chapter_0110.html#CUCM_RF_TF4B6BF0_00

 

Do not enable additional options not specified there, and do not mark any certificate extensions as critical.

Hi Brandon !

Thanks for your reply. We are using some 3rd Party CA. In that case how we can achieve this ?