cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1788
Views
0
Helpful
7
Replies
Highlighted
Participant

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID intermittent issues

Hi,

I’m hoping someone can help here as I have exhausted all Google searches and any other blog posts.

I’m having intermittent caller ID issues. Sometimes it works then for some reason stops. When it stops I used to get “unknown” display on the phones, however now I get “999” which is strange, as 999 is a UK emergency services number. This is my lab router which is in a working environment at home. I only have one POTS line. I first began to get the “999” CID after I connected the 2901 to a CUCM server as a gateway, and then stripped out all configuration on the 2901 to return to the home environment. I eventually did this by loading a previous config via TFTP and rebooting.

I believe I should have the correct configuration on the FXO port for this to work correctly. On first test CID displays fine, but if you do not receive a call for some time (e.g. 12 hours) it seems to stop working. I’ve found that if you shut and no shut the FXO interface then it begins to work once more.

I also have a BT device on the line which sole purpose is to display CID of incoming and missed calls. This is always correct which leads me to think either a config issue of my FXO or fault.

As I have exhausted all of my avenues, last night I swapped the DSP chip to the other free DSP slot on the mainboard and also switched the VIC2-2FXO card to another slot on the router. This worked fine last night, but today it’s back to displaying “999” as incoming calls.

Here is the voice port config that connects to the FXO

voice-port 0/1/0

supervisory disconnect anytone

cptone GB

timing sup-disconnect 85

connection plar opx immediate xxxxxxx3162

impedance complex3

description PSTNtoSkyBT

caller-id enable

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocate


Here is my entire config with sensitive info removed


D-2901V#sh run
Building configuration...


Current configuration : 14454 bytes
!
! No configuration change since last restart
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname D-2901V
!
boot-start-marker
boot system flash c2900-universalk9-mz.SPA.151-4.M1.bin
boot-end-marker
!
!
security authentication failure rate 3 log
logging buffered 512000 informational
enable secret 5 xxxxxxxxxxxxxxxxx
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
clock timezone GMT 0 0
clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 1:00
!
ipv6 unicast-routing
ipv6 cef
no ip source-route
ip cef
!
!
!
!
!
no ip bootp server
ip domain name VOICE.local
ip name-server 8.8.8.8
multilink bundle-name authenticated
!
!
!
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1986870583
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1986870583
revocation-check none
rsakeypair TP-self-signed-1986870583
!
!
voice-card 0
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
h323
  call service stop
sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
  registrar server expires max 3600 min 120
!
!
voice register global
mode cme
source-address 192.168.192.253 port 5060
max-dn 100
max-pool 20
tftp-path flash:
create profile sync 0199372855642417
!
voice register dn  99
number 1010
allow watch
name SIP-Phone
no-reg
!
voice register pool  1
id mac 0000.0000.0000
number 1 dn 99
username 1010 password xxxxxxxxx
codec g711alaw
no vad
!
voice hunt-group 1 parallel
list 1001,1002,1100,1003
pilot 0xxxxxxxxx2
!
!
voice logout-profile 1
pin 1234
user logoutprofile password xxxxxxxxxxxx
number 1100 type normal
!
voice user-profile 1
pin 6654
user tp password xxxxxxxxxx
number 1002 type normal
speed-dial 1 0xxxxxxxxx0 label "Mobile"
speed-dial 2 1001 label "Home" blf
!
voice user-profile 2
pin 1234
user pxxxxx password xxxxxxxxxx
number 1001 type normal
speed-dial 1 0xxxxxxxxxxx label ""
speed-dial 2 0xxxxxxxxxx label "Home"
speed-dial 3 0xxxxxxxxxxx label "Doctors"
speed-dial 4 7xxxxxxxxxxx label " work line"
speed-dial 5 1002 label "Tony" blf
!
voice user-profile 3
pin 6654
user tp2 password pass
number 1003 type normal
speed-dial 1 0xxxxxxx0 label "Mobile"
speed-dial 2 1001 label "Home" blf
!
!
!
!
license udi pid CISCO2901/K9 sn FCZ15169223
license boot module c2900 technology-package uck9
hw-module pvdm 0/1
!
!
!
dial-control-mib retain-timer 35791
dial-control-mib max-size 1200
username tony privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxx
!
redundancy
!
!
ip tcp synwait-time 10
no ip ftp passive
gw-accounting syslog
!
!
!
!
interface Null0
no ip unreachables
!
interface Embedded-Service-Engine0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
shutdown
!
interface GigabitEthernet0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/1
description $FW_INSIDE$
ip address 192.168.192.253 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
duplex auto
speed auto
ipv6 address FD00:0:2:1::2/64
no mop enabled
!
ip default-gateway 192.168.192.254
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:/gui
!
ip route 0.0.0.0 0.0.0.0 192.168.192.254
!
!
!
tftp-server flash:/phone/7906-7911.911/apps11.9-1-1TH1-16.sbn alias apps11.9-1-1TH1-16.sbn
tftp-server flash:/phone/7906-7911.911/cnu11.9-1-1TH1-16.sbn alias cnu11.9-1-1TH1-16.sbn
tftp-server flash:/phone/7906-7911.911/cvm11sccp.9-1-1TH1-16.sbn alias cvm11sccp.9-1-1TH1-16.sbn
tftp-server flash:/phone/7906-7911.911/dsp11.9-1-1TH1-16.sbn alias dsp11.9-1-1TH1-16.sbn
tftp-server flash:/phone/7906-7911.911/jar11sccp.9-1-1TH1-16.sbn alias jar11sccp.9-1-1TH1-16.sbn
tftp-server flash:/phone/7906-7911.911/SCCP11.9-1-1SR1S.loads alias SCCP11.9-1-1SR1S.loads
tftp-server flash:/phone/7906-7911.911/term06.default.loads alias term06.default.loads
tftp-server flash:/phone/7970-7971.911/apps70.9-1-1TH1-16.sbn alias apps70.9-1-1TH1-16.sbn
tftp-server flash:/phone/7970-7971.911/cnu70.9-1-1TH1-16.sbn alias cnu70.9-1-1TH1-16.sbn
tftp-server flash:/phone/7970-7971.911/cvm70sccp.9-1-1TH1-16.sbn alias cvm70sccp.9-1-1TH1-16.sbn
tftp-server flash:/phone/7970-7971.911/dsp70.9-1-1TH1-16.sbn alias dsp70.9-1-1TH1-16.sbn
tftp-server flash:/phone/7970-7971.911/jar70sccp.9-1-1TH1-16.sbn alias jar70sccp.9-1-1TH1-16.sbn
tftp-server flash:/phone/7970-7971.911/term70.default.loads alias term70.default.loads
tftp-server flash:/phone/7970-7971.911/term71.default.loads alias term71.default.loads
tftp-server flash:/phone/7970-7971.911/SCCP70.9-1-1SR1S.loads alias SCCP70.9-1-1SR1S.loads
tftp-server flash:/Desktops/320x212x12/Cody.png alias Desktops/320x212x12/Cody.png
tftp-server flash:/Desktops/320x212x12/TN-Cody.png alias Desktops/320x212x12/TN-Cody.png
tftp-server flash:/Desktops/320x212x12/List.xml alias Desktops/320x212x12/List.xml
tftp-server flash:/Desktops/320x212x12/CampusNight.png alias Desktops/320x212x12/CampusNight.png
tftp-server flash:/Desktops/320x212x12/CiscoFountain.png alias Desktops/320x212x12/CiscoFountain.png
tftp-server flash:/Desktops/320x212x12/MorroRock.png alias Desktops/320x212x12/MorroRock.png
tftp-server flash:/Desktops/320x212x12/NantucketFlowers.png alias Desktops/320x212x12/NantucketFlowers.png
tftp-server flash:/Desktops/320x212x12/TN-CampusNight.png alias Desktops/320x212x12/TN-CampusNight.png
tftp-server flash:/Desktops/320x212x12/TN-CiscoFountain.png alias Desktops/320x212x12/TN-CiscoFountain.png
tftp-server flash:/Desktops/320x212x12/TN-Fountain.png alias Desktops/320x212x12/TN-Fountain.png
tftp-server flash:/Desktops/320x212x12/TN-MorroRock.png alias Desktops/320x212x12/TN-MorroRock.png
tftp-server flash:/Desktops/320x212x12/TN-NantucketFlowers.png alias Desktops/320x212x12/TN-NantucketFlowers.png
tftp-server flash:/Desktops/320x212x12/Fountain.png alias Desktops/320x212x12/Fountain.png
tftp-server flash:/User_Define_1/tc-sccp.jar alias User_Define_1/tc-sccp.jar
tftp-server flash:/User_Define_1/td-sccp.jar alias User_Define_1/td-sccp.jar
tftp-server flash:/User_Define_1/g3-tones.xml alias User_Define_1/g3-tones.xml
tftp-server flash:/User_Define_1/SCCP-dictionary.xml alias User_Define_1/SCCP-dictionary.xml
!
!
!
control-plane
!
!
voice-port 0/1/0
supervisory disconnect anytone
cptone GB
timing sup-disconnect 85
connection plar opx immediate 0xxxxxxx2
impedance complex3
description PSTNtoSkyBT
caller-id enable
caller-id alerting line-reversal
caller-id alerting dsp-pre-allocate
!
voice-port 0/1/1
!
!
!
mgcp profile default
!
!
dial-peer cor custom
name LOCAL
name PREMIUM
name INTERNATIONAL
!
!
dial-peer cor list LOCAL-CALL
member LOCAL
!
dial-peer cor list INTERNATIONAL-CALL
member INTERNATIONAL
!
dial-peer cor list PREMIUM-CALL
member PREMIUM
!
dial-peer cor list LOCAL-INTERNATIONAL
member LOCAL
member INTERNATIONAL
!
!
dial-peer voice 999 pots
description Emergency number
destination-pattern 999
no digit-strip
port 0/1/0
!
dial-peer voice 112 pots
description Emergency number
destination-pattern 112
no digit-strip
port 0/1/0
!
dial-peer voice 118 pots
description 118 Directory
destination-pattern 118...
no digit-strip
port 0/1/0
!
dial-peer voice 1000 pots
corlist outgoing INTERNATIONAL-CALL
description International 00(area code)
destination-pattern 00T
no digit-strip
port 0/1/0
!
dial-peer voice 20 pots
corlist outgoing LOCAL-CALL
description London 020x numbers
destination-pattern (141)%(020)%[3,7,8].......
no digit-strip
port 0/1/0
!
dial-peer voice 123 pots
description Talking clock
destination-pattern 123
no digit-strip
port 0/1/0
!
dial-peer voice 5000 voip
description Skype Test service
destination-pattern 55
session protocol sipv2
session target sip-server
codec ilbc
!
dial-peer voice 5001 voip
description xxxxxxxs
destination-pattern 5001
session protocol sipv2
session target sip-server
codec ilbc
!
dial-peer voice 50 pots
description 0500 numbers
destination-pattern (141)%0500......
no digit-strip
port 0/1/0
!
dial-peer voice 100 pots
corlist outgoing LOCAL-CALL
description Combined dial peers for 01,02,03,07,08
destination-pattern (141)%0[1,2,3,7,8].........
no digit-strip
port 0/1/0
!
dial-peer voice 2000 voip
destination-pattern 2...
session target ipv4:192.168.192.250
codec g711alaw
!
dial-peer voice 90 pots
corlist outgoing PREMIUM-CALL
description Premium numbers
destination-pattern (141)%09.........
no digit-strip
port 0/1/0
!
dial-peer voice 99999 pots
destination-pattern .T
port 0/1/0
!
!
num-exp 08xxxxx74 8xxxx0
presence
presence call-list
!
sip-ua
credentials username skypests password 7 xxxxxxxxxxx realm 192.168.192.166
credentials username tony password 7 xxxxxxxxxxxxx realm 192.168.192.166
authentication username skypests password 7 xxxxxxxxxxxxx
timers connect 100
sip-server ipv4:192.168.192.166:5070
presence enable
!
!
!
gatekeeper
shutdown
!
!
telephony-service
no auto-reg-ephone
em keep-history
max-ephones 20
max-dn 100
ip source-address 192.168.192.253 port 2000
service phone webAccess 0
timeouts ringing 60
system message I am a phone. Welcome.
url authentication http://192.168.192.253/CCMIP/authenticate.asp tony xxxxxxxxxxx
cnf-file location flash:
user-locale U1 GB
network-locale U1
load 7906 SCCP11.9-1-1SR1S.loads
load 7970 SCCP70.9-1-1SR1S.loads
load 7971 SCCP70.9-1-1SR1S.loads
time-zone 21
time-format 24
date-format dd-mm-yy
max-conferences 8 gain -6
moh flash:/Prayer711.wav
web admin system name tony secret 5 xxxxxxxxxx
web admin customer name admin password Password1
transfer-system full-consult
directory entry 1 xxxxxxxxxx
create cnf-files version-stamp 7960 Oct 04 2011 13:19:20
!
!
ephone-template  1
softkeys hold  Join Newcall Resume Select
softkeys idle  Redial Newcall Pickup Gpickup Dnd
softkeys seized  Redial Endcall Cfwdall Pickup Gpickup Callback
softkeys alerting  Endcall
softkeys connected  Hold Endcall Trnsfer Confrn Park
!
!
ephone-dn  1  dual-line
number 1001
label Downstairs Computer
name Downstairs Computer
allow watch
corlist incoming LOCAL-INTERNATIONAL
!
!
ephone-dn  2  dual-line
number 1002
label Tony
name Tony
allow watch
corlist incoming LOCAL-INTERNATIONAL
!
!
ephone-dn  3  dual-line
number 1003
label Tony's PC
name Tony's PC
allow watch
corlist incoming LOCAL-INTERNATIONAL
!
!
ephone-dn  50
number 3000
park-slot timeout 60 limit 10
name Call Park
!
!
ephone-dn  70
number 5555
name PAGETEST1
paging
!
!
ephone-dn  71
number 5556
name PAGETEST2
paging
paging group 70
!
!
ephone-dn  100  octo-line
number 1100
description Logged out extension template
!
!
ephone  1
description Downstairs computer 7970
mac-address 0015.F949.0CBA
ephone-template 1
paging-dn 70
type 7970
logout-profile 1
!
!
!
ephone  2
description Upstairs computer 7906
mac-address 0023.339D.3CA1
ephone-template 1
type 7906
logout-profile 1
!
!
!
ephone  10
description Tony's Dell office laptop IPC
mac-address 001C.233F.D655
paging-dn 70
type CIPC
logout-profile 1
!
!
!
ephone  20
description Tony's main workstation IPC
mac-address 0024.1DC0.D8FB
type CIPC
logout-profile 1
!
!
!
banner login ^CWARNING Authorised access ONLY^C
!
line con 0
logging synchronous
transport output telnet
line aux 0
transport output telnet
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
transport input telnet ssh
line vty 5 15
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 192.168.192.254 prefer source GigabitEthernet0/1
end

Many thanks in advance.

7 REPLIES 7

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

Hi Tony

When I've done FXOs, I've used configs like so:

voice-port 0/0/0

cptone GB

timing sup-disconnect 85

connection plar opx 6002

impedance complex3

caller-id alerting dsp-pre-allocate

dsp-pre-allo being the key one; sup-disconnect being what BT seem to use.. and the rest being default. Impedance choice was made based on an impedance matching/test tone call (see the notes here : http://www.cisco.com/en/US/tech/tk652/tk701/technologies_tech_note09186a0080477a06.shtml especially near the end re generating test call/tones).

Obviously it's not a million miles from what you have... maybe take out the extra stuff and see how it runs. If it works for a short while, then fails, and other kit can still pick up the CLI on the same line... then it is fairly likely it's a bug. Maybe try a different IOS if problems continue.

I think your 999 gets inserted based on the dial-peer that is matched inbound when there is no CLI on the call. For example, when it happens again, delete your 999 dial-peer and re test. It'll probably pick up another dial-peer associated to that port.

Configuring a new dial-peer with no 'destination-pattern', pointed at the port, with 'incoming called-number .' might work around it.

Regards

Aaron

Please rate helpful posts..

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Participant

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

Thank you Aaron for this. I will try this at tonight.

I understand about matching the dial peers on the inbound call although I'm still learning, I added the "destination pattern .T" dial-peer to try and match instead that if it was matching "999".

I'll digest this properly tonight and try what you suggest.

Thanks again!

Advocate

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

Hi,

I would also add these few lines to ensure dial peer matching.

Also FXO disc problems

!

dial-peer voice 1 pots

description *** FOR INCOMING CALL MATCHING ***

incoming called-number .

direct-inward-dial

no vad

port 0/1/0

!

!

voice-port 0/1/0

supervisory disconnect dualtone mid-call

!

Please not the incoming called-number .

---- IS A FULLSTOP AFTER THE SPACE

HTH

Alex

Regards, Alex. Please rate useful posts.
Participant

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

Thanks all I have tried all suggestions above. It was working for a while but stopped again this morning. I've since removed and readded dial-peer 999. New dial-peers get added to the bottom. There is also dial-peer 1 matching "incoming called number .".

My current voice port is below. I cannot remove the line reversal caller-id command, it comes back when dsp-pre-allocate is used. This seems to be a consequence of using "cptone GB".

voice-port 0/1/0

supervisory disconnect dualtone mid-call

cptone GB

timing sup-disconnect 85

connection plar opx immediate 0xxxxxxx2

impedance complex3

description PSTNtoSkyBT

caller-id enable

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocate

I made these changes at around 11am so if the issue has returned when I get back tonight I'll try IOS 15.01M6 and see how that goes. Although this means going from CUCME 8.6 to 7.1 at least if the problem goes away we know it's a bug and not another defect of some kind.

Thanks again.

Also, when I swapped my DSP chip between slots, it was very very difficult to insert back in. Thought I was going to break it!

Participant

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

Issue back when I got home although the calling number was "112" instead of "999" so you were right about it matching the dial-peer and using that as the caller-ID, which I think is a little odd anyway.

Have on 15.0.1M6, and rung it numerous times from both mobiles. We'll see how it is tomorrow.

Thanks,

Participant

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

I tried calling my number again this afternoon. The first time I called the ID was "unknown". If I called back immediately the ID is picked up. If I call back from another number the ID is also picked up

It's still intermittent but seems better than before.

What I do notice is that when I call from my mobile, I hear the ring on the mobile before my landline rings. During this time I notice that my BT caller ID unit (that sits in front of another telephone but in parallel to my 2901 FXO port) seems to detect the incoming call before the phone actually rings, the phone icon lights up. I assume this is when caller ID is being sent down the line.

The system is now on a different IOS. The incoming call leg is now correct, as I had obviously neglected that so "unknown" is displayed when no ID is detected. I haven't looked in detail, into the impedence types so will do that either tonight or tomorrow.

Any other suggestions appreciated, thank you.

Regards,

Participant

CUCME 8.6 2901 VIC2-2FXO to British Telecom (BT) Caller ID inter

The TAC engineer took some captures and advised me to adjust the input gain so the router receives a better signal for Caller ID. I've made the following change and the whole of today Caller ID has worked flawlessly.

voice-port 0/1/0

  input gain -6

I'm going to continue testing but before, I was easily able to reproduce the problem by not receiving a call for a few hours.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards