cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
700
Views
0
Helpful
4
Replies
Highlighted
Beginner

data traffic delayed when voice calls are in progress autoqos enable

Please help me out here. What can I change base on the running-config below to have a better data traffic?

mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
no file verify auto
!
spanning-tree mode pvst

spanning-tree extend system-id
spanning-tree vlan 1-500 priority 0
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
  description PUBLIC WI-FI
  switchport access vlan 300
  switchport voice vlan 200
  duplex full
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/2
  description PUBLIC WI-FI
  switchport access vlan 300
  switchport voice vlan 200
  duplex full

srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/3
  description DATA PORT TO PIX506E_INSIDE (VLAN100)
  switchport access vlan 100
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/4
  description PC & IP PHONE BASEMENT
  switchport access vlan 100
  switchport voice vlan 200

srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
!
interface FastEthernet0/5
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/6
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200

srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/7
  description TO_B8_PATCH_PANEL
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/8
  description FLOOR2_SWITCH_F0/1
  switchport trunk encapsulation dot1q

switchport mode trunk
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
!
interface FastEthernet0/9
  description FLOOR3_SWITCH_F0/1
  switchport trunk encapsulation dot1q
  switchport mode trunk
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
!
interface FastEthernet0/10
  description FLOOR4_SWITCH_F0/1
  switchport trunk encapsulation dot1q
  switchport mode trunk

srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
!
interface FastEthernet0/11
  description JUNIPER-BRIDGE-GROUP0
  switchport access vlan 100
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/12
  description SPARE PORT
  switchport access vlan 100
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0

priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/13
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/14
  description TO_B6_PATCH_PANEL
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/15
  description CUCMBE(VOICE_SRVR)
  switchport access vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust dscp
  auto qos voip trust
  spanning-tree portfast
!
interface FastEthernet0/16
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0

priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/17
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/18
  description 6_PORT_LINKSYS_SW
  switchport access vlan 100
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0

priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
!
interface FastEthernet0/19
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/20
  description SPARE PORT
  switchport access vlan 100
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out

mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/21
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/22
  description 2851VOICE_GW
  switchport trunk encapsulation dot1q
  switchport mode trunk
  duplex full
  speed 100

srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust dscp
  auto qos voip trust
!
interface FastEthernet0/23
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20
  srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface FastEthernet0/24
  description PC & IP PHONES
  switchport access vlan 100
  switchport voice vlan 200
  srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
  no ip address
  no ip route-cache
!
interface Vlan100
  description DATA_INSIDE VLAN
  ip address 10.6.4.31 255.255.255.0
  no ip route-cache
!
interface Vlan200
  description VOICE_INSIDE VLAN
  ip address 192.168.0.20 255.255.255.0

no ip route-cache
!
ip default-gateway 10.6.4.1
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
  password ************
  login
  length 0
line vty 5 15
  password ************
  login
!
!
end

4 REPLIES 4
Hall of Fame Master

data traffic delayed when voice calls are in progress autoqos e

In my opinion and direct experience (other will not agree), the best results are had by removing all and any QoS configuration.

If you do, please report results.

Beginner

data traffic delayed when voice calls are in progress autoqos e

out of interest could you elaborate your experiences

Hall of Fame Master

data traffic delayed when voice calls are in progress autoqos e

Simply that QoS is not necessary on LANs, because there is enough bandwith.

Instead problems stars one one starts messing with buffer resources and thresholds, that are better left to defaults.

My custoimers have many Catalyst networks running w/o QoS, and all are working perfectly.

Beginner

data traffic delayed when voice calls are in progress autoqos e

Paolo has a point.  If you have enough bandwidth, your QoS doesn't come into play.  Have you looked at your queues?  If you have no packets being queued, you have enough bandwidth.  If you have a particular queue that really gets hit hard, modify your queueing structure.  I also read on the Cisco learning network, "For the switch platforms, it is recommended that any standard QoS commands configured on the router be deleted before issuing AutoQoS. CDP must be enabled on the interface on which AutoQoS is turned on."  I don't see CDP on your config.

Hope this helps,

SteveO

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards