cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
540
Views
0
Helpful
10
Replies
Andrew Mathu
Beginner

Database Communication Error on Publisher.

Hi Guys,

I am getting a " Database Communication Error" whe I try to log into the CM administration and CM serviceability on the Publisher.

I have tried to restart the services by using the command "utils system restart". When I check the services running after the restart the following are not running:

A Cisco DB

A Cisco DB Replicator

Cisco CAR DB

Cisco CDR Agent

Cisco Tftp

The system is configured in a cluster and the error appears on the Publisher. I am able to log into the Subscriber but sicnce it was configured for secondary/backup services only, I can not edit anything. Backup had not been done for a long time, so users are not able to work properly.

I can only access the Publisher through the CLI and restarting the stopped services has no effect.

10 REPLIES 10
Manish Gogna
Cisco Employee

Hi Andrew,

Has there been any recent change on the Publisher , like an IP or a hostname change?

Manish

Hi Manish,

There has been no IP address or hostname change on ether the Publisher or Subscriber. From the Subscriber, the Publisher is reachable (you can ping it from the Subscriber's OS administration).

LDAP synchronization between the Active Directory and Publisher was failing. We rebooted the Publisher with the aim of making the synchronization work. After the reboot, the "Database Communication Error" began.

No changes in IP or hostname have been made.

I had already tried using the solutions on the link given.

Unfortunately none have worked.

Andrew

Can you please share the output of "utils diagnose test" from the Publisher.

Manish

This is what I get when I run the test:

admin:utils diagnose test

Log file: platform/log/diag2.log

Starting diagnostic test(s)

===========================

test - disk_space          : Passed (available: 30145 MB, used: 11677 MB)

skip - disk_files          : This module must be run directly and off hours

test - service_manager     : Passed

test - tomcat              : Passed

test - tomcat_deadlocks    : 0 second(s) left

Its not going beyond that.

Hi Andrew,

what is the CUCM version u are using ?

in case if u  are using CUCM 8.6(2) , u can build your publisher by restoring data from Sub.

regds,

aman

We are running version 8.5(1)

Hi Andrew,

Suggest opening a tac case.

regds,

aman

Yes, looking at the output of "utils diagnose test" i would recommend opening a tac case as this may actually need TAC to require root access and work from there.

Manish

Content for Community-Ad

Spotlight Awards 2021