Showing results for 
Search instead for 
Did you mean: 

Dial-Peer configuration help in CME


Hello experts,

i have been trying to get my voice network up from 2days but no luck.

Here is my scenario:



Iris PBX

+++++++++++++++Config posted at the Bottom+++++++++++++++++

CME and PBX are PRI trunked; i can see layer 1 active and layer 2 multi_Frame_Established in "show isdn status".

SIP trunk from CUCM to CME Established.

Unable to communicate from Voip phones registered to CUCM to analog phones in PBX.

Few times voip to analog calls working and then few changes in the PBX making it crap again. (Those were made by PBX technician)

Voip ext: 1003

Analog Ext: 270

!!for voip to analog calls


Route pattern: 9XXX --> to CME trunk


Destination pattern: 9... --> to E1 card (with auto stripping)

!!for analog to voip calls

In PBX the guy given access code as 4 and stripped it while sending.

that means from analog ext to reach 1003 user will dial 41003 and 4 will be stripped off.


Destination pattern: 1... -->  session target ipv4:<ip of CUCM>

With this configuration in the "debug ccapi inout" am seeing "Transfer number is NULL" and

in the "show call history last 1" am seeing cause code "1C" -- Invalid number.

After doing some research these are my ideas but no tested:

1. I should have incoming dial peer to match traffic from e1 card:

dial-peer voice X pots

incoming called-number .T

2) I should configure dtmf-relay sip-notify and dtmf-relay rtp-nte for accepting digits from telephone-service.

3) Do i need create any DIDs for incoming calls from pbx?

Please help me on this, how could i get calls from analog to voip and vice versa, what i am thinking is right? if not what could be the alternatives? where we should use dtmf-relay commands.?

Thanks everyone in advance.

Existing config:

card type e1 0 1
network-clock-participate wic 1
network-clock-select 1 E1 0/1/1
isdn switch-type primary-qsig
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
  registrar server expires max 600 min 60
  no update-callerid
voice class codec 1
 codec preference 1 g729br8
 codec preference 2 g729r8
 codec preference 3 g723ar63
 codec preference 4 g711ulaw
 codec preference 5 g711alaw
controller E1 0/1/1
 framing NO-CRC4
 pri-group timeslots 1-31
voice-port 0/1/1:15
 bearer-cap Speech
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
mgcp profile default
dial-peer voice 3 pots
 destination-pattern 9...
 port 0/1/1:15
dial-peer voice 1 voip
 destination-pattern 1...
 session target ipv4:
 max-conferences 8 gain -6
 transfer-system full-consult

1 Accepted Solution

Accepted Solutions

Ok, Lets remove all of your Dial-Peers and start from scratch.

For testing purposes we will test with specific numbers.  We can get more general later.  Try the following for inbound.

dial-peer voice 10 pots

desc ## Inbound from Iris PBX ##

incoming called-number .

 forward-digits all

Then lets try this for your Call Manager Dial-Peer

dial-peer voice 20 voip

destination-pattern 501

session protocol sipv2

session target ipv4: CUCM_IP

Please retest and submit fresh outputs showing,

debug ccapi voice inout

debug ccsip messages

debug isdn q931

View solution in original post

24 Replies 24

Chris Deren
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

So, what is the purpose of CME here? Do you have any phones registered to CME or was the intent to use the router for the integration to PBX only? If so, CME does not need to be configured, only dial peers. What device type do you have configured on CUCM side as your dial peer is configured for H323 (default) is the GW configured as H323 GW or SIP trunk on CUCM as you mention SIP? You need to add "session protocol sipv2" to your dial peer. Also, please post "debug ccsip messages" and "debug isdn q931" along with information about called and calling numbers.

CME for integration with PBX only.

Device type is SIP trunk.

I am adding that.

Currently i don't have access to the router to send the debug messages.

If possible please clarify me on one thing:

If i want to enable communication between analog to IP then i have this dial peer,

dial-peer voice 2 voip

destination-pattern 1...

session target ipv4: IP

is it sufficient to route calls to CUCM?

or do i need to use direct inward dialing command also?

Like I said you do not need to configure CME to build an integration to another PBX. It is all done via dial peers. As to dial peer question, the dial peer you reference would be the outbound dial peer pointing to CUCM matching all extensions in 1XXXX range. Things to consider:

  • codec - default is G729, if you want to use G711 you need to specify it
  • inbound dial peer - every IP leg matches two dial peers so you can add "incoming called-number ." to dial peer 2 to keep it simply
  • DTMF method, you need to make sure you have proper DTMF method if you will be passing any digits during a call, i.e. voicemail, IVR, etc. i.e "dtmf-relay rtp-nte sip-kpml"
  • CSS on the SIP trunk. In order for CUCM route the call correctly you need to assign a CSS to the SIP trunk built in CUCM, where this CSS has access to the partition assigned to the phones.

Here is an example of a dial-peer that might work for you:

dial-peer voice 2 voip
 description CUCM leg
 session protocol sipv2
 incoming called-number .

 codec g711ulaw

 destination-pattern 1...

 session target ipv4: <IP>
 dtmf-relay rtp-nte sip-kpml
 no vad

i dont have any digits passing during the call, so i don't require dtmf-relay, i think.

for calling search space in cucm sip trunk, should i select for inbound css or outbound css?

In cisco doc i read, session target command will be ignored for incoming dial-peers. 

So in your example, as you have mentioned Destination-pattern also that means it will match the inbound dial peer with incoming called-number and then will match the outbound dial peer so the session target command would work ?

And you have mentioned the incoming called-number to ".", isn't it to match a single digit? then how the whole called number would match that? 

If i call from 270 ext to 1003 then 1003 will be called number (DNIS) and 270 will be my calling number (answer address) right? I am confused with these terms. please correct me if am wrong.

configured as you said bro.. still issue...

Voip to Analog phones working fine.

but from analog to voip phones not working. here's my dial peer config

dial-peer voice 10 pots

incoming called-number .

session protocol sipv2

session target ipv4:ip

please find the attached debugs.. the issue am facing is:

when from the analog extension am trying to dial ip phone, after pressing the access code immediately the phone giving busy tone.

Tried direct-inward-dial also still the same.

Few hours ago it worked somehow but voip to analog didn't work, then i have removed config and started from scratch the this is the result.


Can you add another copy of your config?  Will need it to compare with the debugs you have added.


hi please find the attached...


This only contains debugs, can you attach the full output of sh run?  Please feel free to mask any parts that are sensitive like password hashes and public IP's etc.


Hi please find the attched config.


Let's deal with inbound first.  So we have an extension the other side of the Iris PBX 270.  They are dialling 41003 which is being stripped to 1003 by the time it reaches your CME box?  The CME box is then using dial-peer voice 1 voip to direct it to your Call Manager for delivery to the phone?

Does the Trunk in Call Manager contain an inbound CSS that contains the partition where extension 1003 is located?


oh...god... there you got me. previously i selected the incoming CSS. Then as the voip dialpeers got some issue i removed that and forgot to add back.

Tomorrow i will configure and update you, hope this gonna be resolve.

Thank you brother.. thank you very much.. i will confirm you tomorrow.

unfortunately still same problem bro,

i have assigned css and then removed css in trunk, device, and route partition of the trunk even then also same problem.

Ok, can you run the following debugs on the CME box, generate a test call then post the output?

Debug ccapi voice inout

Debug ccsip messages

Debug isdn q931


now its showing cause code 38 * network failure

i have created a new dn 501, with no css, partition and in trunk also mentioned nothing.

 then called 9501 from  270 then the debug is attached.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers