cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
8275
Views
0
Helpful
9
Replies
Highlighted
Beginner

dial peer failover with two SIP server problem

Dear All

I have two sip servers(primary , backup) , and cisco 2900 voice gateway , the problem is

when the primary server goes down , when the backup server goes up for redaundancy ,  All sip phones get not working and give me but i can make ping to the backup server  , when the primary return up all sip phones become working fine , what is the missing in the configuration ??? and how to solve this problem ????

please see the configuration below:

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0

!

sip-ua

retry invite 2 

timers trying 150

!

interface GigabitEthernet0/0

description ABK-HO-Connection

ip address 12.103.115.137 255.0.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/1:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 12.103.105.254

!

!

!

!

control-plane

!

!

voice-port 0/0/0:15

connection plar 1890890

!

voice-port 0/1/0:15

connection plar 1890890

!

voice-port 0/0/1:15

connection plar 1890890

!

voice-port 0/1/1:15

connection plar 1890890

!

!

!

!

dial-peer voice 10 pots

destination-pattern 9

port 0/0/0:15

!

dial-peer voice 11 pots

preference 1

destination-pattern 9

port 0/0/1:15

!

dial-peer voice 1 voip

destination-pattern 1890890

session protocol sipv2

session transport udp

session target ipv4:12.103.115.133:8060

dtmf-relay rtp-nte

codec g711ulaw

fax-relay ecm disable

fax rate 14400

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

no vad

!

dial-peer voice 2 voip

preference 1

destination-pattern 1890890

session protocol sipv2

session target ipv4:12.103.115.134:8060

session transport udp

dtmf-relay rtp-nte

codec g711ulaw

fax-relay ecm disable

fax rate 14400

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

no vad

!

!

gateway

media-inactivity-criteria all

timer receive-rtcp 5

timer receive-rtp 1200

!

sip-ua

!

!

!

gatekeeper

shutdown

9 REPLIES 9
Highlighted

if the primary server goes down (SIP stuck is down) and you can still ping it you can implement the SIP option keep alive feature to determine that.

dial-peer voice 1 voip

voice-class sip options-keepalive

dial-peer voice 2 voip

voice-class sip options-keepalive

The other side of the connection must support it, though. The gateway will send SIP options messages to monitor if the destination is still alive.

You can tune the timers as well:

dial-peer voice 100 voip

  voice-class sip options-keepalive up-interval 12 down-interval 65 retry 3

Here is some documentation:

http://www.cisco.com/en/US/docs/ios/voice/command/reference/vr_v2.html#wp1272954

Highlighted

Hi radoslav

first of all , thanks for ur reply

voice-class sip options-keepalive up-interval 12 down-interval 65 retry 3

to add this commands , i need to create new dial-peer as mention above  , or this global commad ???

Assume that after adding this commands , and the problem is still not solved , do have another soution or double work for that  ???? , becasue i have to turn of the sip  primary server today  at mid night to test the backup sip server and i have down time only one hour to solve this issue

thanks and regards

Highlighted

Hi Radoslav

please feed me back ASAP

I am waiting your updates

thanks

Highlighted

Hi,

just add these lines under the dial-peer for the primary and secondary server and it should be fine.

dial-peer voice 1 voip

voice-class sip options-keepalive

dial-peer voice 2 voip

voice-class sip options-keepalive

Anyway, without this command, the router will try the first server and then it will try the second one. But without options-keepalive the failover might take longer. Options keepalive activaly monitors the destination and busyout the dial-peer if the destination is not reachable.

sip-ua

retry invite 2  -> 2 Invites, if it fails it tries the second dial-peer.

Highlighted

Hi Radoslav

I did add these commands , but still the same problem ,  then i did open ticket with cisco , we found that the problem from Sip  server is not resoponding

thanks so much for supporting

Highlighted

Hi Radoslav

sorry for bothering you again , in actually the customer did check with ININ sip server support and they said dont have ant troubles in SIP servers and the problem from voice gateway , now i have confused , cisco said the problem from ININ server and ININ said the problem from voice gateway, what you think the problem , did you face like this problem before ???  , see below the last configuration and debug :

====================================================================

voice service voip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

sip

!

!

!

!

license udi pid CISCO2901/K9 sn FGL152723QM

hw-module pvdm 0/0

!

!

!

username icadmin secret 5 $1$7AMW$EP19aUZuccUF3u8lEFuQZ.

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31

!

controller E1 0/0/1

pri-group timeslots 1-31

!

controller E1 0/1/0

pri-group timeslots 1-31

!

controller E1 0/1/1

pri-group timeslots 1-31

!

interface GigabitEthernet0/0

description ABK-HO-Connection

ip address 12.103.115.137 255.0.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/1:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 12.103.105.254

!

!

!

snmp-server community abk@8kro RO

!

control-plane

!

!

voice-port 0/0/0:15

connection plar 1890890

!

voice-port 0/1/0:15

connection plar 1890890

!

voice-port 0/0/1:15

connection plar 1890890

!

voice-port 0/1/1:15

connection plar 1890890

!

!

!

!

dial-peer voice 10 pots

destination-pattern 9

port 0/0/0:15

!

dial-peer voice 11 pots

preference 1

destination-pattern 9

port 0/0/1:15

!

dial-peer voice 1 voip

destination-pattern 1890890

session protocol sipv2

session target ipv4:12.103.115.133:8060

voice-class sip options-keepalive up-interval 12 down-interval 65 retry 1

dtmf-relay rtp-nte

codec g711ulaw

fax-relay ecm disable

fax rate 14400

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

no vad

!

dial-peer voice 2 voip

preference 2

destination-pattern 1890890

session protocol sipv2

session target ipv4:43.103.103.242:8060

voice-class sip options-keepalive up-interval 12 down-interval 65 retry 1

dtmf-relay rtp-nte

codec g711ulaw

fax-relay ecm disable

fax rate 14400

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

no vad

!

!

gateway

media-inactivity-criteria all

timer receive-rtcp 5

timer receive-rtp 1200

!

sip-ua

retry invite 2

timers trying 200

!

!

!

gatekeeper

shutdown

==================================

Nov 23 02:15:50.080:  vsacount in free is 1

Nov  23 02:15:50.080: //5227327/889C8894AD39/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Nov 23 02:15:50.080: //5227327/889C8894AD39/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

Nov 23 02:15:50.080: //5227327/889C8894AD39/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Nov 23 02:15:50.132: //5227327/889C8894AD39/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x29DF9334,exit Tag=0x0, Call Id=5227327,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

Nov 23 02:15:50.132: //5227327/889C8894AD39/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Nov 23 02:15:50.132: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:15:50.132: :cc_free_feature_vsa freeing 31BA8AD8

Nov 23 02:15:50.132: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:15:50.132:  vsacount in free is 0

Nov 23 02:16:01.644: //-1/8FA03029AD3A/CCAPI/c

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#c_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=67060870

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=1890890

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-lastrdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_tim

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#eout =0

Nov 23 02:16:01.644: //-1/8FA03029AD3A/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x29DF9334, Call Info(

   Calling Number=67060870,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=10, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Rundeoute Label=, CLID Transparent=FALSE), Call Id=-1

Nov 23 02:16:01.644: //-1/8FA03029AD3A/CCAPI/ccCheckClipClir:

   In: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:01.644: //-1/8FA03029AD3A/CCAPI/ccCheckClipClir:

   Out: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:01.644: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:01.644: :cc_get_feature_vsa malloc success

ABK_CCVoiceGateway#undebug a

Nov 23 02:16:01.644: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:01.644:  cc_get_feature_vsa count is 1

Nov 23 02:16:01.644: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:01.644: :FEATURE_VSA attributes are: feature_name:0,feature_time:834308832,feature_id:4895384

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Alll

All possible debugging has been turned off

ABK_CCVoiceGateway#lowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown))

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/cc_process_call_setup_ind:

   Event=0x31379178

Nov 23 02:16:01.644: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 1890890

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/ccCallSetContext:

   Context=0x31AB674C

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 5227329 with tag 10 to app "_ManagedA

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#ppProcess_Default"

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=TRUE, Mode=0,

   Outgoing Dial-peer=2, Params=0x302C5AD0, Progress Indication=NULL(0)

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/ccCheckClipClir:

   In: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:01.644: //

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#5227329/8FA03029AD3A/CCAPI/ccCheckClipClir:

   Out: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/ccCallSetupRequest:

   Destination Pattern=1890890, Called Number=1890890, Digit Strip=FALSE

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/ccCallSetupRequest:

   Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown),

   Redirect Number=, Display Info=

   Account Number=, Final Destination Flag=TRUE,

   Guid=8FA03029-344A-11E2-AD3A-30E4DB632720, Outgoing Dial-peer=2

Nov 23 02:16:01.644: //5227329/8FA03029AD3A/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=67060870

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=1890890

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-lastrdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Nov 23 02:16:01.648: //5227329/8FA03029AD3A/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x29680440, Interface Type=3, Destination=, Mode=0x0,

   Call Params(Calling Number=67060870,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE, Outgoing Dial-peer=2, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

Nov 23 02:16:01.648: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:01.648: :cc_get_feature_vsa malloc success

Nov 23 02:16:01.648: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:01.648:  cc_get_feature_vsa count is 2

Nov 23 02:16:01.648: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:01.648: :FEATURE_VSA attributes are: feature_name:0,feature_time:834308608,feature_id:4895385

Nov 23 02:16:01.648: //5227330/8FA03029AD3A/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1

Nov 23 02:16:01.648: //5227330/8FA03029AD3A/CCAPI/ccCallSetContext:

   Context=0x302C5A80

Nov 23 02:16:01.648: //5227329/8FA03029AD3A/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=2

Nov 23 02:16:01.648: //5227330/8FA03029AD3A/CCAPI/cc_api_call_proceeding:

   Interface=0x29680440, Progress Indication=NULL(0)

Nov 23 02:16:02.012: //5227330/8FA03029AD3A/CCAPI/cc_api_call_disconnected:

   Cause Value=38, Interface=0x29680440, Call Id=5227330

Nov 23 02:16:02.012: //5227330/8FA03029AD3A/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)

Nov 23 02:16:02.012: //5227329/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:

   release reserved xcoding resource.

Nov 23 02:16:02.012: //5227330/8FA03029AD3A/CCAPI/ccCallSetAAA_Accounting:

   Accounting=0, Call Id=5227330

Nov 23 02:16:02.012: //5227330/8FA03029AD3A/CCAPI/ccCallDisconnect:

Nov 23 02:16:02.012: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:02.012:  vsacount in free is 1

Nov 23 02:16:02.012: //5227329/8FA03029AD3A/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Nov 23 02:16:02.012: //5227329/8FA03029AD3A/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

Nov 23 02:16:02.012: //5227329/8FA03029AD3A/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Nov 23 02:16:02.632: //5227329/8FA03029AD3A/CCAPI/cc_api_call_disconnect_done:

Nov 23 02:16:23.240: //-1/9C7F7B0DAD3B/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=69602498

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=1890890

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-lastrdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Nov 23 02:16:23.240: //-1/9C7F7B0DAD3B/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x29DF9334, Call Info(

   Calling Number=69602498,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=10, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

Nov 23 02:16:23.240: //-1/9C7F7B0DAD3B/CCAPI/ccCheckClipClir:

   In: Calling Number=69602498(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:23.240: //-1/9C7F7B0DAD3B/CCAPI/ccCheckClipClir:

   Out: Calling Number=69602498(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:23.240: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:23.240: :cc_get_feature_vsa malloc success

Nov 23 02:16:23.240: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:23.240:  cc_get_feature_vsa count is 1

Nov 23 02:16:23.240: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:23.240: :FEATURE_VSA attributes are: feature_name:0,feature_time:834308832,feature_id:4895386

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=69602498(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown))

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/cc_process_call_setup_ind:

   Event=0x31379178

Nov 23 02:16:23.240: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 1890890

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCallSetContext:

   Context=0x31ABC674

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 5227331 with tag 10 to app "_ManagedAppProcess_Default"

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=TRUE, Mode=0,

   Outgoing Dial-peer=2, Params=0x2A584D7C, Progress Indication=NULL(0)

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCheckClipClir:

   In: Calling Number=69602498(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCheckClipClir:

   Out: Calling Number=69602498(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCallSetupRequest:

   Destination Pattern=1890890, Called Number=1890890, Digit Strip=FALSE

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccCallSetupRequest:

   Calling Number=69602498(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown),

   Redirect Number=, Display Info=

   Account Number=, Final Destination Flag=TRUE,

   Guid=9C7F7B0D-344A-11E2-AD3B-30E4DB632720, Outgoing Dial-peer=2

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=69602498

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=1890890

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-lastrdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Nov 23 02:16:23.240: //5227331/9C7F7B0DAD3B/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x29680440, Interface Type=3, Destination=, Mode=0x0,

   Call Params(Calling Number=69602498,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE, Outgoing Dial-peer=2, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

Nov 23 02:16:23.244: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:23.244: :cc_get_feature_vsa malloc success

Nov 23 02:16:23.244: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:23.244:  cc_get_feature_vsa count is 2

Nov 23 02:16:23.244: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:23.244: :FEATURE_VSA attributes are: feature_name:0,feature_time:834308608,feature_id:4895387

Nov 23 02:16:23.244: //5227332/9C7F7B0DAD3B/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1

Nov 23 02:16:23.244: //5227332/9C7F7B0DAD3B/CCAPI/ccCallSetContext:

   Context=0x2A584D2C

Nov 23 02:16:23.244: //5227331/9C7F7B0DAD3B/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=2

Nov 23 02:16:23.244: //5227332/9C7F7B0DAD3B/CCAPI/cc_api_call_proceeding:

   Interface=0x29680440, Progress Indication=NULL(0)

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/cc_api_call_disconnected:

   Cause Value=38, Interface=0x29680440, Call Id=5227332

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)

Nov 23 02:16:23.444: //5227331/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:

   release reserved xcoding resource.

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/ccCallSetAAA_Accounting:

   Accounting=0, Call Id=5227332

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=38)

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/cc_api_call_disconnect_done:

   Disposition=-11, Interface=0x29680440, Tag=0x0, Call Id=5227332,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

Nov 23 02:16:23.444: //5227332/9C7F7B0DAD3B/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Nov 23 02:16:23.444: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:23.444: :cc_free_feature_vsa freeing 31BA89F8

Nov 23 02:16:23.444: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:23.444:  vsacount in free is 1

Nov 23 02:16:23.444: //5227331/9C7F7B0DAD3B/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Nov 23 02:16:23.444: //5227331/9C7F7B0DAD3B/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

Nov 23 02:16:23.444: //5227331/9C7F7B0DAD3B/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Nov 23 02:16:23.496: //5227331/9C7F7B0DAD3B/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x29DF9334, Tag=0x0, Call Id=5227331,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

Nov 23 02:16:23.496: //5227331/9C7F7B0DAD3B/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Nov 23 02:16:23.496: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:23.496: :cc_free_feature_vsa freeing 31BA8AD8

Nov 23 02:16:23.496: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:23.496:  vsacount in free is 0

Nov 23 02:16:45.224: //-1/A999F8D5AD3C/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=67060870

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=1890890

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-lastrdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Nov 23 02:16:45.224: //-1/A999F8D5AD3C/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x29DF9334, Call Info(

   Calling Number=67060870,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=10, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

Nov 23 02:16:45.224: //-1/A999F8D5AD3C/CCAPI/ccCheckClipClir:

   In: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:45.224: //-1/A999F8D5AD3C/CCAPI/ccCheckClipClir:

   Out: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:45.224: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:45.224: :cc_get_feature_vsa malloc success

Nov 23 02:16:45.224: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:45.224:  cc_get_feature_vsa count is 1

Nov 23 02:16:45.224: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:45.224: :FEATURE_VSA attributes are: feature_name:0,feature_time:811055800,feature_id:4895388

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown))

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/cc_process_call_setup_ind:

   Event=0x31379178

Nov 23 02:16:45.224: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 1890890

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCallSetContext:

   Context=0x302C9398

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 5227333 with tag 10 to app "_ManagedAppProcess_Default"

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=TRUE, Mode=0,

   Outgoing Dial-peer=2, Params=0x2A56E3E4, Progress Indication=NULL(0)

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCheckClipClir:

   In: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCheckClipClir:

   Out: Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCallSetupRequest:

   Destination Pattern=1890890, Called Number=1890890, Digit Strip=FALSE

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/ccCallSetupRequest:

   Calling Number=67060870(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown),

   Redirect Number=, Display Info=

   Account Number=, Final Destination Flag=TRUE,

   Guid=A999F8D5-344A-11E2-AD3C-30E4DB632720, Outgoing Dial-peer=2

Nov 23 02:16:45.224: //5227333/A999F8D5AD3C/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=67060870

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=1890890

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-lastrdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Nov 23 02:16:45.228: //5227333/A999F8D5AD3C/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x29680440, Interface Type=3, Destination=, Mode=0x0,

   Call Params(Calling Number=67060870,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=1890890(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE, Outgoing Dial-peer=2, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

Nov 23 02:16:45.228: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:45.228: :cc_get_feature_vsa malloc success

Nov 23 02:16:45.228: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:45.228:  cc_get_feature_vsa count is 2

Nov 23 02:16:45.228: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Nov 23 02:16:45.228: :FEATURE_VSA attributes are: feature_name:0,feature_time:811055576,feature_id:4895389

Nov 23 02:16:45.228: //5227334/A999F8D5AD3C/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1

Nov 23 02:16:45.228: //5227334/A999F8D5AD3C/CCAPI/ccCallSetContext:

   Context=0x2A56E394

Nov 23 02:16:45.228: //5227333/A999F8D5AD3C/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=2

Nov 23 02:16:45.228: //5227334/A999F8D5AD3C/CCAPI/cc_api_call_proceeding:

   Interface=0x29680440, Progress Indication=NULL(0)

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/cc_api

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#_call_disconnected:

   Cause Value=38, Interface=0x29680440, Call Id=5227334

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)

Nov 23 02:16:45.428: //5227333/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:

   release reserved xcoding resource.

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/ccCallSetAAA_Accounting:

   Accounting=0, Call Id=5227334

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/ccCallDisconnect:

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#

ABK_CCVoiceGateway#   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=38)

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/cc_api_call_disconnect_done:

   Disposition=-11, Interface=0x29680440, Tag=0x0, Call Id=5227334,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

Nov 23 02:16:45.428: //5227334/A999F8D5AD3C/CCAPI/cc_api_call_d

ABK_CCVoiceGateway#unisconnect_done:

   Call Disconnect Event Sent

Nov 23 02:16:45.428: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:45.428: :cc_free_feature_vsa freeing 3057B9D0

Nov 23 02:16:45.428: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:45.428:  vsacount in free is 1

Nov 23 02:16:45.428: //5227333/A999F8D5AD3C/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Nov 23 02:16:45.428: //5227333/A999F8D5AD3C/CCAPI/ccCalldebDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

Nov 23 02:16:45.428: //5227333/A999F8D5AD3C/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Nov 23 02:16:45.480: //5227333/A999F8D5AD3C/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x29DF9334, Tag=0x0, Call Id=5227333,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

Nov 23 02:16:45.480: //5227333/A999F8D5AD3C/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event S

ABK_CCVoiceGateway#undebug allent

Nov 23 02:16:45.480: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Nov 23 02:16:45.480: :cc_free_feature_vsa freeing 3057BAB0

Nov 23 02:16:45.480: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Highlighted

From the  logs, Cisco is right in that the call disconnect is coming from the far end, that is your provider side. The cause code is 38 which  means that  network is out of order.. The call was routed using the second dial-peer. So the failover is working.

Can you send a debug ccsip messages.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts
Highlighted

Hi aokanlawon

I escalated to another cisco engineer , and said chage the port from 8060 to 5060 and add this commads : session transport TCP to make it TCP not UDP then test.

In actually if i did as he said , how the dial-peer 1 voip is working  with port 8060???

do you think he is right ??

thanks

Highlighted

I didnt even see that in your config. May I ask why you are using port 8060. Sip uses port 5060. So yes the Cisco engineer is right. You can also change the transport mode to use TCP and see if it helps. But it is important to use port 5060. Did your provider instruct you to use port 8060?

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts