cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
284
Views
0
Helpful
6
Replies
Beginner

Dial-peer from pstn cant reach cucm

can someone help me what the issue is with my dial-peers, and to why i cant reach the extension numbers 6001,2,3 on cucm from the pstn, 

 

Router1 connected to the cucm server has a dial-peer as followed

dial-peer voice 1 voip

destination-pattern 10201020

session target voip ipv4:192.168.30.41

dtfm-relay h245-alphanumeric

preference 0

no vad

 

dial-peer voice 2 pots

destination-pattern .T

port 0/0/0:15

 

note: i can reach the ip phone (999) and the analog phone (991) connected to the router2 that is acting as my pstn  from the cucm but thats not the case in the other way round. Im using h323 as my gateway in cucm.

 

Router2 dial-peer:- 

Dial-peer voice 1 pots

Destination-pattern 991

description analog phone extension

Port 0/1/0

 

Dial-peer voice 2 voip

Destination-pattern 6…$

Session target ipv4:192.168.30.41 (cucm ip)

Dtmf-relay h245-alphanumeric

Preference 0

No vad

6 REPLIES 6
Rising star

Re: Dial-peer from pstn cant reach cucm

Hi,

I hope I understand your scenario correctly. The extension 991 on Router-2 is acting as PSTN and extensions 6001, 6002 and 6003 are registered with CUCM. You are trying to call from 991 to CUCM extension 600X. If this is the case, please verify following items:

  1. You have correctly configured H.323 gateway on CUCM with correct Calling Search Space (CSS) for inbound calls. Make sure this CSS can reach extensions 600X.
  2. Verify below configuration on Router-2: 
voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
 allow-connections h323 to h323
 h323
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class h323 1
  h225 timeout tcp establish 2
  h225 timeout setup 2
!
interface GigabitEthernet<Port_Number>
 description # CONNECTED TO LAN #
 ip address <LAN_IP_Address>
 h323-gateway voip interface
 h323-gateway voip bind srcaddr <LAN_IP_Address>
 !
dial-peer voice 2 voip
 description # Dial-Peer for Outgoing Calls to CUCM #
 preference 0
 destination-pattern 6...$
 session target ipv4:192.168.30.41
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 no vad
!

If it still doesn't work then please post the logs for following commands:

debug voip ccapi inout
debug h225 events
debug h225 asn1
debug dial-peer

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.
Beginner

Re: Dial-peer from pstn cant reach cucm

Int fa0/0

No ip add

No shut

Int fa0/0.10

Encapsulation dot1q 10

Ip add 192.168.10.1 255.255.255.0

H323-gateway voip interface

H323-gateway voip bind scraddr 192.168.10.1

 

Voice service voip

Allow-connection sip to sip

Allow-connection sip to h323

Allow-connection h323 to sip

Allow-connection h323 to h323

H323

H225 plus-digit passthru source

Sip

Bind control source-interface fa0/0.10

Bind media source-interface fa0/0.10

 

Dial-peer voice 1 voip

Destination-pattern 10201020

Session target ipv4:192.168.30.41

Dtmf-relay h245-alphanumeric

Preference 0

No vad

 

Dial-peer voice 2 pots

Destination-pattern .T

Port 0/0/0:15

 

Router2:-

 

Note: for router-2 I don’t have voice service voip neither a h323 configured, could that be the issue to why I can’t call from the pstn. I also don’t have voice class and css configured in cucm either, for router 2 it is CME and there’s no voice class

 

Dial-peer voice 1 pots

Destination-pattern 991

description analog phone extension

Port 0/1/0

 

Dial-peer voice 2 voip

Destination-pattern 6…$

Session target ipv4:192.168.30.41

Dtmf-relay h245-alphanumeric

Preference 0

No vad

 

 

If this is not enough, I will post the full config when I get home.

Highlighted
Rising star

Re: Dial-peer from pstn cant reach cucm

Hi,

Can you please put together your scenario in a diagram to understand it better and help you resolve the issue?

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.
Beginner

Re: Dial-peer from pstn cant reach cucm

Sorry for the late reply, heres the exact config im running on the two routers, and im trying to do the same as the picture below.

 

Router-1 config:-

 

!
hostname Router-1
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
enable password 123
!
no aaa new-model
!
memory-size iomem 10
network-clock-participate wic 0
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
!
ip dhcp pool DATA
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 4.2.2.2
!
ip dhcp pool VOICE
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 4.2.2.2
option 150 ip 192.168.30.41
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice service voip
no ip address trusted authenticate
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
h225 plus-digit passthru source
sip
bind control source-interface FastEthernet0/0.10
bind media source-interface FastEthernet0/0.10
registrar server
!
!
voice register global
mode cme
source-address 192.168.10.1 port 5060
max-dn 10
max-pool 10
authenticate register
tftp-path flash:
create profile sync 0004966123053825
camera
video
!
voice register dn 1
number 6001
name Kulan
label Kulan 6001
!
voice register pool 1
id mac 1CAA.0711.325F
type 9971
number 1 dn 1
dtmf-relay rtp-nte sip-notify
description 02077336001
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FCZ092870NQ
license accept end user agreement
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-3,16
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
description CONNECTION FOR VOICE VLAN
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.10.1
!
interface FastEthernet0/0.20
description CONNECTION FOR DATA VLAN
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/0.30
description CONNECTION FOR SERVER VLAN
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn outgoing display-ie
no cdp enable
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
cdp timer 5
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
destination-pattern 10201020
session target ipv4:192.168.30.41
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 2 pots
destination-pattern .T
port 0/0/0:15
!
!
!
!
!
line con 0
exec-timeout 0 0
password 123
logging synchronous
login
line aux 0
line vty 0 4
exec-timeout 0 0
password 123
logging synchronous
login
transport input all
!
scheduler allocate 20000 1000
end

 

 

 

 

Router-2 config:

 

!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router-2
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
!
no aaa new-model
!
memory-size iomem 10
network-clock-participate wic 0
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
!
ip dhcp pool voice
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
option 150 ip 192.168.10.1
dns-server 4.2.2.2
!
ip dhcp pool data
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 4.2.2.2
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FCZ110274Z1
license accept end user agreement
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-3,16
!
controller E1 0/0/1
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn protocol-emulate network
isdn incoming-voice voice
isdn outgoing display-ie
no cdp enable
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
interface FastEthernet0/3/0
switchport access vlan 20
switchport voice vlan 10
no ip address
!
interface FastEthernet0/3/1
switchport access vlan 30
no ip address
!
interface FastEthernet0/3/2
no ip address
!
interface FastEthernet0/3/3
no ip address
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
ip address 10.0.0.2 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
destination-pattern 991
port 0/1/0
!
dial-peer voice 2 voip
destination-pattern 6...$
session target ipv4:192.168.30.41
no vad
!
!
!
!
telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.10.1 port 2000
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Oct 06 2019 07:58:51
!
!
ephone-dn 1 dual-line
number 999
!
!
ephone-dn 2 dual-line
number 999
!
!
ephone 1
device-security-mode none
mac-address E840.40A3.397B
type 7965
button 1:1
!
!
!
ephone 2
device-security-mode none
mac-address 00E1.6D15.297F
type 7965
button 1:1
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end

 

 

 

Rising star

Re: Dial-peer from pstn cant reach cucm

Hi,

It looks like this is your lab environment. There are many issues with the configuration:

1. Same IP Address on Router-1 and Router-2

Router-1

 

interface FastEthernet0/0.10
description CONNECTION FOR VOICE VLAN
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.10.1
!
interface FastEthernet0/0.20
description CONNECTION FOR DATA VLAN
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!

Router-2

 

interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
!

 

2.  Same CME IP Address on both Routers:

Router-1

 

voice register global
mode cme
source-address 192.168.10.1 port 5060

!

Router-2

 

telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.10.1 port 2000

!

 

3. In your post, you mentioned that the extension 6001, 6002 and 6003 are registered with CUCM. But as per below configuration, extension 6001 is configured on Router-1

 

Router-1


voice register dn 1
number 6001
name Kulan
label Kulan 6001
!
voice register pool 1
id mac 1CAA.0711.325F
type 9971
number 1 dn 1
dtmf-relay rtp-nte sip-notify
description 02077336001
!

 

4. From configuration, it looks like you are using switch module on Router-2 and connecting switch port FastEthernet0/3/1 on Router-2 to  FastEthernet0/1 Router-1. This seems to be a switching access port with only VLAN 30 allowed on it.

 

What you are trying to achieve is not going to work with this configuration. You need to streamline your scenario with proper connections, IP Addressing schema and IP Routing.

 

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.
Beginner

Re: Dial-peer from pstn cant reach cucm

same ip add on router 1 and 2:-
they have the same ip address but would you say that would be an issue
since they are configured on seperate routers.

same CME IP Address on both routers:-
for router 1 i registered sip 9971 phone as a cme in my previous lab but then moved
the phones to cucm, so that config is no more relevent.


Yes, in my post i did mention 6001, 2 and 3 and that is in cucm, for router-1
my phones are rigestered through the call manager, i moved away from the cme in
router-1, this was a previous lab sorry for not letting you know


About vlan 30, this was another lab i tried, i setted up both routers as CME
and i was able to route calls from both sides through the pstn and wan link(vlan 30)


how would you configured the pstn that has a switch module card and you would
want to reach an ip phone number on the cucm?

in this dial-peer voip below where we have the ip address of the cucm, doesnt this
dial-peer needs to be first pointed to the cube, how is it going to reach the cube
from the pstn?
dial-peer voice 1 voip
destination-pattern 6...$
session target ipv4:192.168.30.41
dtmf-relay h245-alphanumeric
no vad

does router-2 acting as a pstn require a h323 to be configured as well since i have
router-1 configured as h323?
CUCM Server <---> router-1 (cube) <------> router-2 (CME)


thank you very much, i appricaite your help
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards