cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
7444
Views
16
Helpful
19
Replies
rajasekarvs
Beginner

Dial-peer Preference not working on IOS

Hi,

With regard to the dial peer preference on the router ,we have configured two dial-peers with different session targets and preference. The system seems to be always prefering the dial-peer which is in the first order in router`s configuration.The preference does`nt seem to be actually making any difference.We were able to failover to the second dial-peer if the first dial-peer is kept shut.Could somebody advise on the solution ,if you had come across this ever?

Note : The calls are being tried through the csim start from the router itself.

Hardware Platform : 3845

Software Platform : 12.4(15)T3

Raj

19 REPLIES 19
rajasekarvs
Beginner

Just to add to it ,the dial-peers are sip dial-peers and is being configured for the redundancy purpose.

Raj

Jaime Valencia
Hall of Fame Cisco Employee

can you post the dial-peers?

javalenc

HTH

java

if this helps, please rate

Here you go !!!

dial-peer voice 101 voip

description To Reach CallServer

translation-profile incoming block

preference 1

destination-pattern 6500

session protocol sipv2

session target ipv4:10.10.10.60:5060

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 102 voip

description To Reach CallServer

translation-profile incoming block

preference 2

destination-pattern 6500

session protocol sipv2

session target ipv4:10.10.10.61:5060

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

sip-ua

retry invite 1

timers expires 60000

reason-header override

Jaime Valencia
Hall of Fame Cisco Employee

you would need to run a debug voip ccapi inout to determine if indeed the dial-peers are being used as you mention

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

The default behavior is that the longest matching dial peer supersedes the preference value.

To change it, you can enter "dial-peer hunt 2" in telephony-service.

Nico

I have already tried this with no luck ,as it always prefer the dial-peer 101 and fails over to 102 ,only when the dial-peer is kept shut.Please note that I have the same destination pattern on both of the dial-peers.

Raj

Hi Raj,

In the configuration you posted, dial-peer 101 has a lower preference (and therefore is the preferred dial-peer) than dial-peer 102. Can you confirm that you have you have indeed tried configuring a lower preference on dial-peer 102 to cause it to be the preferred dial-peer?

Regards,

Michael.

Hi Mike,

I have tried that already and was hitting the 101 dial-peer only.

Raj

Thanks Raj,

Any chance you can post here the output of 'debug voip dialpeer all' collected when recreating the problem?

Thanks,

Michael.

Try "preference 10" on DP 101 an "default preference" on 102.

Maybe the "max-con" can help as well.

Greets

Hi,

I still have the same problem ,as the DP 101 is always preferred even after changing the preference 10 & default as suggested. Please find the debus as attached.

Raj

Mike,

Please find the requested debug mesages as attached.DP 101 with pref 2 & DP 102 with pref 1 in this case.

Raj

Hi Raj,

My apologies for the delayed response here. Today's been a busy day. Thanks for capturing and posting your debugs. The observation from the traces is that both dial-peers are indeed candidates for routing the call, but 101 is being selected regardless of the preference on dial-peer 102. My suspicion (and I haven't verified this in the lab) is that the results will be different if the test was an actual call, and not a 'csim start'. Have you had the opportunity to verify if this is the case or if the result is different when there is an inbound dial peer involved before the call is sent out of 101/102?

Regards,

Michael.

I think Michael's suspicion is right. csim doesn't observe all the settings under a DP, for example, it doesn't apply translation-profile. So that could be the issue here.

Create
Recognize Your Peers
Content for Community-Ad