cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
2835
Views
15
Helpful
5
Replies
yesenia-m
Beginner

Dial-peer SIP trunking to PSTN

It has SIP trunks to the PSTN when dialing to the PSTN to an IVR or automatic answering does not collect the digits to be dialed to select menu options or the digits of the extension to which you want to dial.

The dial-peer is configured as follows:

dial-peer voice 3002 voip

description LLAMADAS 01800 POR SIP

destination-pattern 01800.......

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:64.132.31.26

dtmf-relay cisco-rtp rtp-nte

clid network-number 55110713

My question is if I have to change the DTMF command for this:

dtmf-relay h245-alphanumeric

The Gateway is configured as H323.

What is your recommendation?

Thank you

regards

5 REPLIES 5
Suresh Subramanian
Rising star

Hi, I believe it is H.323 to SIP CUBE. please confirm the dtmf method your SIP provider supports. if it is rfc2833, in sip dial-peer, you can configure "dtmf-relay rtp-nte" what is the in-leg dtmf method you have configured for h.323 to cucm?

For DTMF method in SIP: http://www.cisco.com/en/US/docs/ios/12_3/sip/configuration/guide/chapter8.html

//Suresh Please rate all the useful posts.

Please send the full config. Are you using sip-sip or h323-sip? What I mean is that what is your dial-peer to cucm configured for?

Also what DTMF preference have configured for your sip trunk?

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts
yesenia-m
Beginner

Hi Aokanlawon, sureshsub

     This gateway is configured as H323, I send the topology and full config on voice gateway:

.....

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol cisco

!

!

!

voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g723r63

codec preference 4 g711ulaw

codec preference 5 g711alaw

!

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

voice translation-rule 1

rule 1 /0050/ /8500/

!

!

voice translation-profile VOSS

translate called 1

!

!

voice-card 0

dsp services dspfarm

!

!

!

!

!

controller E1 0/0/0

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-20 type r2-digital r2-compelled ani

cas-custom 0

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4

  dnis-digits min 4 max 4

description 20 TRONCALES A PSTN TELMEX

!

!

class-map match-any VOIP-SIGNAL

match ip dscp cs5

match ip precedence 4

match ip precedence 3

class-map match-any VOIP-RTP

match ip dscp ef

match ip precedence 5

!

!

policy-map QOS-Policy

class VOIP-SIGNAL

    priority percent 5

class VOIP-RTP

    priority percent 70

class class-default

    fair-queue

     random-detect

policy-map PARENT

class class-default

    shape average 1700000

  service-policy QOS-Policy

!

!

!

!

!

interface GigabitEthernet0/0

description TO LAN

no ip address

ip virtual-reassembly

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

description INTERFAZ DE DATOS

encapsulation dot1Q 10

ip address 10.10.10.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.20

description INTERFAZ DE VOZ

encapsulation dot1Q 20

ip address 10.10.20.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip h323-id GW-VOSS

h323-gateway voip bind srcaddr 10.10.20.1

!

interface GigabitEthernet0/0.30

description SIP

encapsulation dot1Q 30

ip address 10.10.30.1 255.255.255.0

ip access-group securevoipsip in

no cdp enable

!

!

interface GigabitEthernet0/0.90

description INTERFAZ DE ADMIN

encapsulation dot1Q 90 native

ip address 10.10.90.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/1

ip address dhcp

ip flow ingress

ip nat outside

no ip virtual-reassembly

duplex auto

speed auto

no cdp enable

!

ip local pool ippool 10.10.254.10 10.10.254.12

ip forward-protocol nd

ip route 64.132.31.27 255.255.255.255 64.132.31.26

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source static tcp 10.10.10.11 80 interface GigabitEthernet0/1 8080

ip nat inside source list 103 interface GigabitEthernet0/1 overload

ip nat inside source static tcp 10.10.10.21 3306 interface GigabitEthernet0/1 3306

!

!

!

route-map To-Prodigy permit 10

match ip address 23

set ip default next-hop 200.38.193.226

!

!

!

control-plane

!

!

!

call filter match-list 13 voice

outgoing dialpeer 3003

!

voice-port 0/0/0:0

description TRONCALES DIGITALES TELMEX (444) 8340050

!

voice-port 0/1/0

supervisory disconnect dualtone mid-call

cptone MX

timeouts call-disconnect 2

timeouts wait-release 2

connection plar opx 5000

description TRONCAL ANALOGA (444) 1232306

caller-id enable

!

voice-port 0/1/1

supervisory disconnect dualtone mid-call

cptone MX

timeouts call-disconnect 2

timeouts wait-release 2

connection plar opx 5000

description TRONCAL ANALOGA 444 1232305

caller-id enable

!

voice-port 0/2/0

!

voice-port 0/2/1

!

!

mgcp fax t38 ecm

!

sccp local GigabitEthernet0/0.20

sccp ccm 10.10.20.2 identifier 1 version 7.0

sccp ip precedence 3

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register XCODER

!

dspfarm profile 1 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 15

associate application SCCP

!

!

dial-peer voice 1000 pots

  description TDM-IN

incoming called-number .

direct-inward-dial

port 0/0/0:0

!

dial-peer voice 2000 voip

description MARCACION A CALL MANAGER PUBLISHER

destination-pattern [1-8]...

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.20.2

incoming called-number .

dtmf-relay cisco-rtp rtp-nte h245-alphanumeric h245-signal

fax-relay ecm disable

fax rate 9600

no vad

!

dial-peer voice 9000 pots

description LLAMADAS LOCALES SLP A PSTN DIGITAL  PTO 0/0/0:0

preference 2

destination-pattern #9[1-9]......

port 0/0/0:0

forward-digits 7

!

dial-peer voice 3000 voip

description LLAMADAS EU-CANADA POR SIP

destination-pattern 001.............

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:64.132.31.26

dtmf-relay cisco-rtp rtp-nte

clid network-number 55110713

!

dial-peer voice 3001 voip

description LLAMADAS INTERNACIONALES POR SIP

destination-pattern 00T

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:64.132.31.26

dtmf-relay cisco-rtp rtp-nte

  clid network-number 55110713

!

dial-peer voice 3002 voip

description LLAMADAS 01800 POR SIP

destination-pattern 01800.......

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:64.132.31.26

dtmf-relay cisco-rtp rtp-nte

clid network-number 55110713

!

....

It's the first time I must configure voice gateways that have SIP trunks to the PSTN, if you need any other information they do get.

Thank you for your support.

regards

Can you try this..

Configure only dtmf relay rtp-nte on your sip dial-peer

eg..

dial-peer voice 3002 voip

dtmf-relay rtp-nte

then configure the following on your h323 dial-peer (make sure you configure this on all the h323 dial-peer to cucm)

Also ensure you remove the old dtmf config.

dial-peer voice 2000 voip

dtmf-relay rtp-nte digit-drop sip-kpml

Do a test call and send the ff debugs if it doesnt work

debug ccsip messages

debug voip rtp session named-event

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts

I think he should try "dtmf-relay  rtp-nte" on both the incoming (h323 dial peer) and outgoing (sip dialpeer)  call legs.

please remove "dtmf-relay cisco-rtp rtp-nte h245-alphanumeric h245-signal" from the dial-peer voice 2000 voip and configure only rtp-nte with the command "dtmf-relay rtp-nte".

In dial-peer voice 3002 voip also, remove "dtmf-relay cisco-rtp rtp-nte" and add only "dtmf-relay rtp-nte".

if that doesn't work, as aokanlawon said, collect debug ccsip messages & debug voip rtp session named-event.

please provide, calling party number, called party number and time of call.

thanks

//Suresh Please rate all the useful posts.
Content for Community-Ad

Spotlight Awards 2021