cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
387
Views
0
Helpful
0
Replies

Dial-Peer voip Busyout State No Options packet being sent

MARK CASEY
Level 1
Level 1

Hi

I have a 3925E IOS 15.6(3)M4 router

When I enable the voice-class sip options-keepalive profile 19 to the dial peer, the peer goes busy out.

I can ping both ways between the router 10.178.2.25 and the 10.242.253.252 (asterisk system) in vrf Local-Voice from the router.  If I set qualify=no on the asterisk system and dial, I see the INVITE, but no return packets.

 

Its an internal route with no firewalls/access control nat available.

Packet capture shows no SIP Option Packets.

 

 With the following debug 

debug ccsip messages

debug ccsip events

debug ccsip error

debug voip ccapi inout

 

the only thing I see is

 

Dec 17 14:38:22 10.178.2.25 360443990: Dec 17 14:38:21: //-1/xxxxxxxxxxxx/SIP/Error/sip_udp_ipv4_create_connect:
Dec 17 14:38:22 10.178.2.25 360443991: Inconsistency error in Conn table, status: 1513
Dec 17 14:38:22 10.178.2.25 360443992: Dec 17 14:38:21: //-1/xxxxxxxxxxxx/SIP/Error/sipConnectionManagerProcessConnFailed:
Dec 17 14:38:22 10.178.2.25 360443993: Could not find connection for addr=10.242.253.252, port=5060, local_addr=10.178.2.25
Dec 17 14:38:22 10.178.2.25 360443994: Dec 17 14:38:22: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

 

 

 

Dec 17 13:51:06 10.178.2.25 359734190: Dec 17 13:51:06: //96461076/89A727AB8B8D/SIP/Error/sipSPIFlushDeferredQueue:
Dec 17 13:51:06 10.178.2.25 359734191: Invalid deferredQueue
Dec 17 13:51:06 10.178.2.25 359734192: Dec 17 13:51:06: //-1/xxxxxxxxxxxx/SIP/Error/sipConnectionManagerUnregisterCtxtInConnection:
Dec 17 13:51:06 10.178.2.25 359734193: Connection not found for addr=10.242.253.252, port=5060 local_addr=10.178.2.25
Dec 17 13:51:06 10.178.2.25 359734194: Dec 17 13:51:06: //-1/xxxxxxxxxxxx/SIP/Error/httpish_msg_free:
Dec 17 13:51:06 10.178.2.25 359734195: Freeing NULL pointer!

 

Relevant configurations is

ip vrf Local-Voice
description Local Voice

voice vrf Local-Voice
!
voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0
no notify redirect ip2ip
callmonitor
media statistics
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
no supplementary-service sip handle-replaces
supplementary-service media-renegotiate
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 3600 min 3600
privacy-policy passthru
sip-profiles 1
no call service stop
!

voice class sip-options-keepalive 19
description MSA PABX
down-interval 5
up-interval 5
retry 4
transport udp
sip-profiles 1

voice class server-group 19
ipv4 10.242.253.252
description Outgoing Calls to MSA-PBX


interface GigabitEthernet0/0
description internal Trunk
no ip address
duplex auto
speed auto
service-policy output BRANCH-WAN-EDGE
!
interface GigabitEthernet0/0.1
description Management Interface
encapsulation dot1Q 99
ip address 10.242.99.149 255.255.255.0
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 91
ip vrf forwarding Local-Voice
ip address 10.178.2.25 255.255.255.0

dial-peer voice 19 voip
description Outbound Calls To MSA-PABX - (Outbound)
huntstop
destination-pattern 0280803677
session protocol sipv2
session server-group 19
voice-class codec 1
voice-class sip options-keepalive profile 19
voice-class sip bind control source-interface GigabitEthernet0/0.2
voice-class sip bind media source-interface GigabitEthernet0/0.2
dtmf-relay rtp-nte
no vad

 

I am assuming that this indicates that the router cant work out how to connect to the remote system. But I cant work out how to tell it as it can already route packets to it.

 

Any ideas ?

Any Idea what additional debug I could enable to work out what the issue is ?

 

Thanks in advance

 

Mark

0 Replies 0