cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4985
Views
0
Helpful
3
Replies

Dial peers in MGCP

Hello,

     I have a cisco 3825 gateway and would like to add a second PRI. I have configured the Call Manager gateway to take the second PRI on 0/2/1. When I looked at the configuration on the 3825 gateway I got confused when I saw Dial-peer with port 0/2/0:23. I thought that if I set it in the call manager the MGCP gateway would get the configuration from the call manager and no dial-peer would be needed in the gateways configuration. How can I add the second PRI on the gateway and have call manager use it? What is the use for dial-peers?

dial-peer voice 9 pots
service mgcapp
port 0/2/0:23
!
dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
port 0/2/0:23
!
dial-peer voice 911 pots
destination-pattern 911
no digit-strip
port 0/2/0:23
!
dial-peer voice 9911 pots
translation-profile outgoing OUTBOUND_STRIP9
destination-pattern 9911
no digit-strip
port 0/2/0:23
!
dial-peer voice 100 pots
translation-profile outgoing OUTBOUND_STRIP9
destination-pattern 9[2-9]......
no digit-strip
port 0/2/0:23
!
dial-peer voice 101 pots
translation-profile outgoing OUTBOUND_STRIP9
destination-pattern 9[2-9]..[2-9]......
no digit-strip
port 0/2/1:23
!
dial-peer voice 102 pots
translation-profile outgoing OUTBOUND_STRIP9
destination-pattern 91[2-9]..[2-9]......
no digit-strip
port 0/2/1:23
!
dial-peer voice 103 pots
translation-profile outgoing OUTBOUND_STRIP9
destination-pattern 9011T
no digit-strip
port 0/2/1:23
!

3 Replies 3

Clifford McGlamry
Spotlight
Spotlight

Those dial peers are for SRST use most likely (if the gateway is in MGCP mode).

The circuit is added to MGCP control by defining the PRI under the controller with something like:

pri-group timeslots 1-24 service mgcp

And under the serial interface you may need to add:

isdn bind-l3 ccm-manager

You do not normally need the dial peer to place a T1 under MGCP control because it's defined under the controller.  As a result, the following from your config probably isn't needed:

dial-peer voice 9 pots
service mgcapp
port 0/2/0:23

You would need something like the above for an analog port (FXO or FXS).

Cliff

Clifford,

     I copied and pasted the voice configuration of the 3825 gateway. We don’t use SRST since we have one site. We have two call managers and two gateways (3825&2811). I am adding a second PRI to the 3825 gateway; I have configured the second VIC endpoint in call manager under gateway configuration. Both gateways are running MGCP and are controlled by call manager. Is there any reason why I should have the dial peers other than for SRST? Can you see any mistakes on my voice config?

!

isdn switch-type primary-dms100

voice-card 0

no dspfarm

!

!

!

voice call carrier capacity active

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

!

!

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /^9/ //

!

!

voice translation-profile OUTBOUND_STRIP9

translate called 1

!

controller T1 0/2/0

framing esf

linecode b8zs

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description AT&T VOIP PRI - ***-***-0041

!

controller T1 0/2/1

framing esf

linecode b8zs

cablelength long 0db

pri-group timeslots 1-24 service mgcp

description AT&T VOIP PRI - ***-***-8789

!

ip ssh time-out 60

ip ssh version 2

!

!

!

!

interface Tunnel1

no ip address

!

interface GigabitEthernet0/0

ip address 10.10.0.14 255.255.255.0

duplex full

speed 1000

media-type rj45

no mop enabled

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex full

speed 1000

media-type rj45

!

interface Serial0/2/0:23

description AT&T VOIP PRI Channels - ***-***-0041

no ip address

encapsulation ppp

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

!

interface Serial0/2/1:23

description AT&T VOIP PRI Channels - ***-***-8789

no ip address

encapsulation ppp

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

!

control-plane

!

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/2/0:23

echo-cancel coverage 24

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/2/1:23

echo-cancel coverage 24

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.10.0.8

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.0.9

ccm-manager config

!

mgcp

mgcp call-agent 10.10.0.9 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 gateway force

mgcp rtp payload-type g726r16 static

mgcp behavior g729-variants static-pt

!

mgcp profile default

!

!

!

dial-peer voice 9 pots

service mgcapp

port 0/2/0:23

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

port 0/2/0:23

!

dial-peer voice 911 pots

destination-pattern 911

no digit-strip

port 0/2/0:23

!

dial-peer voice 9911 pots

translation-profile outgoing OUTBOUND_STRIP9

destination-pattern 9911

no digit-strip

port 0/2/0:23

!

dial-peer voice 100 pots

translation-profile outgoing OUTBOUND_STRIP9

destination-pattern 9[2-9]......

no digit-strip

port 0/2/0:23

!

dial-peer voice 101 pots

translation-profile outgoing OUTBOUND_STRIP9

destination-pattern 9[2-9]..[2-9]......

no digit-strip

port 0/2/0:23

!

dial-peer voice 102 pots

translation-profile outgoing OUTBOUND_STRIP9

destination-pattern 91[2-9]..[2-9]......

no digit-strip

port 0/2/0:23

!

dial-peer voice 103 pots

translation-profile outgoing OUTBOUND_STRIP9

destination-pattern 9011T

no digit-strip

port 0/2/0:23

!

dial-peer voice 10 pots

service mgcapp

!

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.10.0.14 port 2000

max-ephones 100

metalium2007
Level 3
Level 3

Please take a careful look at the following doc:

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/interop/intcnf1.html

Rgds

met