cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9421
Views
27
Helpful
16
Replies
Beginner

dial plan and inter-digit timeout

we are using CUCM 8.6

we have a route pattern set up for local 7 digit numbers: [5-9]XXXXXX

we also have internal 4 digit DNs which start with 9

when dialing the internal DNs there is a delay because of inter-digit timeout

how can i fix this , isaw somthing about using the # button to stop interdigit  counting.

how could i set taht up ,or any other solution.

thanks

Everyone's tags (4)
16 REPLIES 16
Highlighted
Contributor

Re: dial plan and inter-digit timeout

In the route pattern put in the end # .. Then you can dial outside call following with the #

or change the access code for pstn numbers from 9 to 8.00! For example

Sent from Cisco Technical Support iPhone App

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Beginner

Re: dial plan and inter-digit timeout

my problem is with the inside calls, having to wait for timeout is no good.

we do not want to use an access access code for outside calls

the question is is there a way to to let call manager know when i mean to dial only 4 digits and otherwise wait for more?

Highlighted
Contributor

Re: dial plan and inter-digit timeout

8.00! It was for international calls.. You can do it also for local calls..

I am sure that you catch what i mean

Sent from Cisco Technical Support iPhone App

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Contributor

Re: dial plan and inter-digit timeout

Just to understand.. For calls outside to the pstn you don't use access code.. I mean for example 9 and then the other digits ?

Sent from Cisco Technical Support iPhone App

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Beginner

Re: dial plan and inter-digit timeout

we do not use an access code

we dial 7 digits for local area calls (the users like it that way , just like they call at home)

Highlighted
Contributor

Re: dial plan and inter-digit timeout

OK

Clear.But you will have problem with this setup since your extensions numbers starting with 9.Your route pattern for local calls overlaping with  your extensions numbers.

If i am correct you cant do anything about that with the current setup

Two solutions

Access code and then the remaining digits(But you dont want that)

Second change your first number of your  extensions ..starting with 1 for example

But the best practice is the access code

Regards

chrysostomos

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted
Beginner

Re: dial plan and inter-digit timeout

i read about an option of adding a # after internal DNs to cut of inter-digit timeout.

do you know of such an option?

Highlighted
Contributor

Re: dial plan and inter-digit timeout

Hi

You can change the inter-digit value to a 3000(this is the lower) , but dont except too much with that.

You will have again a delay (3sec)

Check at the service Parameter

Service: Call Manager

Clusterwide Parameters (Device - General)

T302 and change the value there

Regards

cc

Please rate all useful posts Regards Chrysostomos ""The Most Successful People Are Those Who Are Good At Plan B""
Highlighted

dial plan and inter-digit timeout

Hi Jacob Berger,

were you able to find a solution ?

Iam having the same issue

thank you.

Highlighted
Beginner

dial plan and inter-digit timeout

Hi  Syed

No we didnt find a solution for uor current config

the two choices left are changing the current config.

1. creating an access code for external calls (a number which none of our internal DNs start with)

2. dialing external calls with area code even in local area (maybe easier to implemnet becuse its like dialing from a mobile phone)

Highlighted

Re: dial plan and inter-digit timeout

Hi Jocab,

Here is what i did as a work around.

Configured to Connect to Remote Extensions

!

dial-peer voice 330 voip

destination-pattern 33..T

session target ipv4:10.11.3.15

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 340 voip

destination-pattern 34..T

session target ipv4:10.11.3.15

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad  

!

dial-peer voice 350 voip

destination-pattern 35..T

session target ipv4:10.11.3.15

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!     

Configured to connect Local PSTN

!        

dial-peer voice 501 pots

corlist outgoing Local

service aa

destination-pattern [3,8,6].T

port 0/2/3

forward-digits 7

!  

with the above configuration the calls are working as expected with default interdigit time out.

at least for now it seems to be working, but i did infrom the customer to get back to me if they face any issue to change the configuration to have an access code for external calls as you stated.

thank you.

Highlighted
Beginner

Hi, run the following command

Hi,

 

run the following command:

R1#config term
R1(config term)#telephony-service
R1(config-telephony)#timeouts interdigit 2  ---time between digits before dialing


Please STAR5
​Thank you

 

Interdigit timeout duration, in seconds. Range is 0 to 120. The default is 10.
To set the interdigit timeout value for all Cisco IP phones in a Cisco Unified CME system, use the timeouts interdigit command in telephony-service configuration mode. To return to the default value, use the noform of this command.
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/command/reference/cme_cr/cme_t1ht.html#wp9582813200

 

 

Highlighted
Hall of Fame Cisco Employee

This is an old thread, and

This is an old thread, and the were asking about CUCM, NOT CME

HTH

java

if this helps, please rate
Highlighted
Beginner

Hi, I had the same problem

Hi, I had the same problem for a while, in my case calls made from the VG224 did not perform calls for very long digits, such as international calls, eg "9188 0 X XXXXXXXXXXXX" even if they could make the call without problem from conventional iP phones, looking for solutions got both:

1. From the VG224 changing the voice port parameter "timeouts inter-digit = 30 (default is 10), that work for my.


This led me to think that the problem was marking time and got another more general and definitive solution.


2. In the CUCM (7, 9 or 10) "Administratio> System> Service Parameters> Call Manager (Active)" modify the "T302 Timer" value to 6000 (default 15000, this definitely solved the problem for me.


I hope this helps.

CreatePlease to create content