cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
858
Views
0
Helpful
2
Replies

Dial Plan delay in calling

DOUGLAS DRURY
Beginner
Beginner

Hi,

I've configured CME 8.6 and all is working fine I can make outgoing calls and incoming on my ISDN line however, how two small issues that I can’t quite figure out.  I'm more than certain that the two issues are down to my dial plan.  The first one is when there is an incoming call the 0 in the area code is cut off i.e.. 01771688547 will look like 1771688547 thus if you try and hit redial the call fails.  The second issue is when you make an outgoing call there is about a 10 second delay before the call is made.  Again I think this is down to my poor dial plan.  I'm still trying to get my head round dial plans but I would greatly appreciate if someone could help me.

Thanks

Doug 

TS-UCME-01#sh run
Building configuration...


Current configuration : 11886 bytes
!
! Last configuration change at 10:47:16 PCTime Tue Jun 10 2014 by tsadmin
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TS-UCME-01
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$B2oE$/iD9ywnNv28iVOQx2e2pQ.
!
no aaa new-model
!
clock timezone PCTime 0 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
network-clock-participate wic 0
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 192.168.15.1 192.168.15.9
ip dhcp excluded-address 192.168.15.201 192.168.15.254
!
ip dhcp pool UCME
 import all
 network 192.168.15.0 255.255.255.0
 domain-name Tekserv.local
 dns-server 8.8.8.8
 option 150 ip 192.168.15.1
 lease 0 10
!
!
!
ip domain name tekserv.local
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
!
!
voice hunt-group 1 parallel
 final 907963375351
 list 5401,5402
 timeout 15
 pilot 2001
!
!
!
!
voice translation-rule 1
 rule 1 /^.*/ /478064/
!
voice translation-rule 2
 rule 1 /^478064$/ /2001/
!
voice translation-rule 3
 rule 1 /^481618$/ /5401/
!
!
voice translation-profile CALLER_ID_478064
 translate calling 1
!
voice translation-profile In_2
 translate called 2
!
voice translation-profile Phil_Inbound_DDI_3
 translate called 3
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2390328788
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2390328788
 revocation-check none
 rsakeypair TP-self-signed-2390328788

!
license udi pid CISCO2811 sn FCZ123570ZM
username tsadmin privilege 15 secret 5 $1$h3QN$JDGfI/oPLZGmIRgLk8.K01
!
redundancy
!
!
no ip ftp passive
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description Phone_LAN
 ip address 192.168.15.1 255.255.255.0
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered FastEthernet0/0
 service-module ip address 192.168.15.2 255.255.255.0
 service-module ip default-gateway 192.168.15.1
!
interface FastEthernet0/1
 description Inside LAN
 ip address 192.168.1.253 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0/0
 description Tekserv_ISDN_1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn static-tei 0
!
interface BRI0/0/1
 description NOT_IN_USE
 no ip address
 shutdown
 isdn switch-type basic-net3
 isdn point-to-point-setup
!
!
router eigrp 10
 network 192.168.15.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
!
ip route 192.168.15.2 255.255.255.255 Service-Engine0/0
!
!
!
!
!
!
tftp-server flash:phone/sccp6921-6941-6961/SCCP69xx.9-1-1-0.loads alias SCCP69xx.9-1-1-0.loads
tftp-server flash:phone/sccp6921-6941-6961/SCCP69xx.9-1-1-0.zz.sgn alias SCCP69xx.9-1-1-0.zz.sgn
tftp-server flash:phone/sccp6921-6941-6961/DSP69xx.0-0-0-4.zz.sgn alias DSP69xx.0-0-0-4.zz.sgn
tftp-server flash:phone/sccp6921-6941-6961/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash:phone/sccp7905/CP7905080003SCCP070409A.sbin alias CP7905080003SCCP070409A.sbin
tftp-server flash:phone/sccp7905/CP7905080003SCCP070409A.zup alias CP7905080003SCCP070409A.zup
tftp-server flash:phone/sccp7906-7911/SCCP11.9-1-1SR1S.loads alias SCCP11.9-1-1SR1S.loads
tftp-server flash:phone/sccp7906-7911/apps11.9-1-1TH1-16.sbn alias apps11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/cnu11.9-1-1TH1-16.sbn alias cnu11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/cvm11sccp.9-1-1TH1-16.sbn alias cvm11sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/dsp11.9-1-1TH1-16.sbn alias dsp11.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7906-7911/jar11sccp.9-1-1TH1-16.sbn alias jar11sccp.9-1-1TH1-16.sbn
tftp-server flash:term06.default.loads alias term06.default.loads
tftp-server flash:term11.default.loads alias term11.default.loads
tftp-server flash:phone/sccp7915/B015-1-0-4.SBN alias B015-1-0-4.SBN
tftp-server flash:phone/sccp7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
tftp-server flash:P00307020200.bin alias P00307020200.bin
tftp-server flash:phone/sccp7940-7960/P00308010200.loads alias P00308010200.loads
tftp-server flash:phone/sccp7940-7960/P00308010200.bin alias P00308010200.bin
tftp-server flash:phone/sccp7940-7960/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:phone/sccp7940-7960/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:phone/sccp7941-7961/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads
tftp-server flash:phone/sccp7941-7961/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn
tftp-server flash:phone/sccp7941-7961/term41.default.loads alias term41.default.loads
tftp-server flash:phone/sccp7941-7961/term61.default.loads alias term61.default.loads
!
control-plane
!
!
voice-port 0/0/0
 compand-type a-law
 cptone GB
 description Tekserv_ISDN_1
!
voice-port 0/0/1
 description NOT_IN_USE
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
 destination-pattern 5499
 session protocol sipv2
 session target ipv4:192.168.15.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 2 voip
 destination-pattern 5498
 session protocol sipv2
 session target ipv4:192.168.15.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 pots
 description Main_Line_OutBound
 translation-profile outgoing CALLER_ID_478064
 destination-pattern 9T
 port 0/0/0
!
dial-peer voice 4 pots
 description Main_Line_Inbound
 translation-profile incoming In_2
 incoming called-number 478064
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 5 pots
 description Phil_Inbound
 translation-profile incoming Phil_Inbound_DDI_3
 incoming called-number 481618
 direct-inward-dial
 port 0/0/0
!
!
!
!
telephony-service
 no auto-reg-ephone
 max-ephones 10
 max-dn 10
 ip source-address 192.168.15.1 port 2000
 service dnis dir-lookup
 system message Tekserv PD
 cnf-file location flash:
 load 7915-12 B015-1-0-4.SBN
 load 7915-24 B015-1-0-4.SBN
 load 7916-12 B016-1-0-4.SBN
 load 7916-24 B016-1-0-4.SBN
 load 7906 SCCP11.8-3-3S.loads
 load 7911 SCCP11.8-3-3S.loads
 load 7920 cmterm_7920.4.0-02-00.bin
 load 7960-7940 P00307020200.loads
 load 7941 SCCP41.9-1-1SR1S.loads
 load 7941GE SCCP41.9-1-1SR1S.loads
 load 7961 SCCP41.9-1-1SR1S.loads
 load 7961GE SCCP41.9-1-1SR1S.loads
 load 6921 SCCP69xx.9-1-1-0.loads
 load 6941 SCCP69xx.9-1-1-0.loads
 load 6961 SCCP69xx.9-1-1-0.loads
 date-format dd-mm-yy
 voicemail 5499
 max-conferences 8 gain -6
 hunt-group logout HLog
 moh flash:/Cisco_CallManagerOHM.au
 multicast moh 239.1.1.1 port 16384 route 192.168.1.253 192.168.15.1
 web admin system name phoneadmin password phoneadmin
 dn-webedit
 transfer-system full-consult
 night-service code *1234
 night-service day Sun 07:31 07:30
 night-service day Mon 17:00 07:30
 night-service day Tue 17:00 07:30
 night-service day Wed 17:00 07:30
 night-service day Thu 17:00 07:30
 night-service day Fri 17:00 07:30
 night-service day Sat 07:31 07:30

 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn-template  1
 call-forward busy 5499
 call-forward noan 5499 timeout 18
!
!
ephone-template  1
 softkeys hold  Join Newcall Resume Select
 softkeys idle  Pickup Dnd Cfwdall Gpickup Redial Newcall Login
 softkeys seized  Redial Endcall Cfwdall Pickup Gpickup Callback
 softkeys alerting  Acct Callback Endcall
 softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
!
!
ephone-dn  1  dual-line
 number 5401
 pickup-group 1
 label Ext - 5401
 description Phil Rennie
 name Phil Rennie
 call-forward busy 5499
 call-forward noan 5499 timeout 10
 ephone-dn-template 1
!
!
ephone-dn  2  dual-line
 number 5402
 pickup-group 1
 label Ext - 5402
 description Doug Drury
 name Doug Drury
 call-forward busy 5499
 call-forward noan 5499 timeout 10
 ephone-dn-template 1
!
!
ephone-dn  3
 number 1
 name All
 paging ip 239.0.0.1 port 2000
!
!
ephone-dn  4  dual-line
 number 5403
 label Ext - 5403
 description Test
 name test test
 ephone-dn-template 1
!
!
ephone  1
 device-security-mode none
 mac-address 0012.00EC.B345
 ephone-template 1
 username "phil"
 paging-dn 3
 type 7940
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 0012.0101.0C75
 ephone-template 1
 username "doug" password 123456
 paging-dn 3
 type 7940
 button  1:2
 pin 123456
!
!
!
ephone  3
 device-security-mode none
 mac-address E411.5B2B.182C
 username "test" password 123456
 type CIPC
 button  1:4
 pin 123456
!
!
!
!
line con 0
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 login local
 transport input telnet ssh
 transport output telnet ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 194.164.127.6 prefer source FastEthernet0/1
end

TS-UCME-01#

2 Replies 2

Suresh Subramanian
Rising star
Rising star

Hello,

for the first issue, you may configure the translation rule to prefix 0 for the calling number and apply it to translation profile and to the incoming dial-peer. configuration example below.

 

voice translation-rule 4
 rule 1 // /0/


voice translation-profile In_2
 translate called 2
 translate calling 4
!
voice translation-profile Phil_Inbound_DDI_3
 translate called 3
translate calling 4


for the second issue of 10 digits delay, it is the default interdigit timer value. you can change that value under voice-port.

 

voice-port 0/0/0
timeouts interdigit 5 <<5 seconds>>

 

http://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/14074-in-dial-peer-match.html?referring_site=smartnavRD#topic10

 

//Suresh

Please rate all the helpful posts

//Suresh Please rate all the useful posts.

Brian Meade
Rising star
Rising star

To get rid of the 10-second delay, you'll need to make a real dial-plan and not just use 9T unless your users don't mind dialing # at the end of the number or waiting for the delay.

 

You'll need to make dial-peers for emergency calls, local calls, national calls, and international calls that do not overlap.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers