cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2709
Views
10
Helpful
8
Replies

DTMF Issue on Crestron Mercury Hooked to CUCM 11.5.1

mzsaad123
Beginner
Beginner

hello guys,

Here is my topology:

Crestron Mercury--SIP--CUCM 11.5.1SU2--MGCP--VGW--PRI (PSTN)

Everything is working as expected. DTMF works and all.

I changed the Gateway protocol to SIP instead of MGCP. DTMF stopped working.

DMTF on Cisco End Points working as expected (while gateway is on SIP). Only issue is with Crestron Mercury.

Anyone has an idea what could be causing this?

Here are some DTMF related information about how I configured my SIP trunk.

SIP Trunk:

Media Termination Point Required - Unchecked

DTMF Signaling Method: RFC2833

SIP Trunk Profile:

Early Offer support for voice and video calls: Mandatory - Insert MTP if required

On VGW:

Dial-peer towards CUCM

 

dial-peer voice 1 voip
 destination-pattern 555.......
 session protocol sipv2
 session target ipv4:1.1.1.1
 voice-class codec 1
 dtmf-relay rtp-nte
 ip qos dscp cs3 signaling

 

voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g722-64
codec preference 4 g729r8

 

TIA.

 

1 Accepted Solution

Accepted Solutions

mzsaad123
Beginner
Beginner

the issue is fixed. here is what was done.

 

follow this doc:

https://www.crestron.com/getmedia/e2e1c212-4b6a-46a4-ac9b-f8ecaf4aa8a4/mg_cg_ccs-uc-1_sip_endpoint_cisco_ucm

this above doc is for non-secure RTP. if you have secure RTP, there is another doc available on crestron's website. 

Also add for the following command on the cube:

(config)#voice service voip

(conf-voi-serv)#sip

(conf-serv-sip)#asymmetric payload dtmf

 

try the above CUBE command without doing anything else to see if that fixes it.

View solution in original post

8 Replies 8

R0g22
Cisco Employee
Cisco Employee
A couple of changes that I would suggest -
1. Set the DTMF method to "No preference".
2. On the SIP profile, use Best Effort instead of Mandatory.

On the GW dial-peer, add "dtmf-relay sip-kpml rtp-nte".

Clearly there is a DTMF mismatch. To best identify the problem during an
active call check the command 'show call active voice | i Dtmf' and see
what dtmf being selected for both call legs. Then we confirm what the
Crestron is trying to use. Also, you should enable all kinds to dtmf-relay
on dialpeer including sip-kpml and rtp-nte

NB. If the command didn't work try 'show call active voice | i dtmf'

thanks for the response guys. i will try the suggested proposed solutions. 

As far as troubleshooting DTMF while on the active call, I think you are assuming that my telco is SIP too. My PSTN is PRI. I don't think I would get any output on CUBE. DTMF is getting lost somewhere on my side.

 

I have this exact same issue with a Crestron Mercury on CUCM 11.5 utilizing a SIP trunk to our PRI Gateway.

 

Here is some dtmf outputs and i am using

 

 dtmf-relay rtp-nte sip-kpml on my dial peers.

 

These are from the Crestron Mercury that do not work

 

Apr  6 23:29:23.744:  <<<Rcv> Pt:101    Evt:3       Pkt:0A 05 A0
Apr  6 23:29:23.764:          s=VoIP d=DSP payload 0x65 ssrc 0x3B787E0A sequence 0x1637 timestamp 0xECE0
Apr  6 23:29:23.768:  <<<Rcv> Pt:101    Evt:3       Pkt:8A 06 40
Apr  6 23:29:23.792:          s=VoIP d=DSP payload 0x65 ssrc 0x3B787E0A sequence 0x1638 timestamp 0xECE0
Apr  6 23:29:23.792:  <<<Rcv> Pt:101    Evt:3       Pkt:8A 06 40
Apr  6 23:29:23.812:          s=VoIP d=DSP payload 0x65 ssrc 0x3B787E0A sequence 0x1639 timestamp 0xECE0
Apr  6 23:29:23.816:  <<<Rcv> Pt:101    Evt:3       Pkt:8A 06 40

 

And these are from a Cisco 7841 that work perfectly


VOIP RTP Named Events - ALL debugging is on
Apr  6 23:30:21.708:          s=VoIP d=DSP payload 0x65 ssrc 0xF8502698 sequence 0x366D timestamp 0x8A224527
Apr  6 23:30:21.708:  <<<Rcv> Pt:101    Evt:3       Pkt:09 00 00
Apr  6 23:30:21.728:          s=VoIP d=DSP payload 0x65 ssrc 0xF8502698 sequence 0x366F timestamp 0x8A224527

 

 

 

mzsaad123
Beginner
Beginner

the issue is fixed. here is what was done.

 

follow this doc:

https://www.crestron.com/getmedia/e2e1c212-4b6a-46a4-ac9b-f8ecaf4aa8a4/mg_cg_ccs-uc-1_sip_endpoint_cisco_ucm

this above doc is for non-secure RTP. if you have secure RTP, there is another doc available on crestron's website. 

Also add for the following command on the cube:

(config)#voice service voip

(conf-voi-serv)#sip

(conf-serv-sip)#asymmetric payload dtmf

 

try the above CUBE command without doing anything else to see if that fixes it.

I looked through the doc, and did not see that command in there (even did a CTRL+F to find it).

A) How did you know to put it in there, if it's not in the doc?
B) What exactly is that command changing, to make the solution work?

Hi Anthony,

This command is not in this document. I should have clarified earlier. This was given to us by an engineer at Crestron.

Here is what this command does:

 

Cisco UBE supports dynamic payload type negotiation and interworking for all symmetric and asymmetric payload type combinations. A call leg on Cisco UBE is considered as symmetric or asymmetric based on the payload type value exchanged during the offer and answer with the endpoint:

A symmetric endpoint accepts and sends the same payload type.
An asymmetric endpoint can accept and send different payload types.

 

https://www.cisco.com/c/en/us/td/docs/ios/voice/cube/configuration/guide/vb_book/vb_book/vb_10022.html

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: