Showing results for 
Search instead for 
Did you mean: 

DTMF Problem


we have CUCM 11.5 and UCCX 11.6 and recently added new CUBE in our topology. Some of our incoming calls confront with DTMF problem. We have set DTMF command under our dial peer configuration, but still we have problem.

We have 2 SIP Trunks that one of them has connected to Mikrotik firewall and we just created a SIP trunk between CUCM and the SIP trunk. The other one is connected directly to the CUBE. When we checked calls from both  SIP trunk calls, we had DTMF problem. It seems that there is misconfiguration in CUCM. It is some thing wrong with my MTP configuration?  How can I understand that my MTP configuration is OK? Or is it some thing else that I should pay attention to?


8 Replies 8

Using the SIP trunk through the CUBE, during active call issue the commands

sh call active voice calling-number xxxxxx | i Dtmf
sh call active voice called-number xxxxxx | i Dtmf

Note that calling and called number should be as the cube sees them and you
can find them using the command 'show call active voice br' while the call
is active

Also, describe the call routing to be able to advise with this output.


Thank you for the consideration.

I set the command "show call active voice calling-number XXXXX | i Dtmf" that you said. DTMF won't work if the result of the command is like this:


and if the result is:


it will work properly.

I have set the command "dtmf-relay rtp-nte sip-notify sip-kpml sip-info" under my dial peer configurations.

How can I handle those calls that the DTMF relay is set sip-notify in order to work properly?

Cisco Employee
Cisco Employee


What dtmf you hardcoded in dialpeer. Also have you set any dtmf preference on cube. Is mtp checked on trunk? 


Try to add oob dtmf support for the dialpeer, if that doesn't work we need to check ccm logs to see the dtmf.




I have created voice class codec that contains g711ulaw, g711alaw, g722, g723 and g729 and set it for dial peer configurations. Also the command "dtmf-relay rtp-nte sip-notify sip-kpml sip-info" is set.

Yes, MTP is set for the trunk. I have executed the command " show call active voice calling-number XXXX | i Dtmf" and when the output is:


it doesn't work and if the result is:


it works.

1) Try to enforce Only Rtp-NTE in all dial-peers
2) Add the Transcoder resource in CUBE Itself, It will be used if there is any discrepancy in DTMF negotiated.

*** Please rate helpful post; Mark "Accept as a Solution" if applicable



The command "voice-class sip dtmf-relay force rtp-nte" does not work under dial peer configurations. I don't have DSP module in order to create transcoder on CUBE.

Hi, you should copy and paste this command. It's a hidden command.


Yes, You're right.

Actually my problem solved by setting rtp-nte under dial peer configuration and also changing DTMF mode in SIP Trunk configuration in CUCM from RFC2833 to No preference.

Thank You

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: