Showing results for 
Search instead for 
Did you mean: 

Exchange 2013 UM and CUCM 8.6 REFER message


I am running UCM 8.6.   I have Exchange 2013 UM working with diversions from UCM but not refers.  The issue is when I call I voicemail pilot number that points to a trunk that references my 2013 servers I am prompted by the UM auto attendant to enter in an extension.  Once I enter in the extension I hear half of a ring then UM plays "Sorry the person you are trying to reach doesn't have a valid voicemail box on our system.  Goodbye"

The traces reveal that the call is answered by one of 2013 UM servers where the auto attendant is played.  After the caller enters the extension Exchange does a lookup to determine where that extension's mailbox resides then sends a REFER message to UCM.  In the REFER message the actual REFER field shows the correct 2013 server but the CONTACT field (2013 address different than the REFER field) is where the call is being sent.

I have 1 2013 UM trunk that I point my VM route pattern to. 

That trunk has 5 2013 UM FQDNs listed in the destination addresses with destination port of 5060

I have 5 SIP Route Patterns for each of the 2013 UM servers that reference the UM trunk.


Checked: Media Termination Point Required

Checked: Redirecting Diversion Header Delivery - Inbound

Checked: Redirecting Diversion Header Delivery - Inbound

CSS is set: Rerouting Calling Search Space

CSS is set: Out-Of-Dialog Refer Calling Search Space

SIP Security Profile

Checked: Accept out-of-dialog refer**
Checked: Accept unsolicited notification
Checked: Accept replaces header

SIP Profile
Checked: Early Offer support for voice and video calls (insert MTP if needed)


What am I missing to get this working correctly?






5 Replies 5

George Thomas

I dont think the issue is with CUCM, i think its with Exchange. The fact that Exchange says the mailbox does not exist makes me think that way. The extension you are entering, does that exist in Exchange UM? Also, have you checked DTMF to make sure Exchange is getting the correct digits for the mailbox you are trying to transfer to?

Please rate useful posts.

When I call an extension and get redirected I am able to leave voicemail.  I have pointed my voicemail profile directly to the 2010 servers and the 2013 servers.  Both allow redirects.  The problem occurs only when a refer is being sent.  When I call a voicemail pilot number from an unrecognized number the exchange 2013 answers then sends the redirect.  At that time I run a wireshark on my 2010 UM exchange server but the call never reaches it.

Will you be able to post CUCM logs (set to detailed) here?

Please rate useful posts.



just want to check with you if you managed to fix the issue. we're also facing the same issue and it'd be great if you could share the fix or workaround if you have one for this issue.


Thanks in advance.

//Suresh Please rate all the useful posts.

We ran into this issue and it was due to the fact that the server in the refer was unreachable. This was because it was coming in this format REFER-TO: <;transport=Tcp>


In UCM (10.5) there is an Enterprise parameter for "URI Lookup Policy" and the default is Case Sensitive. Once I turned it to Case Insensitive it worked.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers