cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
676
Views
0
Helpful
7
Replies
cooperben
Beginner

External callers don't get MOH

MOH is working fine for internal calls, but external callers do not hear anything.  We run a single-site CMBE 6.1.5 with a 3825 IOS gateway.

Not sure if this is relevant, but I see in the 'Transcoder' section that the registration is in 'Rejected' status.  The IP address is correct and there are no ACLs on the gateway's interface blocking it.

And I see the following commands in the gateway's running config:

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP001FCABAXXXX

The MTP address is correct and matches the transcoder specified in the CM.

So I'm wondering where to begin troubleshooting this issue?  It appears that MOH is not able to make it to the gateway for external calls.  Currently, MOH is set to Unicast and to my knowledge, multicast has never been enabled.  MOH for external callers did work at one time, as I remember several callers complaining about the choice of music we selected, prompting a change.

Thanks in advance.  Any help is much appreciated.

2 ACCEPTED SOLUTIONS

Accepted Solutions
jaschulz
Beginner

Hello Cooper,

Defiently sounds like an issue with the GW. But without a packet capture to tell the audio stream is making it there we can't be certain. One quick thing you can try on the GW is 'no ip cef'...See if that fixes it.

View solution in original post

Ok, yeah I'm sure you probably need that

You are hitting bug CSCtl21854. You will need to upgrade the IOS on the GW. Likely to IOS 15.1(04)M.

View solution in original post

7 REPLIES 7
clileikis
Rising star

Hi Cooper,

As this is a single site, I'm assuming that you're only using G711 is that correct?  Also, have you restarted the IP Voice Media Streaming App service?

HTH,

Chris

Correct, only G711 is in use.

I have restarted the IPVMSA service but still have the problem.  I have yet to restart the entire system, which has been running continuously for ~7 months.

jaschulz
Beginner

Hello Cooper,

Defiently sounds like an issue with the GW. But without a packet capture to tell the audio stream is making it there we can't be certain. One quick thing you can try on the GW is 'no ip cef'...See if that fixes it.

View solution in original post

Issuing the 'no ip cef' command on the gateway fixed it!

So now, how to get it working along with CEF?  We have CEF in place for performance reasons, as this gateway is also routing and firewalling our IP traffic beesides being our gateway connected to 3 PRIs (why it's such a beefy model for our small size).

Ok, yeah I'm sure you probably need that

You are hitting bug CSCtl21854. You will need to upgrade the IOS on the GW. Likely to IOS 15.1(04)M.

View solution in original post

After referencing the article, I enabled Duplex Streaming and tested again and it works.  I will now monitor the performance impact, but the article said it shouldn't be much.

Thanks a lot for your assistance.

Yeah that works too.

You bet, glad I could help.

Content for Community-Ad

Spotlight Awards 2021