Showing results for 
Search instead for 
Did you mean: 

Community Helping Community


Failed CUC Subscriber Upgrade from 9.1.1-10000-11 to 11.5su2


In attempting to upgrade CUC from 9.1.1 to 11.5 su2. The CUC publisher upgrades ok and switches versions; however, the subscriber fails.

I have stuck to the giudlines in the upgrade and release notes, changed the adapter card type and RHL + added ciscocm.version3-keys.cop.sgn.

I have used a lab HP380G6 with ESXi ver 5.5 in order to trial this before I go ahead and upgrade a customers CUCM and CUC with the exact same versions as I am using in my lab. I just wanted to run through this to have confidence when I perform a production system upgrade.

I have attached an install/upgrade log.

Any help would be gratefully received. Many thanks, John.

Cisco Employee

The install fails during the

The install fails during the post install phase , most likely some entry in the database that is causing the upgrade failure

File:/opt/cisco/install/bin/component_install:821, Function: exec_progmeter(), /opt/cisco/install/bin/progmeter failed (1)|<LVL::Error>
05/24/2017 01:24:15|Internal Error, File:/usr/local/bin/base_scripts/, Function: refresh_upgrade(), failed to refresh_upgrade application components|<LVL::Critical>
05/24/2017 01:24:15 post_install|File:/opt/cisco/install/bin/post_install:1030, Function: install_applications(), /usr/local/bin/base_scripts/ -refresh-upgrade failed (1)|<LVL::Error>
05/24/2017 01:24:15 post_install|Exiting with result 1|<LVL::Info>
05/24/2017 01:24:15 post_install|INSTALL_TYPE="Refresh Upgrade"|<LVL::Debug>
05/24/2017 01:24:15 post_install|Process refresh upgrade failure|<LVL::Info>
05/24/2017 01:24:15 post_install|(CAPTURE) Mail notification cancelled - smtp server address for email not found! [/usr/local/platform/conf/platformConfig.xml]|<LVL::Debug>
05/24/2017 01:24:15 post_install

Oneof the bugs that relate to such failures is the following one



Many thanks for your reply

Many thanks for your reply Manish.

I had already tried with the ciscocm.cuc_11.5SU1_pre_upgrade.cop.sgn. cop file, I did not create any admin users and I went straight from a fresh install with nothing much in the database.


I have tried building 9.1.2

I have tried building 9.1.2 and then upgrading CUC Pub and Sub to 11.5su2 but get the same result - the pub upgrades ok but the sub upgrade fails. I have noticed the following in the logs

05/23/2017 23:02:41|The server model does not have IPMI or is not an IBM server.|<LVL::Info>

I am beginning to wonder if the upgrade failure is due to the fact that it is built through ESXi - VM on a HP dl380g6 server. Odd if it is though because I built CUCM Pub and Sub to 9.1.1 and then upgraded to 11.5 without any problems.

Cisco Employee

If it was hardware specific

If it was hardware specific it would have impacted the Publisher as well. Just try to make sure that the following points are followed:

Install the upgrade file on Pub, let it finish completely

Install the Upgrade file on the Sub, let it finish  completely

Switch version on the Publisher you can verify the output of 'utils upgrade status' and 'show cuc version' to ensure the upgrade has completed successfully on Pub

Then attempt the Switch version on Sub

One more thing that you can try is to use the DRS backup from the Production cluster and restore it on the lab cluster ( ensuring same IP, hostname, securityPassword, number of servers, DNS, NTP by building in an isolated network ) and attempt its upgrade to see if you run into any issues.



Finally found the cause of

Finally found the cause of the problem - it is a bug: CSCuo77634. The bug only pertains to PCD RU upgrades on CUC. 

No problem when using OS admin to upgrade the bug is only related to PCD. Frustrating because Cisco is encouraging to go the PCD route.

Hall of Fame Community Legend

Hi John,

Hi John,

Thanks for the kind follow-up to this thread (+5). Your info will likely help someone else somewhere down the road! Awesome!




For install failures, unless

For install failures, unless it is absolutely necessary, I prefer just doing a clean install. When you have a pub/sub to rely on it's relatively easy to rebuild and replicate. 

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here