cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1601
Views
0
Helpful
15
Replies

Fax Machine problem

muratg7777
Beginner
Beginner

Hi Folks;

We have UC520. On Fxs port - Fax Machine is connected.

We are faxing without problem. The problem is, when we fax it uses random analog liner.

We have 4 analog lines. I want to configure that on outgoing faxes, the fax machine shoud only use fxo port 0/1/0.

I have tried ro configure cor list but it did not worked.

How can I configure a fax machine to use only 1 analog line.  don't want to dedicate it to fax machine, on outgoing calls, all 4 analog line must in use

voice-port 0/0/0
cptone TR
description FAX
station-id name Fax Machine
station-id number 191
caller-id enable

voice-port 0/1/0
trunk-group ALL_FXO 64
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 191
description Configured by CCA FAX-Custom-OP
caller-id enable

1 Accepted Solution

Accepted Solutions

Remove all other dial-peers and use the configuration provided below.I have modified it.

voice-port 0/0/0
cptone TR
description FAX
station-id name Fax Machine
station-id number 191
caller-id enable

voice-port 0/1/0
trunk-group ALL_FXO 64
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 191
description Configured by CCA FAX-Custom-OP
caller-id enable


Dial-peer cor custom
  name fax


dial-peer cor list block-from-fax
member phones

dial-peer cor list fax-only
member fax


dial-peer voice 1 pots
description  ****To Fax MAchine***
destination-pattern 191
no digit-strip
port 0/0/0
forward-digits 0
no sip-register

dial-peer voice 58 pots
trunkgroup ALL_FXO
description ** Phone Zero Dialing***
preference 5
destination-pattern 90..........
forward-digits all
no sip-register
corlist outgoing block-from-fax
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
description ***Phone Local  dialing**
no translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
corlist outgoing block-from-fax


!
dial-peer voice 60 pots
description **Incoming Dial-peer from Fax***
answer-address 191
port 0/0/0
corlist incoming fax-only


dial-peer voice 61 pots
description *****Fax outgoing Local Calls***
preference 0
destination-pattern 9[2-9]......
port 0/1/0
forward-digits all
corlist outgoing fax-only
no sip-register

dial-peer voice 62 pots
description *****Fax outgoing Zero dialing Calls***
preference 0
destination-pattern 90..........
port 0/1/0
forward-digits all
corlist outgoing fax-only
no sip-register

HTH
Tom

View solution in original post

15 Replies 15

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Configured correctly, COR should work.

Otherwise, make a translation rule for preper some digits to numbers called from FXS port, have a dial-peer for these digits and the port you want.

Where will I assign the cor list.

I mean, I am creating new dial peer amd assigning corlist to it but the examples are for ephone-dn

I can not assign corlist to ports. Can you give example for it

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_configuration_example09186a008019d649.shtml

You assign cor-list to dial-peers, not ports.

Maybe the method with number manipulation it's easier for you.

I did that but it didn't work

Dial-peer cor custom
name ip
name fax

Dial-peer cor list ip
member ip

dial-peer cor list fax
member fax

dial-peer voice 58 pots
trunkgroup ALL_FXO
description **CCA*Generic Locale*Local Number**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 90..........
forward-digits all
no sip-register
corlist outgoing ip
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
description Lokal
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
corlist outgoing ip
!
dial-peer voice 60 pots
description Fax_ic
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
port 0/0/0
forward-digits all
no sip-register
corlist outgoing fax
!
dial-peer voice 61 pots
description Fax_ic
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 90..........
port 0/0/0
forward-digits all
no sip-register
corlist outgoing fax


I also tried corlist incoming and it did not work. Both ip phones and fax machine dials exactly the same
numbers so destination patterms are the same.

also I tried translation rule :

voice translation-profile Phone1
translate called 1

voice translation-rule 1
rule 1 /^9/ /5551111/

dial-peer voice 60 pots
translation-profile incoming Phone1
preference 5
destination-pattern 9[2-9]......
port 0/0/0
forward-digits all
no sip-register
!
dial-peer voice 61 pots
translation-profile incoming Phone1
preference 5
destination-pattern 90..........
port 0/0/0
forward-digits all
no sip-register

9 for picking up analog line and 5551111 is my fax number

HI ,

No need to put any translation rules for the fax issue.

Now the Idea is to associate your fxs port initated calls  with the corlist

create a specific dial-peer to match all you calls from fax machines using a dial-peer similar to following.

dial-peer voice 55 pots

answer-adress  7000     (I assume your fax machine internal extension as 7000)

port 0/2/0   (FXS port)

corlist  incoming fax

HTH

Tom

Hi Tom;

I tried you config but when I call external numbers, it calls to fax machine's extension.  It forwards all calls to fax machine.

I also bind cor list to all ephones

ephone-dn  67  dual-line
corlist outgoing ip

dial-peer voice 58 pots
trunkgroup ALL_FXO
corlist incoming fax
description **CCA*Generic Locale*Local Number**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 90..........
forward-digits all
no sip-register
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
corlist incoming fax
description Lokal
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 60 pots
corlist incoming ip
description Fax_external
preference 5
answer-address 191
destination-pattern 90..........
port 0/0/0
forward-digits all
no sip-register
!
dial-peer voice 61 pots
corlist incoming ip
description Fax_local
preference 5
answer-address 191
destination-pattern 9[2-9]......
port 0/0/0
forward-digits all
no sip-register

also tried

ephone-dn  67  dual-line
corlist incoming ip

and outgoing cor list on dial peer 58 and 59

Don't put corlist on ephone-dn, so they will be free to use any DP.

Put precedence 1 on the DP for the fax FXO, so the the ephones will not use it.

You only need a corlist, not two.

dial-peer voice 59 pots
trunkgroup ALL_FXO
description Lokal
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
!
!
dial-peer voice 61 pots
corlist incoming fax
description Fax_local
answer-address 191
destination-pattern 9[2-9]......
port 0/0/0
forward-digits 0
no sip-register

I removed preference value and ephones corlist, it fixes the problem but  still fax machine goes from random analog lines.

Now you need an incoming DP with the FXS port of the fax.

DP 61 needs no corlist, and the preferences reversed.

I already have DP for incoming

dial-peer voice 1 pots
description ** CCA Analog Fax **
destination-pattern 191
no digit-strip
port 0/0/0
forward-digits 0
no sip-register

I don't have problem with incoming faxes. Need to bind fax machine to , FXS 0/0/0 to FXO 0/1/0 for outgoing faxes

Could anyone can post a full config???

I almost tried everything and it is not working.

I want to do a simple thing.

Here is my latest config:

voice-port 0/0/0
cptone TR
description FAX
station-id name Fax Machine
station-id number 191
caller-id enable

voice-port 0/1/0
trunk-group ALL_FXO 64
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 191
description Configured by CCA FAX-Custom-OP
caller-id enable

dial-peer voice 1 pots
description ** CCA Analog Fax **
destination-pattern 191
no digit-strip
port 0/0/0
forward-digits 0
no sip-register

dial-peer voice 58 pots
trunkgroup ALL_FXO
description **CCA*Generic Locale*Local Number**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 90..........
forward-digits all
no sip-register
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
description Lokal
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 60 pots
description Fax_external
preference 10
answer-address 191
destination-pattern 90..........
port 0/0/0
forward-digits all
no sip-register
!
dial-peer voice 61 pots
description Fax_local
preference 10
answer-address 191
destination-pattern 9[2-9]......
port 0/0/0
forward-digits all
no sip-register

Is it a UAE Dialplan ?

No Turkey.

2-9 is for local calls


90 is for out of town.

Remove all other dial-peers and use the configuration provided below.I have modified it.

voice-port 0/0/0
cptone TR
description FAX
station-id name Fax Machine
station-id number 191
caller-id enable

voice-port 0/1/0
trunk-group ALL_FXO 64
cptone TR
timeouts call-disconnect 3
timeouts wait-release 3
connection plar opx 191
description Configured by CCA FAX-Custom-OP
caller-id enable


Dial-peer cor custom
  name fax


dial-peer cor list block-from-fax
member phones

dial-peer cor list fax-only
member fax


dial-peer voice 1 pots
description  ****To Fax MAchine***
destination-pattern 191
no digit-strip
port 0/0/0
forward-digits 0
no sip-register

dial-peer voice 58 pots
trunkgroup ALL_FXO
description ** Phone Zero Dialing***
preference 5
destination-pattern 90..........
forward-digits all
no sip-register
corlist outgoing block-from-fax
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
description ***Phone Local  dialing**
no translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]......
forward-digits all
no sip-register
corlist outgoing block-from-fax


!
dial-peer voice 60 pots
description **Incoming Dial-peer from Fax***
answer-address 191
port 0/0/0
corlist incoming fax-only


dial-peer voice 61 pots
description *****Fax outgoing Local Calls***
preference 0
destination-pattern 9[2-9]......
port 0/1/0
forward-digits all
corlist outgoing fax-only
no sip-register

dial-peer voice 62 pots
description *****Fax outgoing Zero dialing Calls***
preference 0
destination-pattern 90..........
port 0/1/0
forward-digits all
corlist outgoing fax-only
no sip-register

HTH
Tom

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers