Showing results for 
Search instead for 
Did you mean: 

Firmware upgrade failed Cisco 8945 SIP


I'm trying to upgrade the firmware of our 8945 SIP phones cause of a time display bug (bug CSCtl73175)

We are currently using the SIP 9-2-2-0 firmware.

I tried to put different firmwares with different results.

with version 9-3-4-17

[15:51:53, 10/23/2014] upgrade BOOT8941_8945.0-0-1-0.bin.sgn from
[15:51:58, 10/23/2014] upgrade BOOT8941_8945.0-0-1-0.bin.sgn success
[15:51:58, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin1.sgn from
[15:55:24, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin2.sgn from
[15:58:41, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin3.sgn from
[16:00:23, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin4.sgn from
[16:04:03, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin5.sgn from
[16:07:14, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin6.sgn from
[16:08:52, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin7.sgn from
[16:11:37, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin8.sgn from
[16:14:20, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin9.sgn from
[16:16:30, 10/23/2014] upgrade SIP8941_8945.9-3-4-17.bin9.sgn fail (read fail)
[16:48:31, 10/23/2014] trigger reset from tAKPL_AMMU (system up time : 2562932680 ticks, 59 days 7 hours 51 minutes 5 seconds)
[16:49:03, 10/23/2014] SEP580a20fb62a9 Get ip from DHCP server :
[16:49:06, 10/23/2014] Trust List updating

[16:49:06, 10/23/2014] Trust List updated fail


with version 9-4-1-8

[11:13:31, 10/24/2014] upgrade BOOT8941_8945.0-0-2-0.bin.sgn from
[11:13:37, 10/24/2014] upgrade BOOT8941_8945.0-0-2-0.bin.sgn success
[11:13:37, 10/24/2014] upgrade SIP8941_8945.9-4-1-8.bin1.sgn from
[11:14:46, 10/24/2014] upgrade SIP8941_8945.9-4-1-8.bin2.sgn from
[11:14:51, 10/24/2014] upgrade SIP8941_8945.9-4-1-8.bin2.sgn fail (read fail)


and with version 9-4-1-SR1

[11:16:22, 10/24/2014] upgrade SIP894x.9-4-1SR1-1.bin1.sgn from

[11:16:27, 10/24/2014] upgrade SIP894x.9-4-1SR1-1.bin1.sgn fail (read fail)


The worst is that with the latest version (the one I want to use : 9-4-2-8) it even doesn't try to upgrade the phone (nothing happen, so nothing on the log too...)


Any thoughts?


Thank you for your help

Everyone's tags (1)

The 8945s are a bit of a pain

The 8945s are a bit of a pain. Read the firmware release notes carefully, as you have to step through a couple of specific firmware versions.



Please rate all helpful posts.

HiYou need a step by step


You need a step by step upgrade. As the Release Notes mention:

Release 9.4(2) can only be upgraded from 9.3(4) and later. Releases prior to 9.3(4) have to be upgraded to 9.3(4) first

SIP 9.3(4) can be upgraded only from Release 9.3(1) and later. This limitation applies to SIP 9.3(4) only; SCCP 9.3(4) is not affected.

The Cisco IP Phone 8941 and 8945 support a new "secure by default" feature with this release. Before phones are upgraded to Firmware Release 9.3(1),
the Cisco Unified Communications Manager must have devpack 8.0.3(24049)/8.5.1(14070)/8.6.2(22030) or higher installed. The phones require this devpack.
If the correct devpack is not installed first, the phones cannot successfully register to the Cisco Unified Communications Manager.


So I guess you need to

1) install latest device pack for your CUCM

2) install firmware 9.3(1)

3) install firmware  9.3(4)

4) install latest 9.4 firmware

If you have all firmware versions already installed to you can try to load one by one using the "Phone Load Name" field at the device > phone  page.




Re: HiYou need a step by step

Hi Eike,


It did work for me.

I also had the same issue of "upgrade SIP8941_8945.9-3-4-17.bin9.sgn fail (read fail)". The existing firmware version was When i tried upgrading the firmware to 9-3-4-17, This error occurred.
I followed your suggestion, the phone firmware got upgraded. Thank you very much dude...!!


Hi, Check the upgrade path.



Check the upgrade path. as you may go to the desired firmware though couple of steps first

for example from version SCCP8941_8945.9-3-2-11 you need to go to SCCP8941_8945.9-3-4-17 and then SCCP8941_8945.9-4-2-8

check the firmware realse notes to check your path.



Regards, Mohamed Helmy
CreatePlease to create content