Showing results for 
Search instead for 
Did you mean: 

flashing 7940 phone

Hi all, I've read loads of posts about this but none that actually give me a solution. I'd really appreciate some expert advice! I have a cisco 7940 phone, I need to flash firmware to sip. The phone came with a strange firmware that renders all the keys locked. I can reset to factory defaults, but the settings button doesn't work at all. So I don't know what firmware it's running. I've connected it to tftp server with dhcp and it says 'tftp timeout' or sometimes 'tftp error'. I've tried a few sip firmware versions, all cause same error. Can anyone help me flash this crazy phone? Many thanks!

First add SCCP firmware and check that phone works

Then U can try to convert it to SIP

Right ok i'll try that. Which sccp firmware version should I try if I don't know the phone's current firmware? Cheers

Try this


I'm just getting the same error, 'TFTP Timeout' - whatever I do, even tried switching off the tftp server and i get the same error.  So I'm wondering if the phone is actually connecting to the tftp server properly.  It's getting an IP address correctly as it shows up in my dhcp clients.  I'm using Mac os x tftp server.  Any ideas?


Have U configured option 150 in DHCP settings?

I use tftp32 (freeware) on Windows PC which works excellent

I do have the dhcp option set in the bootpd.plist. This is what's written:

My tftp server shows no activity in the log, so not sure if the phone is actually getting that far.
It's so annoying that the settings button is locked, I could just set this stuff manually!!
Any ideas where to go next?  I do have a PC but I don't have a dhcp server for it so not sure how to get that working.

Try getting debugs from the switch, where the Phone is connected to

Just wondering if you could post the Switch Port Config from the switch where the IP Phone is connected.


The debug command for the debugs  would run are:

1. debug ip tftp events and packets

2. I would also want to check if the DHCP as well as TFTP packets are being sent out at all on to the VLAN




I'm not using a switch, I'm connecting the phone directly to my mac, using os x server's DHCP server (with option 150 added to the bootpd.plist) and running os x tftp server.

The phone is getting an IP address and I can ping it.  The tftp server doesn't show any log of incoming requests.  The phone just says 'Requesting Configuration' for a while then says 'TFTP Timeout'




Here is the thing, usually Cisco IP Phones depend on the CDP to get the correct VLAN (Voice VLAN) and then gets the IP Address and from there it goes on..

I wonder if there is any possibility at all for you to be able to use a switch?

Without this, its very difficult to see, what the Phone is sending and if there is any Err at all.

May be the Wireshark can help?


Basically I'm trying to flash it to SIP so I can use it in a standard network (not with cisco hardware).  I don't have a cisco router.  Is it theoretically possible to flash the phone with my setup?  I agree the inability to debug is very frustrating. you know why the settings button doesn't work on the phone?


Yes, it should be possible.

Try **#, and see if it unlocks anything at all?

My guess is, when the phone was previously connected to the CCM Server, it was in a "Locked Down" config mode, hence nothing is visible.

Secondly, if that is the case, the only option is to update it with a default config file (and getting the old config erased).


Can you install CCM Server (in a VMWare Wkstn) on your MAC? If yes, then, there would another challenge, how to get the phone be able to talk to the CCM Server on a VM Wkstn on your MAC.. and if that can be done, you should be good :-)



**# doesn't work.. but the factory defaults does work.  So it's been reset with the option to discard network settings.  So I assumed it would have defaulted to finding the tftp server on the dhcp and searching for firmware flash.. but it doesn't

I'll read your suggestion a few times and see if I can do that... I do have a PC too so might give that a go next.

Content for Community-Ad

Spotlight Awards 2021